Run of scrub-obsolete for libhash-util-fieldhash-compat-perl

Try this locally (using the lintian-brush package):

debcheckout libhash-util-fieldhash-compat-perl
cd libhash-util-fieldhash-compat-perl
deb-scrub-obsolete --update-changelog

Merge these changes:

Diff

diff --git a/debian/changelog b/debian/changelog
index f3697e9..49efd15 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,10 @@ libhash-util-fieldhash-compat-perl (0.11-2) UNRELEASED; urgency=medium
   [ gregor herrmann ]
   * debian/watch: use uscan version 4.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends-Indep: Drop versioned constraint on perl.
+
  -- gregor herrmann <gregoa@debian.org>  Sat, 20 Aug 2016 02:45:35 +0200
 
 libhash-util-fieldhash-compat-perl (0.11-1.1) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 8707716..c08a26c 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Priority: optional
 Build-Depends: debhelper-compat (= 12)
 Build-Depends-Indep: libtie-refhash-weak-perl,
                      perl,
-                     perl (>= 5.15.9) | libcpan-meta-requirements-perl
+                     perl | libcpan-meta-requirements-perl
 Standards-Version: 3.9.8
 Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/libhash-util-fieldhash-compat-perl
 Vcs-Git: https://salsa.debian.org/perl-team/modules/packages/libhash-util-fieldhash-compat-perl.git

Debdiff

File lists identical (after any substitutions)

No differences were encountered in the control files

Full worker log Full build log