Run of fresh-snapshots for libmldbm-perl

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
[2022-06-21 03:19:47] Opening branch at https://salsa.debian.org/perl-team/modules/packages/libmldbm-perl.git/,branch=master
[2022-06-21 03:19:48] Using cached branch https://janitor.debian.net/git/libmldbm-perl/,branch=debian%2Flatest
[2022-06-21 03:19:48] Using resume branch: https://janitor.debian.net/git/libmldbm-perl,branch=fresh-snapshots%2Fmain
[2022-06-21 03:19:50] (26/95)
[2022-06-21 03:19:50] Total 482 (delta 54), reused 0 (delta 0), pack-reused 384
[2022-06-21 03:19:51] Total 20 (delta 0), reused 20 (delta 0), pack-reused 0
[2022-06-21 03:19:51] Total 17 (delta 1), reused 0 (delta 0), pack-reused 0
[2022-06-21 03:19:51] All changes applied successfully.
[2022-06-21 03:19:52] Total 4 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-06-21 03:19:52] restarting branch
[2022-06-21 03:19:52] 0), pack-reused 0
[2022-06-21 03:19:52] All changes applied successfully.
[2022-06-21 03:19:52] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-06-21 03:19:52] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-06-21 03:19:52] Workspace ready - starting.
[2022-06-21 03:19:52] Running ['deb-new-upstream', '--snapshot', '--refresh-patches']
Using upstream branch https://github.com/chorny/MLDBM.git (from configuration)
Total 212 (delta 0), reused 0 (delta 0), pack-reused 212
last found upstream version 2.02 (2.02) is lower than previous packaged upstream version (2.05)
Using version string 2.05+git20150302.1.c5a24e7.
No upstream upstream-revision format specified, trying tag:2.05
No upstream upstream-revision format specified, trying tag:libmldbm-perl-2.05
No upstream upstream-revision format specified, trying tag:v2.05
No upstream upstream-revision format specified, trying tag:v.2.05
No upstream upstream-revision format specified, trying tag:release-2.05
No upstream upstream-revision format specified, trying tag:2_05_release
No upstream upstream-revision format specified, trying tag:2_05
No upstream upstream-revision format specified, trying tag:version-2.05
No upstream upstream-revision format specified, trying tag:libmldbm-perl-2_05-release
No upstream upstream-revision format specified, trying tag:libmldbm-perl-v2.05
Old upstream version '2.05' is not present in upstream branch <UpstreamBranchSource for 'https://github.com/chorny/MLDBM.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Looking for upstream 2.05+git20150302.1.c5a24e7 in upstream branch https://github.com/chorny/MLDBM.git/.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitori6bhrzj_/libmldbm-perl/debian
Opened schroot session unstable-amd64-sbuild-bcd0a5f0-4136-44fb-9545-c1c1ac93520f (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n               libmodule-build-perl', 'perl,\n                     libfreezethaw-perl']
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]
Running ['perl', 'Build.PL']
Running ['./Build', 'dist']
Found new tarball MLDBM-2.05.tar.gz in /var/run/schroot/mount/unstable-amd64-sbuild-bcd0a5f0-4136-44fb-9545-c1c1ac93520f/build/tmp7pbkuepu/libmldbm-perl.
Found tarball MLDBM-2.05.tar.gz in parent directory.
Searching for revision importing libmldbm-perl version 2.05 on branch upstream, packaging branch, tag debian/2.05-2.1, tag debian/2.05-1, tag debian/2.05-2, tag debian/2.05-3.
Upstream import of 2.05 lacks a tag. Set one by running: brz tag -rrevid:git-v1:3e5e0db5d391204cf9958e54bed4a07be08a95b9 upstream/2.05
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.05-2.1 points at non-present sha a65cd8a813e17b7d2f2b0c2db612e59f446cb39c
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.05-1 points at non-present sha 72bee5af7772000d78b2b1978f039a6341d6c988
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.05 points at non-present sha 0d5a66d613e6d6b3245c361c06b0fb8673475c42
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.05-2 points at non-present sha f1b1c96c76871218ae40d8deeb0835c4776c89af
  warnings.warn(
debian/2.05-2.1 does not point to a valid object
debian/2.05-1 does not point to a valid object
upstream/2.05 does not point to a valid object
debian/2.05-2 does not point to a valid object
Revision b'git-v1:18f454bace7847f4011ef843f4d1c6dc074873b9' exists in repository but not in upstream branch, ignoring
Imported libmldbm-perl_2.05+git20150302.1.c5a24e7.orig.tar.gz with pristine-tar.
All changes applied successfully.
Committing to: /tmp/janitori6bhrzj_/libmldbm-perl/
modified Build.PL
modified Changes
modified MANIFEST
modified META.json
modified META.yml
modified Makefile.PL
modified README
modified debian/changelog
modified lib/MLDBM.pm
modified lib/MLDBM/Serializer/Data/Dumper.pm
modified lib/MLDBM/Serializer/FreezeThaw.pm
modified lib/MLDBM/Serializer/Storable.pm
modified t/compare.t
modified t/dumper.t
modified t/freezethaw.t
Committed revision 71.
Merged new upstream version 2.05+git20150302.1.c5a24e7 (previous: 2.05)
Merge new upstream version 2.05+git20150302.1.c5a24e7
[2022-06-21 03:20:22] Actual command: ['deb-new-upstream', '--snapshot', '--refresh-patches']
[2022-06-21 03:20:28] Opened schroot session unstable-amd64-sbuild-6f1e0d2a-416e-488f-a944-5b6abb3150f7 (from unstable-amd64-sbuild)
[2022-06-21 03:20:28] Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), SimpleBuildFixer(DebcargoUnacceptablePredicate, debcargo_coerce_unacceptable_prerelease), SimpleBuildFixer(DebcargoUnacceptableComparator, debcargo_coerce_unacceptable_prerelease), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7f77d2a70e20>, [functools.partial(<function python_tie_breaker at 0x7f77d0ddcf70>, <GitWorkingTree of /tmp/janitori6bhrzj_/libmldbm-perl>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/unstable-amd64-sbuild-6f1e0d2a-416e-488f-a944-5b6abb3150f7'), <function popcon_tie_breaker at 0x7f77d0ddfa30>]))]
[2022-06-21 03:20:28] Building debian packages, running 'sbuild -A -s -v'.
[2022-06-21 03:22:16] Built ['libmldbm-perl_2.05+git20150302.1.c5a24e7-1~jan+nus2_amd64.changes'].
[2022-06-21 03:22:17] Running lintian
[2022-06-21 03:22:21] Pushing result branch to {'git': 'https://janitor.debian.net/git', 'bzr': 'https://janitor.debian.net/bzr'}
Traceback (most recent call last):
  File "/code/janitor/worker.py", line 1080, in run_worker
    raise _push_error_to_worker_failure(e)
  File "/code/janitor/worker.py", line 1068, in run_worker
    import_branches_git(
  File "/code/janitor/worker.py", line 582, in import_branches_git
    inter.fetch_refs(get_changed_refs, lossy=False, overwrite=True)
  File "/code/breezy/breezy/git/interrepo.py", line 812, in fetch_refs
    new_refs = self.target.send_pack(
  File "/code/breezy/breezy/git/remote.py", line 967, in send_pack
    return self.controldir.send_pack(get_changed_refs, generate_pack_data)
  File "/code/breezy/breezy/git/remote.py", line 502, in send_pack
    result = self._client.send_pack(
  File "/code/dulwich/dulwich/client.py", line 2043, in send_pack
    resp, read = self._smart_request(
  File "/code/dulwich/dulwich/client.py", line 1983, in _smart_request
    resp, read = self._http_request(url, headers, data)
  File "/code/breezy/breezy/git/remote.py", line 804, in _http_request
    response = self.transport.request(
  File "/code/breezy/breezy/transport/http/urllib.py", line 1844, in request
    response = self._opener.open(request)
  File "/usr/lib/python3.10/urllib/request.py", line 519, in open
    response = self._open(req, data)
  File "/usr/lib/python3.10/urllib/request.py", line 536, in _open
    result = self._call_chain(self.handle_open, protocol, protocol +
  File "/usr/lib/python3.10/urllib/request.py", line 496, in _call_chain
    result = func(*args)
  File "/code/breezy/breezy/transport/http/urllib.py", line 821, in https_open
    return self.do_open(HTTPSConnection, request)
  File "/code/breezy/breezy/transport/http/urllib.py", line 698, in do_open
    connection._send_request(method, url,
  File "/usr/lib/python3.10/http/client.py", line 1328, in _send_request
    self.endheaders(body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.10/http/client.py", line 1277, in endheaders
    self._send_output(message_body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.10/http/client.py", line 1076, in _send_output
    self.send(chunk)
  File "/usr/lib/python3.10/http/client.py", line 998, in send
    self.sock.sendall(data)
  File "/code/breezy/breezy/transport/http/urllib.py", line 149, in sendall
    self.sock.sendall(s, *args)
  File "/usr/lib/python3.10/ssl.py", line 1236, in sendall
    v = self.send(byte_view[count:])
  File "/usr/lib/python3.10/ssl.py", line 1205, in send
    return self._sslobj.write(data)
ssl.SSLEOFError: EOF occurred in violation of protocol (_ssl.c:2396)

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=update deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer pkg-perl-maintainers@lists.alioth.debian.org
  • ☒ change set 5ffcb332-dd7c-422e-b6c6-899342a69194 is working

Full worker log Full build log