Run of fresh-snapshots for libnet-sslglue-perl

Merge these changes:

git pull https://janitor.debian.net/git/libnet-sslglue-perl fresh-snapshots/main
git pull https://janitor.debian.net/git/libnet-sslglue-perl fresh-snapshots/pristine-tar
git pull https://janitor.debian.net/git/libnet-sslglue-perl fresh-snapshots/upstream

Summary

Merged new upstream version: 1.058+git20181118.1.7dab311 (was: 1.058).

Diff

Branch: main

diff --git a/META.json b/META.json
index a4eb2b8..1d3c272 100644
--- a/META.json
+++ b/META.json
@@ -4,13 +4,13 @@
       "unknown"
    ],
    "dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.0401, CPAN::Meta::Converter version 2.150001",
+   "generated_by" : "ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010",
    "license" : [
-      "unknown"
+      "perl_5"
    ],
    "meta-spec" : {
       "url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec",
-      "version" : "2"
+      "version" : 2
    },
    "name" : "Net-SSLGlue",
    "no_index" : {
@@ -42,5 +42,6 @@
          "url" : "https://github.com/noxxi/p5-net-sslglue"
       }
    },
-   "version" : "1.058"
+   "version" : "1.058",
+   "x_serialization_backend" : "JSON::PP version 4.06"
 }
diff --git a/META.yml b/META.yml
index 6ac8a9e..d8308ac 100644
--- a/META.yml
+++ b/META.yml
@@ -7,8 +7,8 @@ build_requires:
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.0401, CPAN::Meta::Converter version 2.150001'
-license: unknown
+generated_by: 'ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010'
+license: perl
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.4.html
   version: '1.4'
@@ -22,3 +22,4 @@ requires:
 resources:
   repository: https://github.com/noxxi/p5-net-sslglue
 version: '1.058'
+x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/Makefile.PL b/Makefile.PL
index 2ab35fc..6ea41c3 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -7,6 +7,7 @@ my $xt = prompt( "Should I do external tests?\n".
 WriteMakefile(
     NAME => 'Net::SSLGlue',
     VERSION_FROM => 'lib/Net/SSLGlue.pm',
+    LICENSE => 'perl_5',
     PREREQ_PM => {
 	'IO::Socket::SSL' => 1.19,
     },
diff --git a/debian/changelog b/debian/changelog
index 578398c..a011fc9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-libnet-sslglue-perl (1.058-2) UNRELEASED; urgency=medium
+libnet-sslglue-perl (1.058+git20181118.1.7dab311-1) UNRELEASED; urgency=medium
 
   [ gregor herrmann ]
   * debian/watch: use uscan version 4.
@@ -10,8 +10,10 @@ libnet-sslglue-perl (1.058-2) UNRELEASED; urgency=medium
     Repository-Browse.
   * Remove obsolete fields Contact, Name from debian/upstream/metadata
     (already present in machine-readable debian/copyright).
+  * New upstream snapshot.
+  * Drop patch spelling-error-in-manpage.patch, present upstream.
 
- -- gregor herrmann <gregoa@debian.org>  Sat, 22 Feb 2020 16:43:03 +0100
+ -- gregor herrmann <gregoa@debian.org>  Fri, 01 Apr 2022 01:36:43 -0000
 
 libnet-sslglue-perl (1.058-1) unstable; urgency=medium
 
diff --git a/debian/patches/series b/debian/patches/series
index f7c4b35..e69de29 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1 +0,0 @@
-spelling-error-in-manpage.patch
diff --git a/debian/patches/spelling-error-in-manpage.patch b/debian/patches/spelling-error-in-manpage.patch
deleted file mode 100644
index 2b257b5..0000000
--- a/debian/patches/spelling-error-in-manpage.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-Description: Fix spelling errors in manpage
-Origin: vendor
-Author: Salvatore Bonaccorso <carnil@debian.org>
-Reviewed-by: gregor herrmann <gregoa@debian.org>
-Last-Update: 2018-04-10
-Forwarded: https://rt.cpan.org/Ticket/Display.html?id=125065
-Bug: https://rt.cpan.org/Ticket/Display.html?id=125065
-Applied-Upstream: 938a3c6
-
---- a/lib/Net/SSLGlue/Socket.pm
-+++ b/lib/Net/SSLGlue/Socket.pm
-@@ -204,7 +204,7 @@ extended:
- =item new
- 
- The method C<new> of L<Net::SSLGlue::Socket> can have the argument SSL. If this
--is true the SSL upgrade will be done immediatly. If not set any SSL_* args will
-+is true the SSL upgrade will be done immediately. If not set any SSL_* args will
- still be saved and used at a later start_SSL call.
- 
- =item start_SSL
-@@ -229,7 +229,7 @@ C<select> to check the socket, but for S
- pending data before trying a select.
- Because SSL needs to read the whole frame before decryption can be done, a
- successful return of can_read is no guarantee that data can be read
--immediatly, only that new data are either available or in the process of
-+immediately, only that new data are either available or in the process of
- arriving.
- 
- =back
diff --git a/lib/Net/SSLGlue/LWP.pm b/lib/Net/SSLGlue/LWP.pm
index 5fa3d58..1492141 100644
--- a/lib/Net/SSLGlue/LWP.pm
+++ b/lib/Net/SSLGlue/LWP.pm
@@ -161,7 +161,7 @@ if (!$use_existent) {
 Net::SSLGlue::LWP - proper certificate checking for https in LWP
 
 =head1 SYNOPSIS
-u
+
     use Net::SSLGlue::LWP SSL_ca_path => ...;
     use LWP::Simple;
     get( 'https://www....' );
diff --git a/lib/Net/SSLGlue/Socket.pm b/lib/Net/SSLGlue/Socket.pm
index 0b27c15..7c3e6e4 100644
--- a/lib/Net/SSLGlue/Socket.pm
+++ b/lib/Net/SSLGlue/Socket.pm
@@ -204,7 +204,7 @@ extended:
 =item new
 
 The method C<new> of L<Net::SSLGlue::Socket> can have the argument SSL. If this
-is true the SSL upgrade will be done immediatly. If not set any SSL_* args will
+is true the SSL upgrade will be done immediately. If not set any SSL_* args will
 still be saved and used at a later start_SSL call.
 
 =item start_SSL
@@ -229,7 +229,7 @@ C<select> to check the socket, but for SSL it will check if there are any
 pending data before trying a select.
 Because SSL needs to read the whole frame before decryption can be done, a
 successful return of can_read is no guarantee that data can be read
-immediatly, only that new data are either available or in the process of
+immediately, only that new data are either available or in the process of
 arriving.
 
 =back

Branch: pristine-tar

diff --git a/libnet-sslglue-perl_1.058+git20181118.1.7dab311.orig.tar.gz.delta b/libnet-sslglue-perl_1.058+git20181118.1.7dab311.orig.tar.gz.delta
new file mode 100644
index 0000000..8fe5d75
Binary files /dev/null and b/libnet-sslglue-perl_1.058+git20181118.1.7dab311.orig.tar.gz.delta differ
diff --git a/libnet-sslglue-perl_1.058+git20181118.1.7dab311.orig.tar.gz.id b/libnet-sslglue-perl_1.058+git20181118.1.7dab311.orig.tar.gz.id
new file mode 100644
index 0000000..bce9506
--- /dev/null
+++ b/libnet-sslglue-perl_1.058+git20181118.1.7dab311.orig.tar.gz.id
@@ -0,0 +1 @@
+0881cf34a725ae4ad977c3d2714696692ac83b09

Branch: upstream

Tag: upstream/1.058+git20181118.1.7dab311
diff --git a/META.json b/META.json
index a4eb2b8..1d3c272 100644
--- a/META.json
+++ b/META.json
@@ -4,13 +4,13 @@
       "unknown"
    ],
    "dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.0401, CPAN::Meta::Converter version 2.150001",
+   "generated_by" : "ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010",
    "license" : [
-      "unknown"
+      "perl_5"
    ],
    "meta-spec" : {
       "url" : "http://search.cpan.org/perldoc?CPAN::Meta::Spec",
-      "version" : "2"
+      "version" : 2
    },
    "name" : "Net-SSLGlue",
    "no_index" : {
@@ -42,5 +42,6 @@
          "url" : "https://github.com/noxxi/p5-net-sslglue"
       }
    },
-   "version" : "1.058"
+   "version" : "1.058",
+   "x_serialization_backend" : "JSON::PP version 4.06"
 }
diff --git a/META.yml b/META.yml
index 6ac8a9e..d8308ac 100644
--- a/META.yml
+++ b/META.yml
@@ -7,8 +7,8 @@ build_requires:
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.0401, CPAN::Meta::Converter version 2.150001'
-license: unknown
+generated_by: 'ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010'
+license: perl
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.4.html
   version: '1.4'
@@ -22,3 +22,4 @@ requires:
 resources:
   repository: https://github.com/noxxi/p5-net-sslglue
 version: '1.058'
+x_serialization_backend: 'CPAN::Meta::YAML version 0.018'
diff --git a/Makefile.PL b/Makefile.PL
index 2ab35fc..6ea41c3 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -7,6 +7,7 @@ my $xt = prompt( "Should I do external tests?\n".
 WriteMakefile(
     NAME => 'Net::SSLGlue',
     VERSION_FROM => 'lib/Net/SSLGlue.pm',
+    LICENSE => 'perl_5',
     PREREQ_PM => {
 	'IO::Socket::SSL' => 1.19,
     },
diff --git a/lib/Net/SSLGlue/LWP.pm b/lib/Net/SSLGlue/LWP.pm
index 5fa3d58..1492141 100644
--- a/lib/Net/SSLGlue/LWP.pm
+++ b/lib/Net/SSLGlue/LWP.pm
@@ -161,7 +161,7 @@ if (!$use_existent) {
 Net::SSLGlue::LWP - proper certificate checking for https in LWP
 
 =head1 SYNOPSIS
-u
+
     use Net::SSLGlue::LWP SSL_ca_path => ...;
     use LWP::Simple;
     get( 'https://www....' );
diff --git a/lib/Net/SSLGlue/Socket.pm b/lib/Net/SSLGlue/Socket.pm
index 0b27c15..7c3e6e4 100644
--- a/lib/Net/SSLGlue/Socket.pm
+++ b/lib/Net/SSLGlue/Socket.pm
@@ -204,7 +204,7 @@ extended:
 =item new
 
 The method C<new> of L<Net::SSLGlue::Socket> can have the argument SSL. If this
-is true the SSL upgrade will be done immediatly. If not set any SSL_* args will
+is true the SSL upgrade will be done immediately. If not set any SSL_* args will
 still be saved and used at a later start_SSL call.
 
 =item start_SSL
@@ -229,7 +229,7 @@ C<select> to check the socket, but for SSL it will check if there are any
 pending data before trying a select.
 Because SSL needs to read the whole frame before decryption can be done, a
 successful return of can_read is no guarantee that data can be read
-immediatly, only that new data are either available or in the process of
+immediately, only that new data are either available or in the process of
 arriving.
 
 =back

Publish Blockers

  • ☑ run was successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=update deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer pkg-perl-maintainers@lists.alioth.debian.org
  • ☑ change set 5b1d0b6d-ff7b-414a-bd69-6590232a187a is ready

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots libnet-sslglue-perl

Lintian Result

Full worker log Full build log