Run of lintian-fixes for libnet-whois-ip-perl

Try this locally (using the lintian-brush package):

debcheckout libnet-whois-ip-perl
cd libnet-whois-ip-perl
lintian-brush

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index e9827d6..21a4ab3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,12 @@ libnet-whois-ip-perl (1.19-3) UNRELEASED; urgency=medium
   [ gregor herrmann ]
   * debian/watch: use uscan version 4.
 
+  [ Debian Janitor ]
+  * Bump debhelper from old 10 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Remove obsolete field Name from debian/upstream/metadata (already present in
+    machine-readable debian/copyright).
+
  -- Salvatore Bonaccorso <carnil@debian.org>  Sun, 25 Feb 2018 15:12:45 +0100
 
 libnet-whois-ip-perl (1.19-2) unstable; urgency=medium
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index f599e28..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-10
diff --git a/debian/control b/debian/control
index 13ec692..d3902ed 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: perl
 Priority: optional
 Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
 Uploaders: Axel Beckert <abe@debian.org>
-Build-Depends: debhelper (>= 10)
+Build-Depends: debhelper-compat (= 12)
 Build-Depends-Indep: libregexp-ipv6-perl (>= 0.02),
                      perl
 Standards-Version: 3.9.8
diff --git a/debian/upstream/metadata b/debian/upstream/metadata
index b483a9a..6d20286 100644
--- a/debian/upstream/metadata
+++ b/debian/upstream/metadata
@@ -1,4 +1,3 @@
 ---
 Archive: CPAN
 Contact: unknown
-Name: Net-Whois-IP

Publish History

  • 2020-06-27T15:11: Successfully pushed (Success)

Full worker log Full build log