Run of fresh-snapshots for libpdf-builder-perl

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
[2022-09-13 20:07:23] Opening branch at https://salsa.debian.org/perl-team/modules/packages/libpdf-builder-perl.git/,branch=master
[2022-09-13 20:07:24] Using cached branch https://janitor.debian.net/git/libpdf-builder-perl/,branch=debian%2Flatest
[2022-09-13 20:07:24] Using resume branch: https://janitor.debian.net/git/libpdf-builder-perl,branch=fresh-snapshots%2Fmain
[2022-09-13 20:07:50] All changes applied successfully.
[2022-09-13 20:07:51] 
Compressing objects:   2% (1/48)
Compressing objects:   4% (2/48)
Compressing objects:   6% (3/48)
Compressing objects:   8% (4
[2022-09-13 20:07:51] 
[2022-09-13 20:07:51] Total 253 (delta 202), reused 253 (delta 202), pack-reused 0
[2022-09-13 20:07:52] restarting branch
[2022-09-13 20:07:52] (28/48)
[2022-09-13 20:07:52] Total 253 (delta 202), reused 253 (delta 202), pack-reused 0
[2022-09-13 20:07:53] archive/debian/3.019-3 does not point to a valid object
[2022-09-13 20:07:53] archive/debian/3.020-1 does not point to a valid object
[2022-09-13 20:07:53] archive/debian/3.021-1 does not point to a valid object
[2022-09-13 20:07:53] archive/debian/3.021-2 does not point to a valid object
[2022-09-13 20:07:53] archive/debian/3.024-1 does not point to a valid object
[2022-09-13 20:07:53] debian/3.023-2 does not point to a valid object
[2022-09-13 20:07:53] upstream/3.024 does not point to a valid object
[2022-09-13 20:08:21] All changes applied successfully.
[2022-09-13 20:08:21] Total 4 (delta 0), reused 4 (delta 0), pack-reused 0
[2022-09-13 20:08:21] archive/debian/3.019-3 does not point to a valid object
[2022-09-13 20:08:21] archive/debian/3.020-1 does not point to a valid object
[2022-09-13 20:08:21] archive/debian/3.021-1 does not point to a valid object
[2022-09-13 20:08:21] archive/debian/3.021-2 does not point to a valid object
[2022-09-13 20:08:21] archive/debian/3.024-1 does not point to a valid object
[2022-09-13 20:08:21] debian/3.023-2 does not point to a valid object
[2022-09-13 20:08:21] upstream/3.024 does not point to a valid object
[2022-09-13 20:08:22]  (427/427), done.
[2022-09-13 20:08:22] (55/66)
[2022-09-13 20:08:22] Total 219 (delta 177), reused 191 (delta 150), pack-reused 0
[2022-09-13 20:08:23] archive/debian/3.019-3 does not point to a valid object
[2022-09-13 20:08:23] archive/debian/3.020-1 does not point to a valid object
[2022-09-13 20:08:23] archive/debian/3.021-1 does not point to a valid object
[2022-09-13 20:08:23] archive/debian/3.021-2 does not point to a valid object
[2022-09-13 20:08:23] archive/debian/3.024-1 does not point to a valid object
[2022-09-13 20:08:23] debian/3.023-2 does not point to a valid object
[2022-09-13 20:08:23] Workspace ready - starting.
[2022-09-13 20:08:23] Running ['deb-new-upstream', '--snapshot', '--refresh-patches']
Using upstream branch https://github.com/PhilterPaper/Perl-PDF-Builder.git (from configuration)
Total 4083 (delta 103), reused 154 (delta 72), pack-reused 3808
Using version string 3.024+git20220913.1.a841841.
No upstream upstream-revision format specified, trying tag:3.024
No upstream upstream-revision format specified, trying tag:libpdf-builder-perl-3.024
No upstream upstream-revision format specified, trying tag:v3.024
No upstream upstream-revision format specified, trying tag:v.3.024
No upstream upstream-revision format specified, trying tag:release-3.024
No upstream upstream-revision format specified, trying tag:3_024_release
No upstream upstream-revision format specified, trying tag:3_024
No upstream upstream-revision format specified, trying tag:version-3.024
No upstream upstream-revision format specified, trying tag:libpdf-builder-perl-3_024-release
No upstream upstream-revision format specified, trying tag:libpdf-builder-perl-v3.024
Old upstream version '3.024' is not present in upstream branch <UpstreamBranchSource for 'https://github.com/PhilterPaper/Perl-PDF-Builder.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Looking for upstream 3.024+git20220913.1.a841841 in upstream branch https://github.com/PhilterPaper/Perl-PDF-Builder.git/.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitor9y5rex8k/libpdf-builder-perl/debian
Opened schroot session unstable-amd64-sbuild-903f0906-4d81-4e7a-9e19-692ddb15567d (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13)', 'fonts-dejavu-core <!nocheck>,\n                     ghostscript <!nocheck>,\n                     imagemagick <!nocheck>,\n                     libfont-ttf-perl <!nocheck>,\n                     libgd-perl <!nocheck>,\n                     libgraphics-tiff-perl (>= 19) <!nocheck>,\n                     libimage-png-libpng-perl <!nocheck>,\n                     libio-compress-perl <!nocheck>,\n                     libtest-exception-perl <!nocheck>,\n                     libtest-memory-cycle-perl <!nocheck>,\n                     perl']
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]
Running ['perl', 'Makefile.PL']
Running ['make', 'dist']
Found new tarball PDF-Builder-3.024.tar.gz in /var/run/schroot/mount/unstable-amd64-sbuild-903f0906-4d81-4e7a-9e19-692ddb15567d/build/tmp8hg161rb/libpdf-builder-perl.
Found tarball PDF-Builder-3.024.tar.gz in parent directory.
Searching for revision importing libpdf-builder-perl version 3.024 on branch upstream, packaging branch, tag debian/3.024-1.
Upstream import of 3.024 lacks a tag. Set one by running: brz tag -rrevid:git-v1:20607450736f97c7ebc46dc474a1322d4e3191a2 upstream/3.024
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.019-3 points at non-present sha d1c30624a299e730684bdc1b661bfb261f5590e6
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.024-1 points at non-present sha a68c7600bad726ceef08f3362499fd88cb377ac9
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/3.020 points at non-present sha 97c5d9aed2ba1145eb2ed687e7773d49e106d146
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.021-2 points at non-present sha 041aff6645fb2f94a657896fb7a63bd735644ee2
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.021-1 points at non-present sha d34a6670cf6bbe6af33a0200f5f1bbaec32aced1
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/3.023 points at non-present sha 64a8a4c8ba53fbab3a8390cd4f84ba03f82ebbb9
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.019-4 points at non-present sha 8edf06994f609353c79d0c25c42caf2e770d8227
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/3.024 points at non-present sha b4e15cb931733a0b769020364e18e504162d8dd4
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/3.021 points at non-present sha 388a0ed02db24eb7f45440a8a00bc02020d10b9a
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.020-1 points at non-present sha 043ff8dd1a521bfddb30c9214502faa4ea8aaeca
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/archive/debian/3.019-2 points at non-present sha d4138af3c4fab8eb33a060f6555d13284b1018c2
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.019-2 points at non-present sha d22afef21b5319b190d73dd8c69c5ac0b16d49b8
  warnings.warn(
debian/3.019-3 does not point to a valid object
debian/3.024-1 does not point to a valid object
upstream/3.020 does not point to a valid object
debian/3.021-2 does not point to a valid object
debian/3.021-1 does not point to a valid object
upstream/3.023 does not point to a valid object
debian/3.019-4 does not point to a valid object
upstream/3.024 does not point to a valid object
upstream/3.021 does not point to a valid object
debian/3.020-1 does not point to a valid object
archive/debian/3.019-2 does not point to a valid object
debian/3.019-2 does not point to a valid object
Imported libpdf-builder-perl_3.024+git20220913.1.a841841.orig.tar.gz with pristine-tar.
Traceback (most recent call last):
  File "/code/breezy-debian/scripts/deb-new-upstream", line 1354, in main
    result = merge_upstream(
  File "/code/breezy-debian/scripts/deb-new-upstream", line 1041, in merge_upstream
    conflicts, imported_revids = do_merge(
  File "/code/breezy-debian/merge_upstream.py", line 173, in do_merge
    return db.merge_upstream(
  File "/code/breezy-debian/import_dsc.py", line 1346, in merge_upstream
    conflicts = self.tree.merge_from_branch(
  File "/code/breezy/breezy/workingtree.py", line 701, in merge_from_branch
    conflicts = merger.do_merge()
  File "/code/breezy/breezy/merge.py", line 671, in do_merge
    merge = self._do_merge_to()
  File "/code/breezy/breezy/merge.py", line 634, in _do_merge_to
    merge.do_merge()
  File "/code/breezy/breezy/merge.py", line 775, in do_merge
    self._compute_transform()
  File "/code/breezy/breezy/merge.py", line 825, in _compute_transform
    self._finish_computing_transform()
  File "/code/breezy/breezy/merge.py", line 833, in _finish_computing_transform
    fs_conflicts = transform.resolve_conflicts(
  File "/code/breezy/breezy/transform.py", line 903, in resolve_conflicts
    raise MalformedTransform(conflicts=conflicts)
breezy.transform.MalformedTransform: Tree transform is malformed [('unversioned executability', 'new-555')]
Malformed tree transform during new upstream merge

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=update deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer pkg-perl-maintainers@lists.alioth.debian.org
  • ☒ change set 9bc0e8bd-a284-4603-9132-13403a50f564 is working

Full worker log