Run of lintian-fixes for libpod-abstract-perl

Try this locally (using the lintian-brush package):

debcheckout libpod-abstract-perl
cd libpod-abstract-perl
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/libpod-abstract-perl lintian-fixes/main

Summary

Diff

=== modified file 'debian/changelog'
--- a/debian/changelog	2018-07-08 09:23:47 +0000
+++ b/debian/changelog	2019-12-14 07:14:36 +0000
@@ -1,3 +1,13 @@
+libpod-abstract-perl (0.20-3) UNRELEASED; urgency=medium
+
+  * Set upstream metadata fields: Contact, Name.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Remove obsolete fields Contact, Name from debian/upstream/metadata
+    (already present in machine-readable debian/copyright).
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 08 Jul 2019 19:45:44 +0000
+
 libpod-abstract-perl (0.20-2) unstable; urgency=medium
 
   * Team upload

=== removed file 'debian/compat'
--- a/debian/compat	2018-07-08 09:22:55 +0000
+++ b/debian/compat	1970-01-01 00:00:00 +0000
@@ -1,1 +0,0 @@
-11

=== modified file 'debian/control'
--- a/debian/control	2018-07-08 09:23:32 +0000
+++ b/debian/control	2019-12-14 07:14:01 +0000
@@ -4,7 +4,7 @@
 Section: perl
 Testsuite: autopkgtest-pkg-perl
 Priority: optional
-Build-Depends: debhelper (>= 11)
+Build-Depends: debhelper-compat (= 12)
 Build-Depends-Indep: perl,
                      libio-string-perl
 Standards-Version: 4.1.5

Publish History

Full build log Full worker log