Run of scrub-obsolete for librecommended-perl

Try this locally (using the lintian-brush package):

debcheckout librecommended-perl
cd librecommended-perl
deb-scrub-obsolete --update-changelog

Merge these changes:

Diff

diff --git a/debian/changelog b/debian/changelog
index ac4bd9b..22feb42 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -18,6 +18,10 @@ librecommended-perl (0.003-2) UNRELEASED; urgency=medium
   * Set upstream metadata fields: Bug-Submit.
   * Remove obsolete fields Contact, Name from debian/upstream/metadata
     (already present in machine-readable debian/copyright).
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends-Indep: Drop versioned constraint on libmodule-runtime-perl.
+    + librecommended-perl: Drop versioned constraint on libmodule-runtime-perl
+      in Depends.
 
  -- Salvatore Bonaccorso <carnil@debian.org>  Sat, 30 Jan 2016 20:06:19 +0100
 
diff --git a/debian/control b/debian/control
index 8dedae8..71cb788 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
 Maintainer: Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
 Uploaders: Axel Beckert <abe@debian.org>
 Build-Depends: debhelper-compat (= 12)
-Build-Depends-Indep: libmodule-runtime-perl (>= 0.014),
+Build-Depends-Indep: libmodule-runtime-perl,
                      perl
 Standards-Version: 3.9.6
 Vcs-Browser: https://salsa.debian.org/perl-team/modules/packages/librecommended-perl
@@ -14,7 +14,7 @@ Testsuite: autopkgtest-pkg-perl
 
 Package: librecommended-perl
 Architecture: all
-Depends: libmodule-runtime-perl (>= 0.014),
+Depends: libmodule-runtime-perl,
          ${misc:Depends},
          ${perl:Depends}
 Description: Load recommended Perl modules on demand when available

Publish History

  • 2021-02-28T00:21: Successfully pushed (Success)

Full worker log Full build log