Run of fresh-snapshots for libterm-extendedcolor-perl

Merge these changes:

Summary

Merged new upstream version: 0.504+git20220402.1.db58063 (was: 0.504).

Diff

Branch: main

diff --git a/META.json b/META.json
index 10892d5..0f00e11 100644
--- a/META.json
+++ b/META.json
@@ -4,7 +4,7 @@
       "Magnus Woldrich <m@japh.se>"
    ],
    "dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 2.150010",
+   "generated_by" : "ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010",
    "license" : [
       "perl_5"
    ],
@@ -32,7 +32,7 @@
       },
       "runtime" : {
          "requires" : {
-            "perl" : "5.01"
+            "perl" : "5.010"
          }
       }
    },
@@ -50,5 +50,5 @@
       }
    },
    "version" : "0.504",
-   "x_serialization_backend" : "JSON::PP version 2.97001"
+   "x_serialization_backend" : "JSON::PP version 4.06"
 }
diff --git a/META.yml b/META.yml
index bf16369..4e7be4a 100644
--- a/META.yml
+++ b/META.yml
@@ -7,7 +7,7 @@ build_requires:
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 2.150010'
+generated_by: 'ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010'
 license: perl
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -18,7 +18,7 @@ no_index:
     - t
     - inc
 requires:
-  perl: '5.01'
+  perl: '5.010'
 resources:
   bugtracker: https://github.com/trapd00r/Term-ExtendedColor/issues
   homepage: http://japh.se/
diff --git a/debian/changelog b/debian/changelog
index a0f3408..c6464cd 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+libterm-extendedcolor-perl (0.504+git20220402.1.db58063-1) UNRELEASED; urgency=low
+
+  * New upstream snapshot.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Fri, 09 Sep 2022 20:24:44 -0000
+
 libterm-extendedcolor-perl (0.504-1) unstable; urgency=medium
 
   * Import upstream version 0.504.
diff --git a/debian/patches/create-manpages.patch b/debian/patches/create-manpages.patch
index 9a7f13f..d3b760d 100644
--- a/debian/patches/create-manpages.patch
+++ b/debian/patches/create-manpages.patch
@@ -4,9 +4,11 @@ Forwarded: not-needed
 Author: gregor herrmann <gregoa@debian.org>
 Last-Update: 2019-11-23
 
---- a/Makefile.PL
-+++ b/Makefile.PL
-@@ -30,7 +30,6 @@
+Index: libterm-extendedcolor-perl/Makefile.PL
+===================================================================
+--- libterm-extendedcolor-perl.orig/Makefile.PL
++++ libterm-extendedcolor-perl/Makefile.PL
+@@ -30,7 +30,6 @@ WriteMakefile1(
    EXE_FILES        => [ glob('bin/*') ],
    PREREQ_PM        => { },
    MIN_PERL_VERSION => 5.010,

Branch: pristine-tar

diff --git a/libterm-extendedcolor-perl_0.504+git20220402.1.db58063.orig.tar.gz.delta b/libterm-extendedcolor-perl_0.504+git20220402.1.db58063.orig.tar.gz.delta
new file mode 100644
index 0000000..edbf0f5
Binary files /dev/null and b/libterm-extendedcolor-perl_0.504+git20220402.1.db58063.orig.tar.gz.delta differ
diff --git a/libterm-extendedcolor-perl_0.504+git20220402.1.db58063.orig.tar.gz.id b/libterm-extendedcolor-perl_0.504+git20220402.1.db58063.orig.tar.gz.id
new file mode 100644
index 0000000..49ddca9
--- /dev/null
+++ b/libterm-extendedcolor-perl_0.504+git20220402.1.db58063.orig.tar.gz.id
@@ -0,0 +1 @@
+00a08f35126c1bff7b98099dd9718e5b72b3fe7d

Branch: upstream

Tag: upstream/0.504+git20220402.1.db58063
diff --git a/META.json b/META.json
index 10892d5..0f00e11 100644
--- a/META.json
+++ b/META.json
@@ -4,7 +4,7 @@
       "Magnus Woldrich <m@japh.se>"
    ],
    "dynamic_config" : 1,
-   "generated_by" : "ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 2.150010",
+   "generated_by" : "ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010",
    "license" : [
       "perl_5"
    ],
@@ -32,7 +32,7 @@
       },
       "runtime" : {
          "requires" : {
-            "perl" : "5.01"
+            "perl" : "5.010"
          }
       }
    },
@@ -50,5 +50,5 @@
       }
    },
    "version" : "0.504",
-   "x_serialization_backend" : "JSON::PP version 2.97001"
+   "x_serialization_backend" : "JSON::PP version 4.06"
 }
diff --git a/META.yml b/META.yml
index bf16369..4e7be4a 100644
--- a/META.yml
+++ b/META.yml
@@ -7,7 +7,7 @@ build_requires:
 configure_requires:
   ExtUtils::MakeMaker: '0'
 dynamic_config: 1
-generated_by: 'ExtUtils::MakeMaker version 7.34, CPAN::Meta::Converter version 2.150010'
+generated_by: 'ExtUtils::MakeMaker version 7.62, CPAN::Meta::Converter version 2.150010'
 license: perl
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.4.html
@@ -18,7 +18,7 @@ no_index:
     - t
     - inc
 requires:
-  perl: '5.01'
+  perl: '5.010'
 resources:
   bugtracker: https://github.com/trapd00r/Term-ExtendedColor/issues
   homepage: http://japh.se/

Publish Blockers

  • ☑ run was successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=update deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 549, max open: 300)
  • ☑ change set 6bedf9b9-f11f-4354-834d-230332f9d794 is ready

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots libterm-extendedcolor-perl

Lintian Result

Full worker log Full build log