Run of fresh-snapshots for libtext-recordparser-perl

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
[2022-09-09 23:00:13] Opening branch at https://salsa.debian.org/perl-team/modules/packages/libtext-recordparser-perl.git/,branch=master
[2022-09-09 23:00:14] Using cached branch https://janitor.debian.net/git/libtext-recordparser-perl/,branch=debian%2Flatest
[2022-09-09 23:00:14] Using resume branch: https://janitor.debian.net/git/libtext-recordparser-perl,branch=fresh-snapshots%2Fmain
[2022-09-09 23:00:19] All changes applied successfully.
[2022-09-09 23:00:19] Total 8 (delta 3), reused 0 (delta 0), pack-reused 0
[2022-09-09 23:00:19] restarting branch
[2022-09-09 23:00:19] Total 8 (delta 3), reused 0 (delta 0), pack-reused 0
[2022-09-09 23:00:19] 
[2022-09-09 23:00:20] All changes applied successfully.
[2022-09-09 23:00:20] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-09-09 23:00:20] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-09-09 23:00:20] Workspace ready - starting.
[2022-09-09 23:00:20] Running ['deb-new-upstream', '--snapshot', '--refresh-patches']
Using upstream branch https://github.com/kyclark/text-recordparser.git (from configuration)
Using version string 1.6.5+git20150421.1.22bd3a3.
No upstream upstream-revision format specified, trying tag:1.6.5
No upstream upstream-revision format specified, trying tag:libtext-recordparser-perl-1.6.5
No upstream upstream-revision format specified, trying tag:v1.6.5
No upstream upstream-revision format specified, trying tag:v.1.6.5
No upstream upstream-revision format specified, trying tag:release-1.6.5
No upstream upstream-revision format specified, trying tag:1_6_5_release
No upstream upstream-revision format specified, trying tag:1_6_5
No upstream upstream-revision format specified, trying tag:version-1.6.5
No upstream upstream-revision format specified, trying tag:libtext-recordparser-perl-1_6_5-release
No upstream upstream-revision format specified, trying tag:libtext-recordparser-perl-v1.6.5
Old upstream version '1.6.5' is not present in upstream branch <UpstreamBranchSource for 'https://github.com/kyclark/text-recordparser.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Looking for upstream 1.6.5+git20150421.1.22bd3a3 in upstream branch https://github.com/kyclark/text-recordparser.git/.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitordn4tw6_v/libtext-recordparser-perl/debian
Opened schroot session unstable-amd64-sbuild-9dfc3eac-ae4c-4f58-981a-e3fb61e318b4 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n               libmodule-install-perl', 'libclass-accessor-perl <!nocheck>,\n                     libgraphviz-perl <!nocheck>,\n                     libio-stringy-perl <!nocheck>,\n                     liblist-moreutils-perl <!nocheck>,\n                     libreadonly-perl <!nocheck>,\n                     libtest-exception-perl <!nocheck>,\n                     libtest-pod-coverage-perl <!nocheck>,\n                     libtest-pod-perl <!nocheck>,\n                     libtext-autoformat-perl <!nocheck>,\n                     libtext-tabulardisplay-perl <!nocheck>,\n                     perl']
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]
Running ['perl', 'Makefile.PL']
Running ['make', 'dist']
Found new tarball Text-RecordParser-1.6.5.tar.gz in /var/run/schroot/mount/unstable-amd64-sbuild-9dfc3eac-ae4c-4f58-981a-e3fb61e318b4/build/tmptrtdb442/libtext-recordparser-perl.
Found tarball Text-RecordParser-1.6.5.tar.gz in parent directory.
Searching for revision importing libtext-recordparser-perl version 1.6.5 on branch upstream, packaging branch, tag debian/1.6.5-3, tag debian/1.6.5-2, tag debian/1.6.5-1.
Upstream import of 1.6.5 lacks a tag. Set one by running: brz tag -rrevid:git-v1:e3c2bdcc3b7644e3e0ff738f45224d370e0b7419 upstream/1.6.5
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.6.1-1 points at non-present sha 353571367e5605a5c57177e2eca72f77e8dfe469
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.6.3 points at non-present sha e329b149e8308353aa8b0ada047f2998288b64a4
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.6.1 points at non-present sha c58eecf71c496b4916effabee65d7877a190957c
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.6.5-2 points at non-present sha 0a9cc8fe9c0e71104542799819fd1c96f6f2197b
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.6.3-1 points at non-present sha c4652c29c0779e861c33877e5375cb84df5b524e
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.6.5-1 points at non-present sha fbf218deacd5ea7d921142e3f4e642b6f351c0d4
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.6.5 points at non-present sha 51b440fcff0b363cdc5f26705949d80060eb0958
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/archive/debian/1.6.5-2 points at non-present sha 17038baf26d60056c30f797cbe6fe4b707f72244
  warnings.warn(
debian/1.6.1-1 does not point to a valid object
upstream/1.6.3 does not point to a valid object
upstream/1.6.1 does not point to a valid object
debian/1.6.5-2 does not point to a valid object
debian/1.6.3-1 does not point to a valid object
debian/1.6.5-1 does not point to a valid object
upstream/1.6.5 does not point to a valid object
archive/debian/1.6.5-2 does not point to a valid object
Imported libtext-recordparser-perl_1.6.5+git20150421.1.22bd3a3.orig.tar.gz with pristine-tar.
All changes applied successfully.
Committing to: /tmp/janitordn4tw6_v/libtext-recordparser-perl/
modified META.yml
modified debian/changelog
modified inc/Module/Install.pm
modified inc/Module/Install/Base.pm
modified inc/Module/Install/Can.pm
modified inc/Module/Install/Fetch.pm
modified inc/Module/Install/Makefile.pm
modified inc/Module/Install/Metadata.pm
modified inc/Module/Install/Scripts.pm
modified inc/Module/Install/Win32.pm
modified inc/Module/Install/WriteAll.pm
Committed revision 90.
Merged new upstream version 1.6.5+git20150421.1.22bd3a3 (previous: 1.6.5)
Merge new upstream version 1.6.5+git20150421.1.22bd3a3
[2022-09-09 23:00:57] Actual command: ['deb-new-upstream', '--snapshot', '--refresh-patches']
[2022-09-09 23:01:10] Opened schroot session unstable-amd64-sbuild-a565a9a3-d174-4157-8a79-936f902e82b7 (from unstable-amd64-sbuild)
[2022-09-09 23:01:10] Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), SimpleBuildFixer(DebcargoUnacceptablePredicate, debcargo_coerce_unacceptable_prerelease), SimpleBuildFixer(DebcargoUnacceptableComparator, debcargo_coerce_unacceptable_prerelease), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7fcde0c88550>, [functools.partial(<function python_tie_breaker at 0x7fcddbe12b00>, <GitWorkingTree of /tmp/janitordn4tw6_v/libtext-recordparser-perl>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/unstable-amd64-sbuild-a565a9a3-d174-4157-8a79-936f902e82b7'), <function popcon_tie_breaker at 0x7fcddbe1d240>]))]
[2022-09-09 23:01:10] Building debian packages, running 'sbuild -A -s -v'.
[2022-09-09 23:03:01] Built ['libtext-recordparser-perl_1.6.5+git20150421.1.22bd3a3+ds-1~jan+nus2_amd64.changes'].
[2022-09-09 23:03:02] Running lintian
[2022-09-09 23:03:09] Pushing result branch to 'https://janitor.debian.net/git/libtext-recordparser-perl'

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=update deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer pkg-perl-maintainers@lists.alioth.debian.org
  • ☒ change set adca72e1-0620-4965-84d5-0955b6c7b858 is working

Full worker log Full build log