Run of fresh-snapshots for libtk-fontdialog-perl

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
[2022-06-16 20:32:17] Opening branch at https://salsa.debian.org/perl-team/modules/packages/libtk-fontdialog-perl.git/,branch=master
[2022-06-16 20:32:18] Using cached branch https://janitor.debian.net/git/libtk-fontdialog-perl/,branch=debian%2Flatest
[2022-06-16 20:32:18] Using resume branch: https://janitor.debian.net/git/libtk-fontdialog-perl,branch=fresh-snapshots%2Fmain
[2022-06-16 20:32:20] (58/78)
[2022-06-16 20:32:20] Total 527 (delta 55), reused 5 (delta 5), pack-reused 442
[2022-06-16 20:32:21] Total 4 (delta 0), reused 4 (delta 0), pack-reused 0
[2022-06-16 20:32:21] 
[2022-06-16 20:32:21] (19/21)
[2022-06-16 20:32:21] All changes applied successfully.
[2022-06-16 20:32:22] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-06-16 20:32:22] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-06-16 20:32:22] Workspace ready - starting.
[2022-06-16 20:32:22] Running ['deb-new-upstream', '--snapshot', '--refresh-patches']
Using upstream branch https://github.com/eserte/tk-fontdialog.git (from configuration)
Total 344 (delta 0), reused 1 (delta 0), pack-reused 341
last found upstream version 0.18 (0.18) is lower than previous packaged upstream version (0.18+git20210808.2.9f548b5)
Using version string 0.18+git20210808.3.9f548b5.
No upstream upstream-revision format specified, trying git:9f548b5
Not including upstream history, since previous upstream version (0.18+git20210808.2.9f548b5) is not present in packaging branch history.
Looking for upstream 0.18+git20210808.3.9f548b5 in upstream branch https://github.com/eserte/tk-fontdialog.git/.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitor2th_a6ds/libtk-fontdialog-perl/debian
Opened schroot session unstable-amd64-sbuild-d67fe66c-3917-4e23-a289-321b032618f9 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n               xauth,\n               xvfb', 'perl,\n                     perl-tk']
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]
Running ['perl', 'Makefile.PL']
Running ['make', 'dist']
Found new tarball Tk-FontDialog-0.18.tar.gz in /var/run/schroot/mount/unstable-amd64-sbuild-d67fe66c-3917-4e23-a289-321b032618f9/build/tmp76n1p5ib/libtk-fontdialog-perl.
Found tarball Tk-FontDialog-0.18.tar.gz in parent directory.
Imported libtk-fontdialog-perl_0.18+git20210808.3.9f548b5.orig.tar.gz with pristine-tar.
All changes applied successfully.
Committing to: /tmp/janitor2th_a6ds/libtk-fontdialog-perl/
modified debian/changelog
Committed revision 26.
Merged new upstream version 0.18+git20210808.3.9f548b5 (previous: 0.18+git20210808.2.9f548b5)
Refresh quilt patches.
Committing to: /tmp/janitor2th_a6ds/libtk-fontdialog-perl/
Merge new upstream version 0.18+git20210808.3.9f548b5
[2022-06-16 20:32:53] Actual command: ['deb-new-upstream', '--snapshot', '--refresh-patches']
[2022-06-16 20:32:59] Opened schroot session unstable-amd64-sbuild-9fed5fc9-8f95-4be3-99f8-ffbe70a85b92 (from unstable-amd64-sbuild)
[2022-06-16 20:32:59] Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), SimpleBuildFixer(DebcargoUnacceptablePredicate, debcargo_coerce_unacceptable_prerelease), SimpleBuildFixer(DebcargoUnacceptableComparator, debcargo_coerce_unacceptable_prerelease), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7fd27b21f310>, [functools.partial(<function python_tie_breaker at 0x7fd2796f9120>, <GitWorkingTree of /tmp/janitor2th_a6ds/libtk-fontdialog-perl>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/unstable-amd64-sbuild-9fed5fc9-8f95-4be3-99f8-ffbe70a85b92'), <function popcon_tie_breaker at 0x7fd2796fbac0>]))]
[2022-06-16 20:32:59] Building debian packages, running 'sbuild -A -s -v'.
[2022-06-16 20:34:53] Built ['libtk-fontdialog-perl_0.18+git20210808.3.9f548b5-1~jan+nus1_amd64.changes'].
[2022-06-16 20:34:54] Running lintian
[2022-06-16 20:34:59] Pushing result branch to {'git': 'https://janitor.debian.net/git', 'bzr': 'https://janitor.debian.net/bzr'}

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=update deb-new-upstream --snapshot --refresh-patches to DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 1416, max open: 300)
  • ☒ change set 20310129-d68c-43f6-82da-33ec6b56b30d is working

Full worker log Full build log