Run of lintian-fixes for maven-ant-helper

Try this locally (using the lintian-brush package):

debcheckout maven-ant-helper
cd maven-ant-helper
lintian-brush --exclude=upstream-metadata-file

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 881c70c..159ef60 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+maven-ant-helper (8.6) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Change priority extra to priority optional.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Fri, 05 Jun 2020 12:57:02 -0000
+
 maven-ant-helper (8.5) unstable; urgency=medium
 
   * Team upload.
@@ -157,7 +166,7 @@ maven-ant-helper (7.1) experimental; urgency=low
 
 maven-ant-helper (7.0) experimental; urgency=low
 
-  * Update Standards-Version to 3.9.1, use source format 3.0 (native)  
+  * Update Standards-Version to 3.9.1, use source format 3.0 (native)
   * Use default-jdk-doc instead of openjdk-6-doc when linking
     Javadoc files (Closes: #587361)
   * d/control: add Suggests: default-jdk-doc, move all Recommends: to Suggest
@@ -173,7 +182,7 @@ maven-ant-helper (7.0) experimental; urgency=low
     the local repository, for consuption by other parts of the build,
     deprecate passing the 'version' variable to Ant as it's read from the POM file,
     remove macro prepare-package-list, update paths to the JDK docs.
- 
+
  -- Ludovic Claude <ludovic.claude@laposte.net>  Thu, 14 Oct 2010 00:08:38 +0200
 
 maven-ant-helper (6.8) unstable; urgency=low
@@ -219,7 +228,7 @@ maven-ant-helper (6.3) experimental; urgency=low
   * Add more Suggest: packages (libmaven-plugin-plugin-java and
     libplexus-components-metadata-java as they provide useful
     Maven plugin often used in the build)
-  * Add support for linking generated Javadoc to other 
+  * Add support for linking generated Javadoc to other
     documented libraries.
 
  -- Ludovic Claude <ludovic.claude@laposte.net>  Thu, 16 Jul 2009 22:34:35 +0100
@@ -251,7 +260,7 @@ maven-ant-helper (5) unstable; urgency=low
   * Add myself to uploaders
   * Add a Build-Depends-Indep dependency on ${misc:Depends}
   * Fix ModelloTask to work with modello >= 1.0, add new properties
-    useJava5 and encoding. 
+    useJava5 and encoding.
   * maven-build.xml: add build.javaVersion property to allow
     building Java 1.5 sources with this script, defaults to 1.4,
     fix javadoc target to use any packages under the current sources
@@ -289,7 +298,7 @@ maven-ant-helper (3) unstable; urgency=low
 maven-ant-helper (2) unstable; urgency=low
 
   * Initial public release (Closes: #428643)
-  
+
   * Changes following review by Michael Koch:
     - Copyright file changed to follow dh_make's format.
     - Version number changed to single integer.
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index 38066b7..13052fb 100644
--- a/debian/control
+++ b/debian/control
@@ -1,6 +1,6 @@
 Source: maven-ant-helper
 Section: java
-Priority: extra
+Priority: optional
 Maintainer: Debian Java Maintainers <pkg-java-maintainers@lists.alioth.debian.org>
 Uploaders:
  Torsten Werner <twerner@debian.org>,
@@ -9,7 +9,7 @@ Build-Depends:
  ant,
  ant-contrib,
  ant-optional,
- debhelper (>= 11),
+ debhelper-compat (= 12),
  default-jdk
 Standards-Version: 4.1.4
 Vcs-Git: https://salsa.debian.org/java-team/maven-ant-helper.git

Full worker log Full build log