Run of fresh-snapshots for merkaartor

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
[2022-06-17 15:49:31] Opening branch at https://salsa.debian.org/debian-gis-team/merkaartor.git/,branch=master
[2022-06-17 15:49:32] Using cached branch https://janitor.debian.net/git/merkaartor/,branch=debian%2Flatest
[2022-06-17 15:49:32] Using resume branch: https://janitor.debian.net/git/merkaartor,branch=fresh-snapshots%2Fmain
[2022-06-17 15:49:39] 
[2022-06-17 15:49:59] Total 32972 (delta 2832), reused 30081 (delta 0), pack-reused 0
[2022-06-17 15:49:59] 
[2022-06-17 15:51:04] Total 27 (delta 23), reused 1 (delta 0), pack-reused 0
[2022-06-17 15:51:07] All changes applied successfully.
[2022-06-17 15:51:09] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-06-17 15:51:09] Workspace ready - starting.
[2022-06-17 15:51:09] Running ['deb-new-upstream', '--snapshot', '--refresh-patches']
Using upstream branch https://github.com/openstreetmap/merkaartor.git (from configuration)
5% (61/242)
Total 4167 (delta 1877), reused 2092 (delta 1867), pack-reused 2046
last found upstream version 0.19.0 (0.19.0) is lower than previous packaged upstream version (0.19.0+git20220115.1.0ec4e27)
Using version string 0.19.0+git20220115.2.0ec4e27.
No upstream upstream-revision format specified, trying git:0ec4e27
Not including upstream history, since previous upstream version (0.19.0+git20220115.1.0ec4e27) is not present in packaging branch history.
Looking for upstream 0.19.0+git20220115.2.0ec4e27 in upstream branch https://github.com/openstreetmap/merkaartor.git/.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitorv3kh4zdn/merkaartor/debian
Opened schroot session unstable-amd64-sbuild-f2b96f37-6a64-4cf0-96c6-971f8630ca43 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n               libboost-dev,\n               libboost-math-dev,\n               libboost-serialization-dev,\n               libexiv2-dev,\n               libgdal-dev,\n               libgps-dev,\n               libproj-dev,\n               libproxy-dev,\n               libqt5svg5-dev,\n               libquazip5-dev,\n               libspatialite-dev,\n               libxml2-dev,\n               libxslt1-dev,\n               pkg-config,\n               qt5-qmake,\n               qt5-qmake:native,\n               qtbase5-dev,\n               qttools5-dev-tools,\n               qtwebengine5-dev [amd64 arm64 armhf i386 mipsel],\n               sharutils,\n               zlib1g-dev']
Ignoring error installing declared build dependencies (apt-file-fetch-failure): Apt file fetch error: 404  Not Found [IP: 146.75.94.132 80]
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.15 points at non-present sha dc34037eb9adb9a9d6a8e6d052987704f9dc78f5
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.18.0 points at non-present sha 46f798c121ed4a3e671740e23505665b3e805019
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.16.3 points at non-present sha 7a31eea87d4a1087ec057fdd24642e1fde81afa3
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.16.1 points at non-present sha 741e822302cc765c08de3aaf6d425b1ba8d7b7e6
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.17.2 points at non-present sha 6a21d6956b788f8ab427b324e241b707a7781db6
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.18.1 points at non-present sha 5344cecd056d1d77db6cefdb235d137f8bc4e539
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.17.1 points at non-present sha cd96b10cf9f76655f9d6cc20c10f0ea25a2c343e
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.14 points at non-present sha 9861d7bffaa7e44a0263080f1b9ea57cd5caaf55
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/0.16.2 points at non-present sha 0c45a673167877c46ba6c787134153d1884d4f4e
  warnings.warn(
0.15 does not point to a valid object
0.18.0 does not point to a valid object
0.16.3 does not point to a valid object
0.16.1 does not point to a valid object
0.17.2 does not point to a valid object
0.18.1 does not point to a valid object
0.17.1 does not point to a valid object
0.14 does not point to a valid object
0.16.2 does not point to a valid object
Not storing pristine-tar metadata, since there is no pristine-tar branch.
All changes applied successfully.
Committing to: /tmp/janitorv3kh4zdn/merkaartor/
modified debian/changelog
Committed revision 316.
Merged new upstream version 0.19.0+git20220115.2.0ec4e27 (previous: 0.19.0+git20220115.1.0ec4e27)
Refresh quilt patches.
Committing to: /tmp/janitorv3kh4zdn/merkaartor/
Merge new upstream version 0.19.0+git20220115.2.0ec4e27
[2022-06-17 15:53:03] Actual command: ['deb-new-upstream', '--snapshot', '--refresh-patches']
[2022-06-17 15:53:12] Opened schroot session unstable-amd64-sbuild-bb8c9572-91a3-436d-8c88-62ffb41677d6 (from unstable-amd64-sbuild)
[2022-06-17 15:53:13] Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), SimpleBuildFixer(DebcargoUnacceptablePredicate, debcargo_coerce_unacceptable_prerelease), SimpleBuildFixer(DebcargoUnacceptableComparator, debcargo_coerce_unacceptable_prerelease), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7fd242abf370>, [functools.partial(<function python_tie_breaker at 0x7fd242ae88b0>, <GitWorkingTree of /tmp/janitorv3kh4zdn/merkaartor>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/unstable-amd64-sbuild-bb8c9572-91a3-436d-8c88-62ffb41677d6'), <function popcon_tie_breaker at 0x7fd242aeb250>]))]
[2022-06-17 15:53:13] Building debian packages, running 'sbuild -A -s -v'.
[2022-06-17 16:22:53] Built ['merkaartor_0.19.0+git20220115.2.0ec4e27-1~jan+nus1_amd64.changes'].
[2022-06-17 16:22:54] Running lintian
[2022-06-17 16:23:29] Pushing result branch to {'git': 'https://janitor.debian.net/git', 'bzr': 'https://janitor.debian.net/bzr'}
Traceback (most recent call last):
  File "/code/janitor/worker.py", line 1080, in run_worker
    raise _push_error_to_worker_failure(e)
  File "/code/janitor/worker.py", line 1068, in run_worker
    import_branches_git(
  File "/code/janitor/worker.py", line 582, in import_branches_git
    inter.fetch_refs(get_changed_refs, lossy=False, overwrite=True)
  File "/code/breezy/breezy/git/interrepo.py", line 812, in fetch_refs
    new_refs = self.target.send_pack(
  File "/code/breezy/breezy/git/remote.py", line 967, in send_pack
    return self.controldir.send_pack(get_changed_refs, generate_pack_data)
  File "/code/breezy/breezy/git/remote.py", line 502, in send_pack
    result = self._client.send_pack(
  File "/code/dulwich/dulwich/client.py", line 2043, in send_pack
    resp, read = self._smart_request(
  File "/code/dulwich/dulwich/client.py", line 1983, in _smart_request
    resp, read = self._http_request(url, headers, data)
  File "/code/breezy/breezy/git/remote.py", line 804, in _http_request
    response = self.transport.request(
  File "/code/breezy/breezy/transport/http/urllib.py", line 1844, in request
    response = self._opener.open(request)
  File "/usr/lib/python3.10/urllib/request.py", line 519, in open
    response = self._open(req, data)
  File "/usr/lib/python3.10/urllib/request.py", line 536, in _open
    result = self._call_chain(self.handle_open, protocol, protocol +
  File "/usr/lib/python3.10/urllib/request.py", line 496, in _call_chain
    result = func(*args)
  File "/code/breezy/breezy/transport/http/urllib.py", line 821, in https_open
    return self.do_open(HTTPSConnection, request)
  File "/code/breezy/breezy/transport/http/urllib.py", line 698, in do_open
    connection._send_request(method, url,
  File "/usr/lib/python3.10/http/client.py", line 1328, in _send_request
    self.endheaders(body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.10/http/client.py", line 1277, in endheaders
    self._send_output(message_body, encode_chunked=encode_chunked)
  File "/usr/lib/python3.10/http/client.py", line 1076, in _send_output
    self.send(chunk)
  File "/usr/lib/python3.10/http/client.py", line 998, in send
    self.sock.sendall(data)
  File "/code/breezy/breezy/transport/http/urllib.py", line 149, in sendall
    self.sock.sendall(s, *args)
  File "/usr/lib/python3.10/ssl.py", line 1236, in sendall
    v = self.send(byte_view[count:])
  File "/usr/lib/python3.10/ssl.py", line 1205, in send
    return self._sslobj.write(data)
ssl.SSLEOFError: EOF occurred in violation of protocol (_ssl.c:2396)

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches to DEB_COMPAT_RELEASE=ubuntu/esm DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☑ review not required
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 1258, max open: 200)
  • ☒ change set 7956a0fe-d2cd-4573-addc-ee940f36d208 is working

Full worker log Full build log