Run of fresh-snapshots for nco

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
Using upstream branch https://github.com/nco/nco.git (from configuration)
Total 111673 (delta 3931), reused 4504 (delta 3687), pack-reused 106924
Using version string 5.1.0+git20220715.1.934a947.
No upstream upstream-revision format specified, trying tag:5.1.0
Not including upstream history, since previous upstream version (5.1.0) is not present in packaging branch history.
Adding DFSG suffix since upstream files are excluded: 5.1.0+git20220715.1.934a947+ds
Looking for upstream 5.1.0+git20220715.1.934a947+ds in upstream branch https://github.com/nco/nco.git/.
No upstream upstream-revision format specified, trying git:934a947
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python310.zip:/usr/lib/python3.10:/usr/lib/python3.10/lib-dynload:/usr/local/lib/python3.10/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitor5uqulsll/nco/debian
Opened schroot session unstable-amd64-sbuild-e4468753-8b3f-4afb-8a51-e384e71ec8f7 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 12),\n               bison,\n               flex,\n               antlr,\n               libantlr-dev,\n               gsl-bin,\n               libgsl-dev,\n               netcdf-bin,\n               libnetcdf-dev,\n               libudunits2-dev,\n               libdap-dev,\n               texinfo']
Creating directory /root in schroot session.
Using dependency resolver: [apt, cpan, ctan, pypi, npm, go, hackage, cran, bioconductor, octave-forge]
Imported nco_5.1.0+git20220715.1.934a947+ds.orig.tar.gz with pristine-tar.
dpkg-mergechangelogs: warning: /tmp/tmp4flfgxxzdeb_changelog_merge/changelog.base(l323): uses full 'April' instead of abbreviated month name 'Apr'
LINE:  -- Charlie Zender <zender@uci.edu>  Thu, 02 April 2014 12:25:00 -0700
dpkg-mergechangelogs: warning: /tmp/tmp4flfgxxzdeb_changelog_merge/changelog.base(l323): cannot parse non-conformant date '02 April 2014 12:25:00 -0700'
LINE:  -- Charlie Zender <zender@uci.edu>  Thu, 02 April 2014 12:25:00 -0700
dpkg-mergechangelogs: warning: /tmp/tmp4flfgxxzdeb_changelog_merge/changelog.other(l329): uses full 'April' instead of abbreviated month name 'Apr'
LINE:  -- Charlie Zender <zender@uci.edu>  Thu, 02 April 2014 12:25:00 -0700
dpkg-mergechangelogs: warning: /tmp/tmp4flfgxxzdeb_changelog_merge/changelog.other(l329): cannot parse non-conformant date '02 April 2014 12:25:00 -0700'
LINE:  -- Charlie Zender <zender@uci.edu>  Thu, 02 April 2014 12:25:00 -0700

All changes applied successfully.
Unexpected line while looking for start of change data: <<<<<<<
Unexpected line while looking for more change data or trailer: =======
Unexpected line while looking for more change data or trailer: >>>>>>>
Unexpected line while looking for start of change data: <<<<<<<
Unexpected line while looking for more change data or trailer: =======
Unexpected line while looking for more change data or trailer: >>>>>>>
Committing to: /tmp/janitor5uqulsll/nco/
modified bld/nco.spec
modified bld/nco_dst.pl
modified configure
modified configure.ac
modified configure.eg
modified debian/changelog
modified doc/ANNOUNCE
modified doc/ChangeLog
modified doc/VERSION
modified doc/debian.txt
modified doc/index.shtml
modified doc/nco.texi
modified src/nco/ncks.c
modified src/nco/nco.h
modified src/nco/nco_cnk.c
modified src/nco/nco_fl_utl.c
modified src/nco/nco_fl_utl.h
modified src/nco/nco_flt.c
modified src/nco/nco_flt.h
modified src/nco/nco_netcdf.c
modified src/nco/nco_netcdf.h
modified src/nco/nco_prn.c
modified src/nco/nco_scm.c
Committed revision 324.
Merged new upstream version 5.1.0+git20220715.1.934a947+ds (previous: 5.1.0)
Merge new upstream version 5.1.0+git20220715.1.934a947+ds
Traceback (most recent call last):
  File "/code/breezy/breezy/git/remote.py", line 511, in send_pack
    result = self._client.send_pack(
  File "/code/dulwich/dulwich/client.py", line 2048, in send_pack
    ref_status = self._handle_receive_pack_tail(
  File "/code/dulwich/dulwich/client.py", line 925, in _handle_receive_pack_tail
    _read_side_band64k_data(proto.read_pkt_seq(), channel_callbacks)
  File "/code/dulwich/dulwich/client.py", line 496, in _read_side_band64k_data
    for pkt in pkt_seq:
  File "/code/dulwich/dulwich/protocol.py", line 287, in read_pkt_seq
    pkt = self.read_pkt_line()
  File "/code/dulwich/dulwich/protocol.py", line 232, in read_pkt_line
    raise HangupException()
dulwich.errors.HangupException: The remote server unexpectedly closed the connection.

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/code/janitor/worker.py", line 1079, in run_worker
    raise _push_error_to_worker_failure(e)
  File "/code/janitor/worker.py", line 1067, in run_worker
    import_branches_git(
  File "/code/janitor/worker.py", line 582, in import_branches_git
    inter.fetch_refs(get_changed_refs, lossy=False, overwrite=True)
  File "/code/breezy/breezy/git/interrepo.py", line 812, in fetch_refs
    new_refs = self.target.send_pack(
  File "/code/breezy/breezy/git/remote.py", line 968, in send_pack
    return self.controldir.send_pack(get_changed_refs, generate_pack_data)
  File "/code/breezy/breezy/git/remote.py", line 524, in send_pack
    raise parse_git_hangup(self.transport.external_url(), e)
breezy.errors.ConnectionReset: Connection closed: Connection closed early The remote server unexpectedly closed the connection.

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☒ command changed from DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches to DEB_COMPAT_RELEASE=ubuntu/esm DEB_UPDATE_CHANGELOG=auto deb-new-upstream --snapshot --refresh-patches
  • ☑ review not required
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer pkg-grass-devel@lists.alioth.debian.org
  • ☒ change set 07fd079e-ff06-4ab7-be63-f29d8932278d is working

Full worker log Full build log