Run of fresh-snapshots for node-duplexer

Merge these changes:

git pull https://janitor.debian.net/git/node-duplexer fresh-snapshots/main
git pull https://janitor.debian.net/git/node-duplexer fresh-snapshots/pristine-tar
git pull https://janitor.debian.net/git/node-duplexer fresh-snapshots/upstream

Summary

Merged new upstream version: 0.1.2+git20210308.1.99ee4c5 (was: 0.1.2).

Diff

Branch: main

diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..ed05f88
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,6 @@
+language: node_js
+node_js:
+  - "0.11"
+  - "0.10"
+  - "0.8"
+  - "0.6"
diff --git a/README.md b/README.md
index 1dd3b89..6cc4a9d 100644
--- a/README.md
+++ b/README.md
@@ -1,3 +1,9 @@
+# DEPRECATED.
+
+Apparently this module is broken and not compatible with more recent versions of nodejs.
+
+Do not use.
+
 # duplexer
 
 [![build status][1]][2] [![dependency status][3]][4]
diff --git a/debian/changelog b/debian/changelog
index 58808dc..b343234 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+node-duplexer (0.1.2+git20210308.1.99ee4c5-1) UNRELEASED; urgency=low
+
+  * New upstream snapshot.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 31 Mar 2022 13:37:43 -0000
+
 node-duplexer (0.1.2-1) unstable; urgency=medium
 
   * Team upload
diff --git a/package-lock.json b/package-lock.json
deleted file mode 100644
index 02e2e1b..0000000
--- a/package-lock.json
+++ /dev/null
@@ -1,43 +0,0 @@
-{
-  "name": "duplexer",
-  "version": "0.1.2",
-  "lockfileVersion": 1,
-  "requires": true,
-  "dependencies": {
-    "deep-equal": {
-      "version": "0.0.0",
-      "resolved": "https://registry.npmjs.org/deep-equal/-/deep-equal-0.0.0.tgz",
-      "integrity": "sha1-mWedO70EcVb81FDT0B7rkGhpHoM=",
-      "dev": true
-    },
-    "defined": {
-      "version": "0.0.0",
-      "resolved": "https://registry.npmjs.org/defined/-/defined-0.0.0.tgz",
-      "integrity": "sha1-817qfXBekzuvE7LwOz+D2SFAOz4=",
-      "dev": true
-    },
-    "jsonify": {
-      "version": "0.0.0",
-      "resolved": "https://registry.npmjs.org/jsonify/-/jsonify-0.0.0.tgz",
-      "integrity": "sha1-LHS27kHZPKUbe1qu6PUDYx0lKnM=",
-      "dev": true
-    },
-    "tape": {
-      "version": "0.3.3",
-      "resolved": "https://registry.npmjs.org/tape/-/tape-0.3.3.tgz",
-      "integrity": "sha1-OtlqvIA1YTXnjxLXiiSreIJle/s=",
-      "dev": true,
-      "requires": {
-        "deep-equal": "~0.0.0",
-        "defined": "~0.0.0",
-        "jsonify": "~0.0.0"
-      }
-    },
-    "through": {
-      "version": "0.1.4",
-      "resolved": "https://registry.npmjs.org/through/-/through-0.1.4.tgz",
-      "integrity": "sha1-gFlXbYMwibPBjszTdYC/nMW1kTA=",
-      "dev": true
-    }
-  }
-}

Branch: pristine-tar

diff --git a/node-duplexer_0.1.2+git20210308.1.99ee4c5.orig.tar.gz.delta b/node-duplexer_0.1.2+git20210308.1.99ee4c5.orig.tar.gz.delta
new file mode 100644
index 0000000..6355961
Binary files /dev/null and b/node-duplexer_0.1.2+git20210308.1.99ee4c5.orig.tar.gz.delta differ
diff --git a/node-duplexer_0.1.2+git20210308.1.99ee4c5.orig.tar.gz.id b/node-duplexer_0.1.2+git20210308.1.99ee4c5.orig.tar.gz.id
new file mode 100644
index 0000000..05b356e
--- /dev/null
+++ b/node-duplexer_0.1.2+git20210308.1.99ee4c5.orig.tar.gz.id
@@ -0,0 +1 @@
+87b7670c1cd9c04d2d64298b37215df2e9978653

Branch: upstream

Tag: upstream/0.1.2+git20210308.1.99ee4c5
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..ed05f88
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,6 @@
+language: node_js
+node_js:
+  - "0.11"
+  - "0.10"
+  - "0.8"
+  - "0.6"
diff --git a/README.md b/README.md
index 1dd3b89..6cc4a9d 100644
--- a/README.md
+++ b/README.md
@@ -1,3 +1,9 @@
+# DEPRECATED.
+
+Apparently this module is broken and not compatible with more recent versions of nodejs.
+
+Do not use.
+
 # duplexer
 
 [![build status][1]][2] [![dependency status][3]][4]
diff --git a/package-lock.json b/package-lock.json
deleted file mode 100644
index 02e2e1b..0000000
--- a/package-lock.json
+++ /dev/null
@@ -1,43 +0,0 @@
-{
-  "name": "duplexer",
-  "version": "0.1.2",
-  "lockfileVersion": 1,
-  "requires": true,
-  "dependencies": {
-    "deep-equal": {
-      "version": "0.0.0",
-      "resolved": "https://registry.npmjs.org/deep-equal/-/deep-equal-0.0.0.tgz",
-      "integrity": "sha1-mWedO70EcVb81FDT0B7rkGhpHoM=",
-      "dev": true
-    },
-    "defined": {
-      "version": "0.0.0",
-      "resolved": "https://registry.npmjs.org/defined/-/defined-0.0.0.tgz",
-      "integrity": "sha1-817qfXBekzuvE7LwOz+D2SFAOz4=",
-      "dev": true
-    },
-    "jsonify": {
-      "version": "0.0.0",
-      "resolved": "https://registry.npmjs.org/jsonify/-/jsonify-0.0.0.tgz",
-      "integrity": "sha1-LHS27kHZPKUbe1qu6PUDYx0lKnM=",
-      "dev": true
-    },
-    "tape": {
-      "version": "0.3.3",
-      "resolved": "https://registry.npmjs.org/tape/-/tape-0.3.3.tgz",
-      "integrity": "sha1-OtlqvIA1YTXnjxLXiiSreIJle/s=",
-      "dev": true,
-      "requires": {
-        "deep-equal": "~0.0.0",
-        "defined": "~0.0.0",
-        "jsonify": "~0.0.0"
-      }
-    },
-    "through": {
-      "version": "0.1.4",
-      "resolved": "https://registry.npmjs.org/through/-/through-0.1.4.tgz",
-      "integrity": "sha1-gFlXbYMwibPBjszTdYC/nMW1kTA=",
-      "dev": true
-    }
-  }
-}

Publish Blockers

  • ☑ run was successful
  • ☑ package has not been removed from the archive
  • ☑ command has not changed
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 549, max open: 300)
  • ☑ change set da62e3db-8656-43cc-a327-add3b843e2ca is ready

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots node-duplexer

Lintian Result

Full worker log Full build log