Run of fresh-snapshots for node-es6-iterator

Merge these changes:

git pull https://janitor.debian.net/git/node-es6-iterator fresh-snapshots/main
git pull https://janitor.debian.net/git/node-es6-iterator fresh-snapshots/pristine-tar
git pull https://janitor.debian.net/git/node-es6-iterator fresh-snapshots/upstream

Summary

Merged new upstream version: 2.0.3+git20210630.1.049b1ef (was: 2.0.3).

Diff

Branch: main

diff --git a/.circleci/config.yml b/.circleci/config.yml
index a2bea21..015b77e 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -31,8 +31,7 @@ jobs:
           paths:
             - node_modules
           key: dependencies-v8-{{ checksum "package.json" }}
-      - run: npm run check-coverage
-      - run: bash <(curl -s https://codecov.io/bash)
+      - run: npm test
   
   node6:
     docker:
diff --git a/.editorconfig b/.editorconfig
index c24a6cd..6923a5e 100644
--- a/.editorconfig
+++ b/.editorconfig
@@ -9,6 +9,6 @@ end_of_line = lf
 insert_final_newline = true
 indent_style = tab
 
-[{*.json,*.yml}]
+[{*.json,*.yml,*.md}]
 indent_style = space
 indent_size = 2
diff --git a/.github/FUNDING.yml b/.github/FUNDING.yml
new file mode 100644
index 0000000..e21af22
--- /dev/null
+++ b/.github/FUNDING.yml
@@ -0,0 +1,2 @@
+github: medikoo
+tidelift: "npm/es6-iterator"
diff --git a/README.md b/README.md
index 288373d..a130112 100644
--- a/README.md
+++ b/README.md
@@ -146,3 +146,19 @@ Chain multiple iterators into one.
 ### Tests [![Build Status](https://travis-ci.org/medikoo/es6-iterator.png)](https://travis-ci.org/medikoo/es6-iterator)
 
 	$ npm test
+
+## Security contact information
+
+To report a security vulnerability, please use the [Tidelift security contact](https://tidelift.com/security). Tidelift will coordinate the fix and disclosure.
+
+---
+
+<div align="center">
+	<b>
+		<a href="https://tidelift.com/subscription/pkg/npm-es6-iterator?utm_source=npm-es6-iterator&utm_medium=referral&utm_campaign=readme">Get professional support for d with a Tidelift subscription</a>
+	</b>
+	<br>
+	<sub>
+		Tidelift helps make open source sustainable for maintainers while giving companies<br>assurances about security, maintenance, and licensing for their dependencies.
+	</sub>
+</div>
diff --git a/debian/changelog b/debian/changelog
index 1db0c75..64242ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+node-es6-iterator (2.0.3+git20210630.1.049b1ef-1) UNRELEASED; urgency=low
+
+  * New upstream snapshot.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 16 Apr 2022 05:10:29 -0000
+
 node-es6-iterator (2.0.3-4) unstable; urgency=medium
 
   * Team upload
diff --git a/package.json b/package.json
index bc2582a..4c9f175 100644
--- a/package.json
+++ b/package.json
@@ -16,15 +16,15 @@
     "url": "git://github.com/medikoo/es6-iterator.git"
   },
   "dependencies": {
-    "d": "1",
-    "es5-ext": "^0.10.35",
+    "d": "^1.0.1",
+    "es5-ext": "^0.10.50",
     "es6-symbol": "^3.1.1"
   },
   "devDependencies": {
-    "eslint": "^4.9",
-    "eslint-config-medikoo-es5": "^1.4.4",
+    "eslint": "^5.16.0",
+    "eslint-config-medikoo-es5": "^1.7.3",
     "event-emitter": "^0.3.5",
-    "tad": "^0.2.7"
+    "tad": "^0.2.8"
   },
   "eslintConfig": {
     "extends": "medikoo-es5",

Branch: pristine-tar

diff --git a/node-es6-iterator_2.0.3+git20210630.1.049b1ef.orig.tar.gz.delta b/node-es6-iterator_2.0.3+git20210630.1.049b1ef.orig.tar.gz.delta
new file mode 100644
index 0000000..c58a1d7
Binary files /dev/null and b/node-es6-iterator_2.0.3+git20210630.1.049b1ef.orig.tar.gz.delta differ
diff --git a/node-es6-iterator_2.0.3+git20210630.1.049b1ef.orig.tar.gz.id b/node-es6-iterator_2.0.3+git20210630.1.049b1ef.orig.tar.gz.id
new file mode 100644
index 0000000..5f7b58d
--- /dev/null
+++ b/node-es6-iterator_2.0.3+git20210630.1.049b1ef.orig.tar.gz.id
@@ -0,0 +1 @@
+53cc82a453072ed9e8b470b57502789daa9fe02f

Branch: upstream

Tag: upstream/2.0.3+git20210630.1.049b1ef
diff --git a/.circleci/config.yml b/.circleci/config.yml
index a2bea21..015b77e 100644
--- a/.circleci/config.yml
+++ b/.circleci/config.yml
@@ -31,8 +31,7 @@ jobs:
           paths:
             - node_modules
           key: dependencies-v8-{{ checksum "package.json" }}
-      - run: npm run check-coverage
-      - run: bash <(curl -s https://codecov.io/bash)
+      - run: npm test
   
   node6:
     docker:
diff --git a/.editorconfig b/.editorconfig
index c24a6cd..6923a5e 100644
--- a/.editorconfig
+++ b/.editorconfig
@@ -9,6 +9,6 @@ end_of_line = lf
 insert_final_newline = true
 indent_style = tab
 
-[{*.json,*.yml}]
+[{*.json,*.yml,*.md}]
 indent_style = space
 indent_size = 2
diff --git a/.github/FUNDING.yml b/.github/FUNDING.yml
new file mode 100644
index 0000000..e21af22
--- /dev/null
+++ b/.github/FUNDING.yml
@@ -0,0 +1,2 @@
+github: medikoo
+tidelift: "npm/es6-iterator"
diff --git a/README.md b/README.md
index 288373d..a130112 100644
--- a/README.md
+++ b/README.md
@@ -146,3 +146,19 @@ Chain multiple iterators into one.
 ### Tests [![Build Status](https://travis-ci.org/medikoo/es6-iterator.png)](https://travis-ci.org/medikoo/es6-iterator)
 
 	$ npm test
+
+## Security contact information
+
+To report a security vulnerability, please use the [Tidelift security contact](https://tidelift.com/security). Tidelift will coordinate the fix and disclosure.
+
+---
+
+<div align="center">
+	<b>
+		<a href="https://tidelift.com/subscription/pkg/npm-es6-iterator?utm_source=npm-es6-iterator&utm_medium=referral&utm_campaign=readme">Get professional support for d with a Tidelift subscription</a>
+	</b>
+	<br>
+	<sub>
+		Tidelift helps make open source sustainable for maintainers while giving companies<br>assurances about security, maintenance, and licensing for their dependencies.
+	</sub>
+</div>
diff --git a/package.json b/package.json
index bc2582a..4c9f175 100644
--- a/package.json
+++ b/package.json
@@ -16,15 +16,15 @@
     "url": "git://github.com/medikoo/es6-iterator.git"
   },
   "dependencies": {
-    "d": "1",
-    "es5-ext": "^0.10.35",
+    "d": "^1.0.1",
+    "es5-ext": "^0.10.50",
     "es6-symbol": "^3.1.1"
   },
   "devDependencies": {
-    "eslint": "^4.9",
-    "eslint-config-medikoo-es5": "^1.4.4",
+    "eslint": "^5.16.0",
+    "eslint-config-medikoo-es5": "^1.7.3",
     "event-emitter": "^0.3.5",
-    "tad": "^0.2.7"
+    "tad": "^0.2.8"
   },
   "eslintConfig": {
     "extends": "medikoo-es5",

Publish Blockers

  • ☑ run was successful
  • ☑ package has not been removed from the archive
  • ☑ command has not changed
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 549, max open: 300)
  • ☑ change set 0e872282-6849-485e-ad8f-fa6a334c8754 is ready

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots node-es6-iterator

Lintian Result

Full worker log Full build log