Run of fresh-snapshots for ocaml-ca-certs

Merge these changes:

git pull https://janitor.debian.net/git/ocaml-ca-certs fresh-snapshots/main
git pull https://janitor.debian.net/git/ocaml-ca-certs fresh-snapshots/pristine-tar
git pull https://janitor.debian.net/git/ocaml-ca-certs fresh-snapshots/upstream

Summary

Merged new upstream version: 0.2.2+git20211209.1.39d203d (was: 0.2.2).

Diff

Branch: main

diff --git a/ca-certs.opam b/ca-certs.opam
index b65f0a4..dcf1e3e 100644
--- a/ca-certs.opam
+++ b/ca-certs.opam
@@ -1,4 +1,3 @@
-version: "0.2.2"
 # This file is generated by dune, edit dune-project instead
 opam-version: "2.0"
 synopsis: "Detect root CA certificates from the operating system"
@@ -28,6 +27,9 @@ depends: [
   "alcotest" {with-test}
   "fmt" {with-test & >= "0.8.7"}
 ]
+conflicts: [
+  "result" {< "1.5"}
+]
 dev-repo: "git+https://github.com/mirage/ca-certs.git"
 build: [
   ["dune" "subst"] {dev}
@@ -46,4 +48,4 @@ build: [
 tags: ["org:mirage"]
 depexts: [
   ["ca_root_nss"] {os = "freebsd"}
-]
\ No newline at end of file
+]
diff --git a/debian/changelog b/debian/changelog
index 6b8f4f1..e050b1b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+ocaml-ca-certs (0.2.2+git20211209.1.39d203d-1) UNRELEASED; urgency=low
+
+  * New upstream snapshot.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sat, 09 Apr 2022 09:42:09 -0000
+
 ocaml-ca-certs (0.2.2-2) unstable; urgency=medium
 
   * Fix FTBFS on bytecode architectures
diff --git a/dune-project b/dune-project
index f91c08e..91e633d 100644
--- a/dune-project
+++ b/dune-project
@@ -1,6 +1,5 @@
 (lang dune 2.0)
 (name ca-certs)
-(version v0.2.2)
 
 (generate_opam_files true)
 (source (github mirage/ca-certs))
@@ -17,6 +16,7 @@
   (ocaml (>= 4.08.0))
   (alcotest :with-test)
   (fmt (and :with-test (>= 0.8.7))))
+ (conflicts (result (< 1.5)))
  (synopsis "Detect root CA certificates from the operating system")
  (description
    "\> TLS requires a set of root anchors (Certificate Authorities) to

Branch: pristine-tar

diff --git a/ocaml-ca-certs_0.2.2+git20211209.1.39d203d.orig.tar.gz.delta b/ocaml-ca-certs_0.2.2+git20211209.1.39d203d.orig.tar.gz.delta
new file mode 100644
index 0000000..aa4b5a7
Binary files /dev/null and b/ocaml-ca-certs_0.2.2+git20211209.1.39d203d.orig.tar.gz.delta differ
diff --git a/ocaml-ca-certs_0.2.2+git20211209.1.39d203d.orig.tar.gz.id b/ocaml-ca-certs_0.2.2+git20211209.1.39d203d.orig.tar.gz.id
new file mode 100644
index 0000000..cdf74a8
--- /dev/null
+++ b/ocaml-ca-certs_0.2.2+git20211209.1.39d203d.orig.tar.gz.id
@@ -0,0 +1 @@
+52319a12749ae8403bdb19d34408f9ee5a396053

Branch: upstream

Tag: upstream/0.2.2+git20211209.1.39d203d
diff --git a/ca-certs.opam b/ca-certs.opam
index b65f0a4..dcf1e3e 100644
--- a/ca-certs.opam
+++ b/ca-certs.opam
@@ -1,4 +1,3 @@
-version: "0.2.2"
 # This file is generated by dune, edit dune-project instead
 opam-version: "2.0"
 synopsis: "Detect root CA certificates from the operating system"
@@ -28,6 +27,9 @@ depends: [
   "alcotest" {with-test}
   "fmt" {with-test & >= "0.8.7"}
 ]
+conflicts: [
+  "result" {< "1.5"}
+]
 dev-repo: "git+https://github.com/mirage/ca-certs.git"
 build: [
   ["dune" "subst"] {dev}
@@ -46,4 +48,4 @@ build: [
 tags: ["org:mirage"]
 depexts: [
   ["ca_root_nss"] {os = "freebsd"}
-]
\ No newline at end of file
+]
diff --git a/dune-project b/dune-project
index f91c08e..91e633d 100644
--- a/dune-project
+++ b/dune-project
@@ -1,6 +1,5 @@
 (lang dune 2.0)
 (name ca-certs)
-(version v0.2.2)
 
 (generate_opam_files true)
 (source (github mirage/ca-certs))
@@ -17,6 +16,7 @@
   (ocaml (>= 4.08.0))
   (alcotest :with-test)
   (fmt (and :with-test (>= 0.8.7))))
+ (conflicts (result (< 1.5)))
  (synopsis "Detect root CA certificates from the operating system")
  (description
    "\> TLS requires a set of root anchors (Certificate Authorities) to

Publish Blockers

  • ☑ run was successful
  • ☑ package has not been removed from the archive
  • ☑ command has not changed
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far.not currently attempting to back off
  • ☒ merge proposals for the package maintainer are currently being rate-limited (open: 1257, max open: 300)
  • ☑ change set 5166dd12-9220-444d-9b64-17015021a052 is ready

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots libca-certs-ocaml-dbgsymapt install -t fresh-snapshots libca-certs-ocaml-devapt install -t fresh-snapshots libca-certs-ocaml

Lintian Result

Full worker log Full build log