Run of fresh-snapshots for ocaml-qcheck

Try this locally package):


git clone  ocaml-qcheck
cd ocaml-qcheck
ogni dist

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
Using upstream branch https://github.com/c-cube/qcheck.git (from configuration)
Total 3547 (delta 824), reused 1034 (delta 682), pack-reused 2286
last found upstream version 0.18 (0.18) is lower than previous packaged upstream version (0.18.1+git20220309.1.e92837e)
Using version string 0.18.1+git20220410.0.0eb5948.
No upstream upstream-revision format specified, trying git:e92837e
Not including upstream history, since previous upstream version (0.18.1+git20220309.1.e92837e) is not present in packaging branch history.
Looking for upstream 0.18.1+git20220410.0.0eb5948 in upstream branch <RemoteGitBranch('https://github.com/c-cube/qcheck.git/', 'master')>.
Running dist command: SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python39.zip:/usr/lib/python3.9:/usr/lib/python3.9/lib-dynload:/usr/local/lib/python3.9/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitorz0vo1cg2/ocaml-qcheck/debian
Opened schroot session unstable-amd64-sbuild-bbd93a45-545d-4eed-8c0c-63cf175b95f2 (from unstable-amd64-sbuild)
apt: running ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n dh-ocaml,\n ocaml,\n ocaml-dune,\n ocaml-findlib,\n libalcotest-ocaml-dev,\n libounit-ocaml-dev (>= 2.2.0)']
Traceback (most recent call last):
  File "/usr/lib/python3.9/runpy.py", line 197, in _run_module_as_main
    return _run_code(code, main_globals, None,
  File "/usr/lib/python3.9/runpy.py", line 87, in _run_code
    exec(code, run_globals)
  File "/code/janitor/dist.py", line 128, in <module>
    satisfy_build_deps(session, packaging_tree, packaging_debian_path)
  File "/code/ognibuild/ognibuild/debian/__init__.py", line 41, in satisfy_build_deps
    apt.satisfy(deps)
  File "/code/ognibuild/ognibuild/debian/apt.py", line 138, in satisfy
    run_apt(self.session, ["satisfy"] + deps, prefix=self.prefix)
  File "/code/ognibuild/ognibuild/debian/apt.py", line 60, in run_apt
    raise UnidentifiedError(retcode, args, lines, secondary=match)
ognibuild.UnidentifiedError: (100, ['apt', '-y', 'satisfy', 'debhelper-compat (= 13),\n dh-ocaml,\n ocaml,\n ocaml-dune,\n ocaml-findlib,\n libalcotest-ocaml-dev,\n libounit-ocaml-dev (>= 2.2.0)'], ['\n', 'WARNING: apt does not have a stable CLI interface. Use with caution in scripts.\n', '\n', 'Reading package lists...\n', 'Building dependency tree...\n', 'The following NEW packages will be installed:\n', '  autoconf automake autopoint autotools-dev bsdextrautils ca-certificates curl\n', '  debhelper dh-autoreconf dh-ocaml dh-strip-nondeterminism dwz file gettext\n', '  gettext-base groff-base intltool-debian ledit libalcotest-ocaml-dev\n', '  libarchive-cpio-perl libarchive-zip-perl libastring-ocaml\n', '  libastring-ocaml-dev libbrotli1 libcmdliner-ocaml-dev libcurl4\n', '  libdebhelper-perl libelf1 libfile-stripnondeterminism-perl libfindlib-ocaml\n', '  libfindlib-ocaml-dev libfmt-ocaml libfmt-ocaml-dev libgpm2 libicu67\n', '  libldap-2.5-0 libldap-common libltdl-dev libltdl7 libmagic-mgc libmagic1\n', '  libmail-sendmail-perl libncurses-dev libncurses5-dev libncurses6\n', '  libncursesw6 libnghttp2-14 libounit-ocaml-dev libpipeline1 libpsl5\n', '  libre-ocaml-dev librtmp1 libsasl2-2 libsasl2-modules libsasl2-modules-db\n', '  libsigsegv2 libssh2-1 libsub-override-perl libsys-hostname-long-perl libtool\n', '  libuchardet0 libuutf-ocaml libuutf-ocaml-dev libxml2 m4 man-db ocaml\n', '  ocaml-base ocaml-compiler-libs ocaml-dune ocaml-findlib ocaml-interp\n', '  ocaml-man ocaml-nox openssl po-debconf publicsuffix sensible-utils\n', '0 upgraded, 78 newly installed, 0 to remove and 0 not upgraded.\n', 'Need to get 141 MB of archives.\n', 'After this operation, 557 MB of additional disk space will be used.\n', 'Get:1 http://deb.debian.org/debian unstable/main amd64 sensible-utils all 0.0.17 [21.5 kB]\n', 'Get:2 http://deb.debian.org/debian unstable/main amd64 openssl amd64 1.1.1n-1 [853 kB]\n', 'Get:3 http://deb.debian.org/debian unstable/main amd64 ca-certificates all 20211016 [156 kB]\n', 'Get:4 http://deb.debian.org/debian unstable/main amd64 libmagic-mgc amd64 1:5.41-2 [295 kB]\n', 'Get:5 http://deb.debian.org/debian unstable/main amd64 libmagic1 amd64 1:5.41-2 [129 kB]\n', 'Get:6 http://deb.debian.org/debian unstable/main amd64 file amd64 1:5.41-2 [66.9 kB]\n', 'Get:7 http://deb.debian.org/debian unstable/main amd64 gettext-base amd64 0.21-4 [175 kB]\n', 'Get:8 http://deb.debian.org/debian unstable/main amd64 libuchardet0 amd64 0.0.7-1 [67.8 kB]\n', 'Get:9 http://deb.debian.org/debian unstable/main amd64 groff-base amd64 1.22.4-8 [936 kB]\n', 'Get:10 http://deb.debian.org/debian unstable/main amd64 bsdextrautils amd64 2.37.3-1+b1 [144 kB]\n', 'Get:11 http://deb.debian.org/debian unstable/main amd64 libpipeline1 amd64 1.5.5-1 [37.6 kB]\n', 'Get:12 http://deb.debian.org/debian unstable/main amd64 man-db amd64 2.10.2-1 [1411 kB]\n', 'Get:13 http://deb.debian.org/debian unstable/main amd64 libsigsegv2 amd64 2.14-1 [37.2 kB]\n', 'Get:14 http://deb.debian.org/debian unstable/main amd64 m4 amd64 1.4.18-5 [204 kB]\n', 'Get:15 http://deb.debian.org/debian unstable/main amd64 autoconf all 2.71-2 [343 kB]\n', 'Get:16 http://deb.debian.org/debian unstable/main amd64 autotools-dev all 20220109.1 [51.6 kB]\n', 'Get:17 http://deb.debian.org/debian unstable/main amd64 automake all 1:1.16.5-1.3 [823 kB]\n', 'Get:18 http://deb.debian.org/debian unstable/main amd64 autopoint all 0.21-4 [510 kB]\n', 'Get:19 http://deb.debian.org/debian unstable/main amd64 libbrotli1 amd64 1.0.9-2+b3 [276 kB]\n', 'Get:20 http://deb.debian.org/debian unstable/main amd64 libsasl2-modules-db amd64 2.1.28+dfsg-2+b1 [74.5 kB]\n', 'Get:21 http://deb.debian.org/debian unstable/main amd64 libsasl2-2 amd64 2.1.28+dfsg-2+b1 [111 kB]\n', 'Get:22 http://deb.debian.org/debian unstable/main amd64 libldap-2.5-0 amd64 2.5.11+dfsg-1 [226 kB]\n', 'Get:23 http://deb.debian.org/debian unstable/main amd64 libnghttp2-14 amd64 1.43.0-1 [77.1 kB]\n', 'Get:24 http://deb.debian.org/debian unstable/main amd64 libpsl5 amd64 0.21.0-1.2 [57.3 kB]\n', 'Get:25 http://deb.debian.org/debian unstable/main amd64 librtmp1 amd64 2.4+20151223.gitfa8646d.1-2+b2 [60.8 kB]\n', 'Get:26 http://deb.debian.org/debian unstable/main amd64 libssh2-1 amd64 1.10.0-3 [178 kB]\n', 'Get:27 http://deb.debian.org/debian unstable/main amd64 libcurl4 amd64 7.82.0-2 [357 kB]\n', 'Get:28 http://deb.debian.org/debian unstable/main amd64 curl amd64 7.82.0-2 [285 kB]\n', 'Get:29 http://deb.debian.org/debian unstable/main amd64 libdebhelper-perl all 13.6 [193 kB]\n', 'Err:30 http://deb.debian.org/debian unstable/main amd64 libtool all 2.4.7-1\n', '  404  Not Found [IP: 199.232.150.132 80]\n', 'Get:31 http://deb.debian.org/debian unstable/main amd64 dh-autoreconf all 20 [17.1 kB]\n', 'Get:32 http://deb.debian.org/debian unstable/main amd64 libarchive-zip-perl all 1.68-1 [104 kB]\n', 'Get:33 http://deb.debian.org/debian unstable/main amd64 libsub-override-perl all 0.09-2 [10.2 kB]\n', 'Get:34 http://deb.debian.org/debian unstable/main amd64 libfile-stripnondeterminism-perl all 1.13.0-1 [26.6 kB]\n', 'Get:35 http://deb.debian.org/debian unstable/main amd64 dh-strip-nondeterminism all 1.13.0-1 [15.8 kB]\n', 'Get:36 http://deb.debian.org/debian unstable/main amd64 libelf1 amd64 0.186-1 [179 kB]\n', 'Get:37 http://deb.debian.org/debian unstable/main amd64 dwz amd64 0.14-1 [98.3 kB]\n', 'Get:38 http://deb.debian.org/debian unstable/main amd64 libicu67 amd64 67.1-7 [8622 kB]\n', 'Get:39 http://deb.debian.org/debian unstable/main amd64 libxml2 amd64 2.9.13+dfsg-1 [709 kB]\n', 'Get:40 http://deb.debian.org/debian unstable/main amd64 gettext amd64 0.21-4 [1311 kB]\n', 'Get:41 http://deb.debian.org/debian unstable/main amd64 intltool-debian all 0.35.0+20060710.5 [26.8 kB]\n', 'Get:42 http://deb.debian.org/debian unstable/main amd64 po-debconf all 1.0.21+nmu1 [248 kB]\n', 'Get:43 http://deb.debian.org/debian unstable/main amd64 debhelper all 13.6 [1054 kB]\n', 'Get:44 http://deb.debian.org/debian unstable/main amd64 dh-ocaml all 1.1.3 [82.9 kB]\n', 'Get:45 http://deb.debian.org/debian unstable/main amd64 ocaml-base amd64 4.13.1-3 [687 kB]\n', 'Get:46 http://deb.debian.org/debian unstable/main amd64 ledit all 2.04-6 [54.2 kB]\n', 'Get:47 http://deb.debian.org/debian unstable/main amd64 libastring-ocaml amd64 0.8.5-1+b2 [174 kB]\n', 'Get:48 http://deb.debian.org/debian unstable/main amd64 ocaml-compiler-libs amd64 4.13.1-3 [30.9 MB]\n', 'Get:49 http://deb.debian.org/debian unstable/main amd64 ocaml-interp amd64 4.13.1-3 [6181 kB]\n', 'Get:50 http://deb.debian.org/debian unstable/main amd64 libncurses6 amd64 6.3-2 [102 kB]\n', 'Get:51 http://deb.debian.org/debian unstable/main amd64 libncursesw6 amd64 6.3-2 [133 kB]\n', 'Get:52 http://deb.debian.org/debian unstable/main amd64 libncurses-dev amd64 6.3-2 [344 kB]\n', 'Get:53 http://deb.debian.org/debian unstable/main amd64 libncurses5-dev amd64 6.3-2 [932 B]\n', 'Get:54 http://deb.debian.org/debian unstable/main amd64 ocaml amd64 4.13.1-3 [72.1 MB]\n', 'Get:55 http://deb.debian.org/debian unstable/main amd64 libastring-ocaml-dev amd64 0.8.5-1+b2 [123 kB]\n', 'Get:56 http://deb.debian.org/debian unstable/main amd64 libcmdliner-ocaml-dev amd64 1.0.4-2+b2 [411 kB]\n', 'Get:57 http://deb.debian.org/debian unstable/main amd64 libfmt-ocaml amd64 0.9.0-2+b1 [125 kB]\n', 'Get:58 http://deb.debian.org/debian unstable/main amd64 libfmt-ocaml-dev amd64 0.9.0-2+b1 [96.5 kB]\n', 'Get:59 http://deb.debian.org/debian unstable/main amd64 libre-ocaml-dev amd64 1.10.3-1+b1 [887 kB]\n', 'Get:60 http://deb.debian.org/debian unstable/main amd64 libuutf-ocaml amd64 1.0.3-1 [73.8 kB]\n', 'Get:61 http://deb.debian.org/debian unstable/main amd64 libuutf-ocaml-dev amd64 1.0.3-1 [480 kB]\n', 'Get:62 http://deb.debian.org/debian unstable/main amd64 libalcotest-ocaml-dev amd64 1.5.0-3+b2 [720 kB]\n', 'Get:63 http://deb.debian.org/debian unstable/main amd64 libarchive-cpio-perl all 0.10-1.1 [10.6 kB]\n', 'Get:64 http://deb.debian.org/debian unstable/main amd64 libfindlib-ocaml amd64 1.9.3-1 [175 kB]\n', 'Get:65 http://deb.debian.org/debian unstable/main amd64 libfindlib-ocaml-dev amd64 1.9.3-1 [165 kB]\n', 'Get:66 http://deb.debian.org/debian unstable/main amd64 libgpm2 amd64 1.20.7-10 [35.9 kB]\n', 'Get:67 http://deb.debian.org/debian unstable/main amd64 libldap-common all 2.5.11+dfsg-1 [71.5 kB]\n', 'Get:68 http://deb.debian.org/debian unstable/main amd64 libltdl7 amd64 2.4.7-1 [401 kB]\n', 'Get:69 http://deb.debian.org/debian unstable/main amd64 libltdl-dev amd64 2.4.7-1 [164 kB]\n', 'Get:70 http://deb.debian.org/debian unstable/main amd64 libsys-hostname-long-perl all 1.5-2 [11.8 kB]\n', 'Get:71 http://deb.debian.org/debian unstable/main amd64 libmail-sendmail-perl all 0.80-1.1 [25.5 kB]\n', 'Get:72 http://deb.debian.org/debian unstable/main amd64 libounit-ocaml-dev amd64 2.2.6-1 [970 kB]\n', 'Get:73 http://deb.debian.org/debian unstable/main amd64 libsasl2-modules amd64 2.1.28+dfsg-2+b1 [109 kB]\n', 'Get:74 http://deb.debian.org/debian unstable/main amd64 ocaml-dune amd64 2.9.1-1+b1 [2242 kB]\n', 'Get:75 http://deb.debian.org/debian unstable/main amd64 ocaml-findlib amd64 1.9.3-1 [486 kB]\n', 'Get:76 http://deb.debian.org/debian unstable/main amd64 ocaml-man all 4.13.1-3 [705 kB]\n', 'Get:77 http://deb.debian.org/debian unstable/main amd64 ocaml-nox all 4.13.1-3 [185 kB]\n', 'Get:78 http://deb.debian.org/debian unstable/main amd64 publicsuffix all 20211207.1025-1 [125 kB]\n', 'Fetched 140 MB in 17s (8241 kB/s)\n', 'E: Failed to fetch http://deb.debian.org/debian/pool/main/libt/libtool/libtool_2.4.7-1_all.deb  404  Not Found [IP: 199.232.150.132 80]\n', 'E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?\n', 'E: Failed to process build dependencies\n'])
Command 'SCHROOT=unstable-amd64-sbuild PYTHONPATH=/:/code:/code/breezy:/code/dulwich:/code/lintian-brush:/code/ognibuild:/code/silver-platter:/code/buildlog-consultant:/code/upstream-ontologist:/code/debmutate:/code/python-debian/lib:/usr/lib/python39.zip:/usr/lib/python3.9:/usr/lib/python3.9/lib-dynload:/usr/local/lib/python3.9/dist-packages:/usr/lib/python3/dist-packages /usr/bin/python3 -m janitor.dist --packaging=/tmp/janitorz0vo1cg2/ocaml-qcheck/debian' returned non-zero exit status 1.

Publish Blockers

  • ☒ run was not successful
  • ☑ package has not been removed from the archive
  • ☑ command has not changed
  • ☒ not yet reviewed, but review needed
  • ☑ 0 publish attempts so far. not currently attempting to back off
  • ☑ proposals not currently being rate-limited for maintainer None
  • ☒ change set bcd36e98-c62f-41c7-a725-0bdedc1588dd is working

Full worker log