Run of fresh-snapshots for pg-ldap-sync

Try this locally (using the package):

debcheckout pg-ldap-sync
cd pg-ldap-sync
new-upstream --snapshot

Summary

Merged new upstream version: 0.2.0+git20180314.1.49a0391 (was: 0.2.0).

Diff

Branch: main

diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 0000000..3214f9e
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,22 @@
+## 0.2.0 / 2018-03-13
+
+* Update gem dependencies
+* Fix compatibility to pg-1.0 gem
+* Add `pg_ldap_sync --version`
+* Fix compatibility with PostgreSQL-10
+* Don't abort on SQL errors, but print ERROR notice
+* Run sync within a SQL transaction, so that no partial sync happens
+* Lots of improvements to the test suite
+* Run automated tests on Travis-CI and Appveyor
+* Remove support for postgres-pr, since it's no longer maintained
+
+
+## 0.1.1 / 2012-11-15
+
+* Add ability to lowercase the LDAP name for use as PG role name
+
+
+## 0.1.0 / 2011-07-13
+
+* Birthday!
+
diff --git a/History.txt b/History.txt
deleted file mode 100644
index 34e4f4b..0000000
--- a/History.txt
+++ /dev/null
@@ -1,8 +0,0 @@
-=== 0.1.1 / 2012-11-15
-
-* Add ability to lowercase the LDAP name for use as PG role name
-
-=== 0.1.0 / 2011-07-13
-
-* Birthday!
-
diff --git a/README.md b/README.md
index 3c1ba72..3daf494 100644
--- a/README.md
+++ b/README.md
@@ -24,13 +24,12 @@ It is meant to be started as a cron job.
 * Can use Active Directory as LDAP-Server
 * Nested groups/roles supported
 * Set scope of considered users/groups on LDAP and PG side
-* Runs with pg.gem (C-library) or postgres-pr.gem (pure Ruby)
 * Test mode which doesn't do any changes to the DBMS
 * Both LDAP and PG connections can be secured by SSL/TLS
 
 ## REQUIREMENTS:
 
-* Ruby-2.0+, JRuby-1.2, Rubinius-1.2 or better
+* Ruby-2.0+, JRuby-1.2+
 * LDAP-v3 server
 * PostgreSQL-server v9.0+
 
@@ -50,8 +49,9 @@ Install pg-ldap-sync and required dependencies:
 ```sh
   git clone https://github.com/larskanis/pg-ldap-sync.git
   cd pg-ldap-sync
-  bundle
-  rake install
+  gem install bundler
+  bundle install
+  bundle exec rake install
 ```
 
 ## USAGE:
@@ -74,7 +74,8 @@ Run in modify-mode:
 There is a small test suite in the `test` directory that runs against an internal LDAP server and a PostgreSQL server. Ensure `pg_ctl`, `initdb` and `psql` commands are in the `PATH` like so:
 ```sh
   cd pg-ldap-sync
-  PATH=$PATH:/usr/lib/postgresql/10/bin/ rake test
+  bundle install
+  PATH=$PATH:/usr/lib/postgresql/10/bin/ bundle exec rake test
 ```
 
 ## ISSUES:
diff --git a/debian/changelog b/debian/changelog
index 2e20d45..19b6df1 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+pg-ldap-sync (0.2.0+git20180314.1.49a0391-1) UNRELEASED; urgency=low
+
+  * New upstream snapshot.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Sun, 06 Jun 2021 15:06:09 -0000
+
 pg-ldap-sync (0.2.0-2) unstable; urgency=medium
 
   * Team upload.

Branch: pristine-tar

diff --git a/pg-ldap-sync_0.2.0+git20180314.1.49a0391.orig.tar.gz.delta b/pg-ldap-sync_0.2.0+git20180314.1.49a0391.orig.tar.gz.delta
new file mode 100644
index 0000000..cfb79c6
Binary files /dev/null and b/pg-ldap-sync_0.2.0+git20180314.1.49a0391.orig.tar.gz.delta differ
diff --git a/pg-ldap-sync_0.2.0+git20180314.1.49a0391.orig.tar.gz.id b/pg-ldap-sync_0.2.0+git20180314.1.49a0391.orig.tar.gz.id
new file mode 100644
index 0000000..f2340ed
--- /dev/null
+++ b/pg-ldap-sync_0.2.0+git20180314.1.49a0391.orig.tar.gz.id
@@ -0,0 +1 @@
+feee878f599e43907ff819fac91250d4b52a731f

Branch: upstream

Tag: upstream/0.2.0+git20180314.1.49a0391
Unable to retrieve diff; error 400

Debdiff

Error retrieving debdiff: Unable to get debdiff: 500 Internal Server Error

500 Internal Server Error

Server got itself in trouble

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots ruby-pg-ldap-sync

Lintian Result

Full worker log Full build log Full dist log