Run of scrub-obsolete for pip-requirements-el

Try this locally (using the package):

debcheckout pip-requirements-el
cd pip-requirements-el
DEB_UPDATE_CHANGELOG=auto deb-scrub-obsolete

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 845d2f4..8b27c76 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,13 @@
 pip-requirements-el (0.5-4) UNRELEASED; urgency=medium
 
+  [ Nicholas D Steeves ]
   * Drop emacs25 from Enhances (package does not exist in bullseye).
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since buster:
+    + Build-Depends: Drop versioned constraint on debhelper.
+    + elpa-pip-requirements: Drop versioned constraint on emacs in Recommends.
+
  -- Nicholas D Steeves <sten@debian.org>  Wed, 28 Jul 2021 19:41:08 -0400
 
 pip-requirements-el (0.5-3) UNRELEASED; urgency=medium
diff --git a/debian/control b/debian/control
index 4f5685c..d556277 100644
--- a/debian/control
+++ b/debian/control
@@ -3,7 +3,7 @@ Section: lisp
 Priority: optional
 Maintainer: Debian Emacsen Team <debian-emacsen@lists.debian.org>
 Uploaders: Lev Lamberov <dogsleg@debian.org>
-Build-Depends: debhelper (>= 11),
+Build-Depends: debhelper,
                dh-elpa
 Standards-Version: 4.1.3
 Homepage: https://github.com/Wilfred/pip-requirements.el
@@ -14,7 +14,7 @@ Package: elpa-pip-requirements
 Architecture: all
 Depends: ${elpa:Depends},
          ${misc:Depends}
-Recommends: emacs (>= 46.0),
+Recommends: emacs,
             elpa-company | elpa-auto-complete
 Enhances: emacs
 Description: major mode for editing pip requirements files

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t scrub-obsolete elpa-pip-requirements

Lintian Result

Full worker log Full build log