Run of cme for pip-requirements-el

Try this locally (using the cme package):

debcheckout pip-requirements-el
cd pip-requirements-el
DEB_UPDATE_CHANGELOG=auto cme fix dpkg

Diff

diff --git a/debian/changelog b/debian/changelog
index 845d2f4..6f47c69 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,32 @@
 pip-requirements-el (0.5-4) UNRELEASED; urgency=medium
 
+  [ Nicholas D Steeves ]
   * Drop emacs25 from Enhances (package does not exist in bullseye).
 
+  [ Debian Janitor ]
+  * Reading package lists... 0%Reading package lists... 0%Reading package
+    lists... 0%Reading package lists... 99%Reading package lists... 99%Reading
+    package lists... Done Building dependency tree... 0%Building dependency
+    tree... 0%Building dependency tree... 50%Building dependency tree...
+    50%Building dependency tree... Done Reading state information... 0% Reading
+    state information... 0%Reading state information... Done Connecting to
+    api.ftp-master.debian.org to check 5 package versions. Please wait... Got
+    info from api.ftp-master.debian.org for 5 packages.  Changes applied to dpkg
+    configuration: - control source Standards-Version: '4.1.3' -> '4.5.1' #
+    applied fix for :Current standards version is '4.5.1'. Please read
+    https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the
+    changes that may be needed on your package to upgrade it from standard
+    version '4.1.3' to '4.5.1'.  - compat deleted value: '11' - control source
+    Build-Depends:0: 'debhelper (>= 11)' -> 'debhelper-compat (= 13)' # applied
+    fix for :Cleared deprecated compat value; Set debhelper dependency version
+    to 13~; changed debhelper dependency to debhelper dependency - control
+    binary:"elpa-pip-requirements" Recommends:0: 'emacs (>= 46.0)' -> 'emacs' #
+    applied fix for :unnecessary greater-than versioned dependency: emacs (>=
+    46.0). Debian has oldoldstable -> 46.1; oldoldoldstable -> 46.1;
+    buster-updates -> 1:26.1+1-3.2+deb10u1; oldstable -> 1:26.1+1-3.2+deb10u2;
+    buster-backports -> 1:27.1+1-3~bpo10+1; testing -> 1:27.1+1-3.1; unstable ->
+    1:27.1+1-3.1; stable -> 1:27.1+1-3.1;
+
  -- Nicholas D Steeves <sten@debian.org>  Wed, 28 Jul 2021 19:41:08 -0400
 
 pip-requirements-el (0.5-3) UNRELEASED; urgency=medium
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index 4f5685c..568e19b 100644
--- a/debian/control
+++ b/debian/control
@@ -1,20 +1,20 @@
 Source: pip-requirements-el
-Section: lisp
-Priority: optional
 Maintainer: Debian Emacsen Team <debian-emacsen@lists.debian.org>
 Uploaders: Lev Lamberov <dogsleg@debian.org>
-Build-Depends: debhelper (>= 11),
+Section: lisp
+Priority: optional
+Build-Depends: debhelper-compat (= 13),
                dh-elpa
-Standards-Version: 4.1.3
-Homepage: https://github.com/Wilfred/pip-requirements.el
+Standards-Version: 4.5.1
 Vcs-Browser: https://salsa.debian.org/emacsen-team/pip-requirements-el
 Vcs-Git: https://salsa.debian.org/emacsen-team/pip-requirements-el.git
+Homepage: https://github.com/Wilfred/pip-requirements.el
 
 Package: elpa-pip-requirements
 Architecture: all
 Depends: ${elpa:Depends},
          ${misc:Depends}
-Recommends: emacs (>= 46.0),
+Recommends: emacs,
             elpa-company | elpa-auto-complete
 Enhances: emacs
 Description: major mode for editing pip requirements files

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t cme elpa-pip-requirements

Lintian Result

Full worker log Full build log