Run of lintian-fixes for plexus-i18n

Try this locally (using the lintian-brush package):

debcheckout plexus-i18n
cd plexus-i18n
lintian-brush --exclude=upstream-metadata-file

Merge these changes:

git pull https://janitor.debian.net/git/plexus-i18n lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 8607739..8c7939a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+plexus-i18n (1.0-beta-10-6) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from old 11 to 12.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 11 Jun 2020 03:09:16 -0000
+
 plexus-i18n (1.0-beta-10-5) unstable; urgency=medium
 
   * Team upload.
@@ -55,7 +63,7 @@ plexus-i18n (1.0-beta-10-1) experimental; urgency=low
   * Update the watch file to reflect changes on the web site, use
     SVN to download the sources
   * Add maven-build.xml to debian/ in order to support compilation with Java 1.5
-  * Change the dependency on libplexus-container-default-java to 
+  * Change the dependency on libplexus-container-default-java to
     libplexus-containers-java
   * Use openjdk-6 JDK instead of gcj to build the package
 
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b4de394..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-11
diff --git a/debian/control b/debian/control
index ffce4e5..754958d 100644
--- a/debian/control
+++ b/debian/control
@@ -6,7 +6,7 @@ Uploaders:
  Torsten Werner <twerner@debian.org>,
  Ludovic Claude <ludovic.claude@laposte.net>
 Build-Depends:
- debhelper (>= 11),
+ debhelper-compat (= 12),
  default-jdk,
  junit4,
  libplexus-component-metadata-java,

Debdiff

File lists identical (after any substitutions)

No differences were encountered in the control files

Full worker log Full build log