Run of scrub-obsolete for python-debian

Try this locally (using the lintian-brush package):

debcheckout python-debian
cd python-debian
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/python-debian scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 761245f..1855304 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,12 @@
 python-debian (0.1.39) UNRELEASED; urgency=medium
 
+  [ Stuart Prescott ]
   * Move re.compile calls out of functions (Closes: #971960).
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on binutils.
+
  -- Stuart Prescott <stuart@debian.org>  Sun, 11 Oct 2020 14:21:54 +1100
 
 python-debian (0.1.38) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index d32c4c9..5e9eea9 100644
--- a/debian/control
+++ b/debian/control
@@ -10,7 +10,7 @@ Uploaders:
  John Wright <jsw@debian.org>,
  Stuart Prescott <stuart@debian.org>
 Build-Depends:
- binutils (>= 2.23),
+ binutils,
  debhelper-compat (= 12),
  dh-python,
  python3-all (>= 3.1.2-8~),

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_cme_obs1.egg-info/PKG-INFO
-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_cme_obs1.egg-info/dependency_links.txt
-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_cme_obs1.egg-info/requires.txt
-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_cme_obs1.egg-info/top_level.txt

Files in first set of .debs but not in second

-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_jan_unchanged2.egg-info/PKG-INFO
-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_jan_unchanged2.egg-info/dependency_links.txt
-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_jan_unchanged2.egg-info/requires.txt
-rw-r--r--  root/root   /usr/lib/python3/dist-packages/python_debian-0.1.39_jan_unchanged2.egg-info/top_level.txt

No differences were encountered in the control files

Publish History

  • 2021-03-26T21:33: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T13:49: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T11:24: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T09:55: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T08:15: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T06:33: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T13:20: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T10:13: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T05:34: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T00:19: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))

Full worker log Full build log