Run of scrub-obsolete for python-flexmock

Try this locally (using the lintian-brush package):

debcheckout python-flexmock
cd python-flexmock
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/python-flexmock scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 03d7207..8899fc9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -9,6 +9,10 @@ python-flexmock (0.10.4-4) UNRELEASED; urgency=medium
   [ Stefano Rivera ]
   * Add upstream metadata.
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on dh-python.
+
  -- Ondřej Nový <onovy@debian.org>  Thu, 24 Sep 2020 08:53:59 +0200
 
 python-flexmock (0.10.4-3) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index a6cff51..ccd1402 100644
--- a/debian/control
+++ b/debian/control
@@ -5,7 +5,7 @@ Maintainer: Debian Python Team <team+python@tracker.debian.org>
 Uploaders: Stefano Rivera <stefanor@debian.org>
 Build-Depends:
  debhelper-compat (= 12),
- dh-python (>= 1.20130807),
+ dh-python,
  python3-all (>= 3.4),
  python3-nose,
  python3-pytest

Publish History

  • 2021-03-26T21:27: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T13:47: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T11:23: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T09:53: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T08:14: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T06:31: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T13:17: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T10:10: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T05:31: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T00:14: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))

Full worker log Full build log