Run of fresh-releases for python-libusb1

Try this locally package):

debcheckout python-libusb1
cd python-libusb1
DEB_UPDATE_CHANGELOG=auto deb-new-upstream --refresh-patches
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
[2022-03-14 10:43:14] Opening branch at https://salsa.debian.org/python-team/packages/python-libusb1.git/,branch=master
[2022-03-14 10:43:15] Using cached branch https://janitor.debian.net/git/python-libusb1/,branch=debian%2Flatest
[2022-03-14 10:43:18] Total 1709 (delta 130), reused 0 (delta 0), pack-reused 1499
[2022-03-14 10:43:18] 
[2022-03-14 10:43:20] Total 16 (delta 0), reused 16 (delta 0), pack-reused 0
[2022-03-14 10:43:20] 68)
[2022-03-14 10:43:20] Total 68 (delta 29), reused 0 (delta 0), pack-reused 0
[2022-03-14 10:43:21] All changes applied successfully.
[2022-03-14 10:43:21] Total 12 (delta 1), reused 0 (delta 0), pack-reused 4
[2022-03-14 10:43:21] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-03-14 10:43:21] Workspace ready - starting.
[2022-03-14 10:43:21] Running ['deb-new-upstream', '--refresh-patches']
Using upstream branch https://github.com/vpelletier/python-libusb1.git (from configuration)
Total 1651 (delta 223), reused 254 (delta 124), pack-reused 1290
Using version string 3.0.0.
No upstream upstream-revision format specified, trying tag:2.0.1
Not including upstream history, since previous upstream version (2.0.1) is not present in packaging branch history.
Using uscan to look for the upstream tarball.
uscan warn: Possible OpenPGP signature found at:
   https://pypi.debian.net/libusb1/libusb1-3.0.0.tar.gz.asc
 * Add opts=pgpsigurlmangle=s/$/.asc/ or opts=pgpmode=auto to debian/watch
 * Add debian/upstream/signing-key.asc.
 See uscan(1) for more details
Possible OpenPGP signature found at:
   https://pypi.debian.net/libusb1/libusb1-3.0.0.tar.gz.asc
 * Add opts=pgpsigurlmangle=s/$/.asc/ or opts=pgpmode=auto to debian/watch
 * Add debian/upstream/signing-key.asc.
 See uscan(1) for more details
Searching for revision importing python-libusb1 version 2.0.1 on branch upstream, packaging branch, tag debian/2.0.1-0.1.
Upstream import of 2.0.1 lacks a tag. Set one by running: brz tag -rrevid:git-v1:0f0b56534e3a2eb37cb0e858682f55853be13ab2 upstream/2.0.1
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.8 points at non-present sha 4f59143688ff1868d930146c0df7fe6a3c0b1b55
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.9.1-1 points at non-present sha b487927209e41643c8abd1bb76f7be7d85d2d836
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.7 points at non-present sha 45d133c21cef42f603185dd75ecfa7491112ed28
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.8-1 points at non-present sha 57a56788e524693343544545195ae5917f57f962
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.7-2 points at non-present sha cf49bf5e1ffcf4c421c66693a06e5a6f99a445bd
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.6-1 points at non-present sha c459a0cbefc83a6215b93dcd88b3fe8bec5b18b9
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.7-1 points at non-present sha 99e519c3a5b8e9f021eb7d98f977913c40ab8afe
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.8-1.1 points at non-present sha c5d0a264342b807426bdf31064f811167814d57c
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.0.1-0.1 points at non-present sha 27abf37890736ba7676efd3964851c2f6256d123
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.9.1 points at non-present sha a0eb10b40032a009aed034fe2cda4c0f2cd0df64
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.0.1 points at non-present sha 6915b76bc240fefabc5cab2ec914fc5369e42fa1
  warnings.warn(
upstream/1.8 does not point to a valid object
debian/1.9.1-1 does not point to a valid object
upstream/1.7 does not point to a valid object
debian/1.8-1 does not point to a valid object
debian/1.7-2 does not point to a valid object
debian/1.6-1 does not point to a valid object
debian/1.7-1 does not point to a valid object
debian/1.8-1.1 does not point to a valid object
debian/2.0.1-0.1 does not point to a valid object
upstream/1.9.1 does not point to a valid object
upstream/2.0.1 does not point to a valid object
Imported python-libusb1_3.0.0.orig.tar.gz with pristine-tar.
All changes applied successfully.
Committing to: /tmp/janitori4xgfbk3/python-libusb1/
modified MANIFEST.in
modified PKG-INFO
modified README.rst
modified debian/changelog
modified libusb1.egg-info/PKG-INFO
modified setup.cfg
modified setup.py
modified usb1/__init__.py
modified usb1/_version.py
modified usb1/testUSB1.py
modified versioneer.py
Committed revision 52.
Merged new upstream version 3.0.0 (previous: 2.0.1)
Refresh quilt patches.
An error occurred refreshing quilt patch usb1.testUSB1-Do-not-allocate-libusb-transfers-in-tests.patch: 

Applying patch debian/patches/usb1.testUSB1-Do-not-allocate-libusb-transfers-in-tests.patch
patching file usb1/testUSB1.py
Hunk #1 FAILED at 16.
Hunk #2 FAILED at 38.
Hunk #3 FAILED at 66.
Hunk #4 FAILED at 129.
Hunk #5 FAILED at 136.
Hunk #6 FAILED at 143.
Hunk #7 FAILED at 174.
7 out of 7 hunks FAILED -- rejects in file usb1/testUSB1.py
Patch debian/patches/usb1.testUSB1-Do-not-allocate-libusb-transfers-in-tests.patch does not apply (enforce with -f)

Full worker log