Run of scrub-obsolete for python-pyqrcode

Try this locally (using the lintian-brush package):

debcheckout python-pyqrcode
cd python-pyqrcode
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/python-pyqrcode scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 826dd73..43c9f29 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+python-pyqrcode (1.2.1-5) UNRELEASED; urgency=medium
+
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 20 May 2021 14:53:24 -0000
+
 python-pyqrcode (1.2.1-4) unstable; urgency=medium
 
   * Remove Python2 autopkgtest.
diff --git a/debian/control b/debian/control
index b135ac3..7e0707e 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: python-pyqrcode
 Section: python
 Priority: optional
 Maintainer: Sascha Steinbiss <satta@debian.org>
-Build-Depends: debhelper (>= 12~),
+Build-Depends: debhelper,
                debhelper-compat (= 12),
                dh-python,
                python3-all,

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t unstable python3-pyqrcode

Lintian Result

Full worker log Full build log