Run of scrub-obsolete for python-werkzeug

Try this locally (using the lintian-brush package):

debcheckout python-werkzeug
cd python-werkzeug
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/python-werkzeug scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 0f2cb2d..213ad54 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,6 +12,11 @@ python-werkzeug (1.0.1+dfsg1-3) UNRELEASED; urgency=medium
     machine-readable debian/copyright).
   * Apply multi-arch hints.
     + python-werkzeug-doc: Add Multi-Arch: foreign.
+  * Remove constraints unnecessary since stretch:
+    + python-werkzeug-doc: Drop versioned constraint on python-werkzeug in
+      Replaces.
+    + python-werkzeug-doc: Drop versioned constraint on python-werkzeug in
+      Breaks.
 
  -- Ondřej Nový <onovy@debian.org>  Thu, 24 Sep 2020 08:51:11 +0200
 
diff --git a/debian/control b/debian/control
index 5e99b8b..f3cabe1 100644
--- a/debian/control
+++ b/debian/control
@@ -62,10 +62,6 @@ Architecture: all
 Depends:
  ${misc:Depends},
  ${sphinxdoc:Depends},
-Replaces:
- python-werkzeug (<< 0.9.3+dfsg-2),
-Breaks:
- python-werkzeug (<< 0.9.3+dfsg-2),
 Multi-Arch: foreign
 Description: documentation for the werkzeug Python library (docs)
  Werkzeug is a lightweight library for interfacing with WSGI. It features

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t scrub-obsolete python-werkzeug-doc
apt install -t scrub-obsolete python3-werkzeug

Lintian Result

Full worker log Full build log