Run of fresh-releases for r-cran-magick

Try this locally (using the lintian-brush package):

debcheckout r-cran-magick
cd r-cran-magick
new-upstream
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
Running ['new-upstream']
Opening branch at https://salsa.debian.org/r-pkg-team/r-cran-magick.git/,branch=master
Cached branch URL https://janitor.debian.net/git/r-cran-magick,branch=master missing: Branch does not exist: Not a branch: "https://janitor.debian.net/git/r-cran-magick/": location is a repository.
Total 617 (delta 346), reused 399 (delta 178), pack-reused 0

Total 14 (delta 0), reused 10 (delta 0), pack-reused 0
4% (42/50)
Total 50 (delta 8), reused 36 (delta 5), pack-reused 0
Workspace ready - starting.
Using upstream branch https://github.com/ropensci/magick.git (from configuration)
)
Total 6239 (delta 95), reused 97 (delta 40), pack-reused 6062
Using version string 2.7.1.
No upstream upstream-revision format specified, trying tag:2.6.0+dfsg
No upstream upstream-revision format specified, trying tag:r-cran-magick-2.6.0+dfsg
No upstream upstream-revision format specified, trying tag:v2.6.0+dfsg
No upstream upstream-revision format specified, trying tag:v.2.6.0+dfsg
Old upstream version '2.6.0+dfsg' is not present in upstream branch <UpstreamBranchSource for 'https://github.com/ropensci/magick.git/'>. Unable to determine whether upstream history is normally included. Assuming no.
Using uscan to look for the upstream tarball.
Imported r-cran-magick_2.7.1.orig.tar.xz with pristine-tar.
All changes applied successfully.
Committing to: /tmp/tmplt2b2g05/r-cran-magick/
modified DESCRIPTION
modified MD5
modified NAMESPACE
modified NEWS
modified R/RcppExports.R
modified R/base.R
modified R/color.R
modified R/composite.R
modified R/effects.R
modified R/threshold.R
modified build/vignette.rds
modified debian/changelog
modified man/color.Rd
modified man/composite.Rd
modified man/effects.Rd
modified man/thresholding.Rd
modified src/Makevars.win
modified src/RcppExports.cpp
modified src/color.cpp
modified src/composite.cpp
modified src/transformations.cpp
Committed revision 43.
Merged new upstream version 2.7.1 (previous: 2.6.0+dfsg)
Opened schroot session unstable-amd64-sbuild-649c4ef7-7615-4d15-9509-d41a4adffe23 (from unstable-amd64-sbuild)
Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7f7a3af1ed00>, [functools.partial(<function python_tie_breaker at 0x7f7a3aef08b0>, <GitWorkingTree of /tmp/tmplt2b2g05/r-cran-magick>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/unstable-amd64-sbuild-649c4ef7-7615-4d15-9509-d41a4adffe23'), <function popcon_tie_breaker at 0x7f7a2a607430>]))]
Building debian packages, running 'sbuild -A -v -c unstable-amd64-sbuild'.
Attempting to use fixer upstream requirement fixer(apt) to address MissingPkgConfig('Magick++', minimum_version=None)
Loading apt contents information
Adding build dependency: libmagick++-6.q16-dev
Committing to: /tmp/tmplt2b2g05/r-cran-magick/
modified debian/control
Committed revision 44.
Building debian packages, running 'sbuild -A -v -c unstable-amd64-sbuild'.
Built r-cran-magick_2.7.1-1~jan+nur1_amd64.changes
Running lintian
Pushing result branch to RemoteVcsManager('https://janitor.debian.net/')

Summary

Merged new upstream version: 2.7.1 (was: 2.6.0+dfsg).

Full worker log Full build log