Run of lintian-fixes for ruby-defaults

Try this locally (using the lintian-brush package):

debcheckout ruby-defaults
cd ruby-defaults
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/ruby-defaults lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 7a4dc7a..f737517 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+ruby-defaults (1:2.7+2) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Wrap long lines in changelog entries: 1.8.1-8.
+  * Set debhelper-compat version in Build-Depends.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Tue, 21 Apr 2020 16:51:16 +0000
+
 ruby-defaults (1:2.7+1) unstable; urgency=medium
 
   * d/control: ruby breaks ruby-bootsnap (<< 1.4.6-1)
@@ -566,8 +574,8 @@ ruby-defaults (1.8.2-1) unstable; urgency=low
 
 ruby-defaults (1.8.1-8) unstable; urgency=low
 
-  * debian/rules: make symlink for usr/bin/testrb and usr/share/man/man1/testrb.1.gz
-    closes: Bug#257608
+  * debian/rules: make symlink for usr/bin/testrb and
+    usr/share/man/man1/testrb.1.gz closes: Bug#257608
   * debian/control: rdoc section move to doc
 
  -- Fumitoshi UKAI <ukai@debian.or.jp>  Tue,  6 Jul 2004 00:20:59 +0900
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index 48082f7..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-12
diff --git a/debian/control b/debian/control
index a46bc72..19f4e0c 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Priority: optional
 Maintainer: Debian Ruby Team <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
 Uploaders: Antonio Terceiro <terceiro@debian.org>,
            Lucas Kanashiro <kanashiro@debian.org>
-Build-Depends: debhelper (>= 12~)
+Build-Depends: debhelper-compat (= 12)
 Standards-Version: 4.5.0
 Homepage: https://www.ruby-lang.org/
 Vcs-Git: https://salsa.debian.org/ruby-team/ruby-defaults.git
@@ -115,4 +115,3 @@ Description: Ruby full installation (default version)
  .
  This package is a dependency package, which depends on Debian's default Ruby
  version (currently v2.7).
-

Publish History

  • 2020-04-21T21:52: Successfully pushed (Success)

Full worker log Full build log