Run of lintian-fixes for ruby-narray-miss

Try this locally (using the lintian-brush package):

debcheckout ruby-narray-miss
cd ruby-narray-miss
lintian-brush

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 9826e1e..a9eb4ec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,12 @@
 ruby-narray-miss (1.4.0-3) UNRELEASED; urgency=medium
 
+  [ Bas Couwenberg ]
   * Bump Standards-Version to 4.4.0, no changes.
   * Add gbp.conf to use pristine-tar & --source-only-changes by default.
 
+  [ Debian Janitor ]
+  * Bump debhelper from old 9 to 12.
+
  -- Bas Couwenberg <sebastic@debian.org>  Sun, 05 Aug 2018 20:31:58 +0200
 
 ruby-narray-miss (1.4.0-2) unstable; urgency=medium
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 1d28ca5..dca61d7 100644
--- a/debian/control
+++ b/debian/control
@@ -3,10 +3,10 @@ Maintainer: Debian GIS Project <pkg-grass-devel@lists.alioth.debian.org>
 Uploaders: Youhei SASAKI <uwabami@gfd-dennou.org>
 Section: ruby
 Priority: optional
-Build-Depends: debhelper (>= 9.0~),
-               gem2deb (>= 0.3.0~),
+Build-Depends: gem2deb (>= 0.3.0~),
                ruby-narray,
-               rdtool
+               rdtool,
+               debhelper-compat (= 12)
 Standards-Version: 4.4.0
 Vcs-Browser: https://salsa.debian.org/debian-gis-team/narray-miss
 Vcs-Git: https://salsa.debian.org/debian-gis-team/narray-miss.git

Full worker log Full build log