Run of fresh-releases for ruby-puppet-forge

Try this locally package):

debcheckout ruby-puppet-forge
cd ruby-puppet-forge
DEB_UPDATE_CHANGELOG=auto deb-new-upstream --refresh-patches
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
[2022-03-15 22:17:49] Opening branch at https://salsa.debian.org/puppet-team/ruby-puppet-forge.git/,branch=master
[2022-03-15 22:17:50] Using cached branch https://janitor.debian.net/git/ruby-puppet-forge/,branch=debian%2Flatest
[2022-03-15 22:17:51] 53)
[2022-03-15 22:17:52] Total 1453 (delta 139), reused 74 (delta 0), pack-reused 1200
[2022-03-15 22:17:52] 
[2022-03-15 22:17:54] Total 24 (delta 2), reused 24 (delta 2), pack-reused 0
[2022-03-15 22:17:54] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-03-15 22:17:54] Total 8 (delta 0), reused 0 (delta 0), pack-reused 8
[2022-03-15 22:17:54] 
[2022-03-15 22:17:55] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-03-15 22:17:55] Workspace ready - starting.
[2022-03-15 22:17:55] Running ['deb-new-upstream', '--refresh-patches']
[2022-03-15 22:17:55] Assuming changelog does not need to be updated, since changelog entries are usually updated in separate commits.
Using upstream branch https://github.com/puppetlabs/forge-ruby.git (from configuration)
Total 1121 (delta 91), reused 149 (delta 56), pack-reused 899
Using version string 3.2.0.
No upstream upstream-revision format specified, trying tag:3.0.0
No upstream upstream-revision format specified, trying tag:ruby-puppet-forge-3.0.0
No upstream upstream-revision format specified, trying tag:v3.0.0
Not including upstream history, since previous upstream version (3.0.0) is not present in packaging branch history.
Using uscan to look for the upstream tarball.
Searching for revision importing ruby-puppet-forge version 3.0.0 on branch upstream, packaging branch, tag debian/3.0.0-1.
Upstream import of 3.0.0 lacks a tag. Set one by running: brz tag -rrevid:git-v1:759b08d25129c76fc513e1818c52919dbfdc51fa upstream/3.0.0
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.2.9 points at non-present sha 026e52a8a7bbca2c18e49191d08c3be573ecee72
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.1.2-1 points at non-present sha fa627d78fa18b4adbe2a84fd15cfcb19894ce837
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/3.0.0 points at non-present sha 45385e04ef1b3fcb759300fca3a3fcf6a8743fc0
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.2.7 points at non-present sha a5db4f1a32b42df01de574d6fe8d9d37b3ff259e
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.3.2 points at non-present sha aefbc6c758dc83525017ff19ec0873f8ae67aff9
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.1.1 points at non-present sha 942e4ca71e335c1774a78b96870c3fb6a15c5583
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.1.1-1 points at non-present sha 59296c9275a5022308ff45eeaf78078c78363af4
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.2-1 points at non-present sha f02c9c1fedaa025dbc455c968f6a15e330acc4d0
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.3.4 points at non-present sha 7f4c54cc61d5b7f6a7794a0e4fe289cd0e6c3892
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.9-1 points at non-present sha c5af54b774d688f74b9dd18286395f31745a66df
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.7-1 points at non-present sha 5347dc3001f7d02ed554a9c7c7d219b92ff92a60
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.2.2 points at non-present sha 77ae9b48acca5d5914b02328aa7d4c0d1ba65231
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.9-2 points at non-present sha 424b2a1b7802b60dde44a0db766a1fe00a6b6b2a
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.3.2-1 points at non-present sha 4195f17b715d410c91655599083596d2fdee7904
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.2.4 points at non-present sha 18301189ecc43c2b3baafe771ef7431e1bafbfde
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.1.2 points at non-present sha 389abf6be8d35cc03481f8f0377f4bb7d9e7eb0d
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.1.3-1 points at non-present sha d16141ceb046ebc8f5c5bb6b928fe654f8dd903d
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/3.0.0-1 points at non-present sha 504d52d80279a164f519edb4c9349eb207a6d1d5
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.9-3 points at non-present sha 4368c5a42d51dc93d0f031f3fa6cf1009e511d11
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.1.5-1 points at non-present sha db75d14815f7ea8631aee7a335a33d1cb6589889
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.2-2 points at non-present sha 38dc4a005e519dedc27b74893099e1b1bc743fd1
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.1.5 points at non-present sha 775aa4f79b7cc49d02cd089b509fd5ec98a26f55
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/2.1.3 points at non-present sha 25cca0e5e796d32850f53afc2e7eacaba97e906c
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.4-1 points at non-present sha c5c5b077af43c4acc0c0338eebb1e1c5b587b498
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/2.2.7-2 points at non-present sha 1a136dc84fe5495bafe8b82782f47ffc20279e3a
  warnings.warn(
upstream/2.2.9 does not point to a valid object
debian/2.1.2-1 does not point to a valid object
upstream/3.0.0 does not point to a valid object
upstream/2.2.7 does not point to a valid object
upstream/2.3.2 does not point to a valid object
upstream/2.1.1 does not point to a valid object
debian/2.1.1-1 does not point to a valid object
debian/2.2.2-1 does not point to a valid object
upstream/2.3.4 does not point to a valid object
debian/2.2.9-1 does not point to a valid object
debian/2.2.7-1 does not point to a valid object
upstream/2.2.2 does not point to a valid object
debian/2.2.9-2 does not point to a valid object
debian/2.3.2-1 does not point to a valid object
upstream/2.2.4 does not point to a valid object
upstream/2.1.2 does not point to a valid object
debian/2.1.3-1 does not point to a valid object
debian/3.0.0-1 does not point to a valid object
debian/2.2.9-3 does not point to a valid object
debian/2.1.5-1 does not point to a valid object
debian/2.2.2-2 does not point to a valid object
upstream/2.1.5 does not point to a valid object
upstream/2.1.3 does not point to a valid object
debian/2.2.4-1 does not point to a valid object
debian/2.2.7-2 does not point to a valid object
Imported ruby-puppet-forge_3.2.0.orig.tar.gz with pristine-tar.
All changes applied successfully.
gbp:error: revision 'debian/3.0.0-1^0' not found
revision 'debian/3.0.0-1^0' not found
Committing to: /tmp/janitorrx7yt2zm/ruby-puppet-forge/
modified .github/workflows/ruby-rspec.yml
modified .gitignore
modified CHANGELOG.md
modified README.md
modified Rakefile
modified debian/changelog
modified lib/puppet_forge.rb
modified lib/puppet_forge/connection.rb
modified lib/puppet_forge/connection/connection_failure.rb
modified lib/puppet_forge/error.rb
modified lib/puppet_forge/lazy_relations.rb
modified lib/puppet_forge/unpacker.rb
modified lib/puppet_forge/v3/metadata.rb
modified lib/puppet_forge/v3/release.rb
modified lib/puppet_forge/version.rb
deleted locales
deleted locales/config.yaml
modified puppet_forge.gemspec
modified spec/fixtures/v3/modules.json
modified spec/fixtures/v3/modules/puppetlabs-apache.json
modified spec/fixtures/v3/modules__owner=puppetlabs.json
modified spec/fixtures/v3/modules__query=apache.json
modified spec/fixtures/v3/releases.json
modified spec/fixtures/v3/releases/puppetlabs-apache-0.1.1.json
modified spec/fixtures/v3/releases__module=puppetlabs-apache.json
modified spec/unit/forge/connection_spec.rb
Committed revision 76.
Merged new upstream version 3.2.0 (previous: 3.0.0)
Refresh quilt patches.
An error occurred refreshing quilt patch 001_locale_path.patch: 

Applying patch debian/patches/001_locale_path.patch
patching file lib/puppet_forge.rb
Hunk #1 FAILED at 15.
1 out of 1 hunk FAILED -- rejects in file lib/puppet_forge.rb
Patch debian/patches/001_locale_path.patch does not apply (enforce with -f)

Full worker log