Run of fresh-snapshots for ruby-rails-deprecated-sanitizer

Try this locally (using silver-platter):

debian-svp new-upstream --snapshot ruby-rails-deprecated-sanitizer 

Merge these changes:

Summary

Merged new upstream version: 1.0.4 (was: 1.0.3).

Diff

Branch: main

diff --git a/.travis.yml b/.travis.yml
index 962af04..a13d1a7 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,11 +1,9 @@
 language: ruby
+before_install:
+  - gem install bundler -v '2.0.2'
 rvm:
-  - 1.9.3
-  - 2.0.0
-  - 2.1
-  - rbx-2
-  - jruby
-  - ruby-head
+  - 2.5
+  - 2.6
 matrix:
   fast_finish: true
   allow_failures:
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 30712ab..3ed1736 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,7 @@
+## 1.0.4
+
+* Rails 6 support https://github.com/rails/rails-deprecated_sanitizer/pull/6
+
 ## 1.0.3
 
 * Improved support for Rails 4.2.0.beta2 and above.
diff --git a/LICENSE.txt b/LICENSE
similarity index 100%
rename from LICENSE.txt
rename to LICENSE
diff --git a/README.md b/README.md
index f89b9a8..d55ef8b 100644
--- a/README.md
+++ b/README.md
@@ -3,7 +3,7 @@
 In Rails 4.2 HTML sanitization has been rewritten using a more secure library.
 
 This gem includes the old behavior shipping with Rails 4.2 and before. It is
-strictly provided to ease migration. It will be supported until Rails 5.
+strictly provided to ease migration.
 
 To downgrade add `gem 'rails-deprecated_sanitizer'` to your Gemfile.
 
diff --git a/debian/changelog b/debian/changelog
index f14db75..512e1a4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-ruby-rails-deprecated-sanitizer (1.0.3-4) UNRELEASED; urgency=medium
+ruby-rails-deprecated-sanitizer (1.0.4-1) UNRELEASED; urgency=medium
 
   [ Utkarsh Gupta ]
   * Add salsa-ci.yml
@@ -10,7 +10,7 @@ ruby-rails-deprecated-sanitizer (1.0.3-4) UNRELEASED; urgency=medium
     Repository-Browse.
   * Update watch file format version to 4.
 
- -- Utkarsh Gupta <guptautkarsh2102@gmail.com>  Tue, 13 Aug 2019 06:58:02 +0530
+ -- Utkarsh Gupta <guptautkarsh2102@gmail.com>  Mon, 05 Apr 2021 07:57:34 -0000
 
 ruby-rails-deprecated-sanitizer (1.0.3-3) unstable; urgency=medium
 
diff --git a/lib/rails/deprecated_sanitizer.rb b/lib/rails/deprecated_sanitizer.rb
index 85276a9..cd7f2d6 100644
--- a/lib/rails/deprecated_sanitizer.rb
+++ b/lib/rails/deprecated_sanitizer.rb
@@ -18,6 +18,10 @@ module Rails
     def white_list_sanitizer
       HTML::WhiteListSanitizer
     end
+
+    def safe_list_sanitizer
+      HTML::WhiteListSanitizer
+    end
   end
 end
 
diff --git a/lib/rails/deprecated_sanitizer/version.rb b/lib/rails/deprecated_sanitizer/version.rb
index 697dbb5..b1b6190 100644
--- a/lib/rails/deprecated_sanitizer/version.rb
+++ b/lib/rails/deprecated_sanitizer/version.rb
@@ -1,5 +1,5 @@
 module Rails
   module DeprecatedSanitizer
-    VERSION = "1.0.3"
+    VERSION = "1.0.4"
   end
 end
diff --git a/rails-deprecated_sanitizer.gemspec b/rails-deprecated_sanitizer.gemspec
index c96f9f5..0bd1d00 100644
--- a/rails-deprecated_sanitizer.gemspec
+++ b/rails-deprecated_sanitizer.gemspec
@@ -18,6 +18,6 @@ Gem::Specification.new do |spec|
 
   spec.add_dependency "activesupport", ">= 4.2.0.alpha"
 
-  spec.add_development_dependency "bundler", "~> 1.6"
+  spec.add_development_dependency "bundler", "~> 2.0"
   spec.add_development_dependency "rake"
 end

Branch: pristine-tar

diff --git a/ruby-rails-deprecated-sanitizer_1.0.4.orig.tar.gz.delta b/ruby-rails-deprecated-sanitizer_1.0.4.orig.tar.gz.delta
new file mode 100644
index 0000000..161d823
Binary files /dev/null and b/ruby-rails-deprecated-sanitizer_1.0.4.orig.tar.gz.delta differ
diff --git a/ruby-rails-deprecated-sanitizer_1.0.4.orig.tar.gz.id b/ruby-rails-deprecated-sanitizer_1.0.4.orig.tar.gz.id
new file mode 100644
index 0000000..b95b38e
--- /dev/null
+++ b/ruby-rails-deprecated-sanitizer_1.0.4.orig.tar.gz.id
@@ -0,0 +1 @@
+bf5a03fc3a80918cc60ce90190f20aaa5e93e66f

Branch: upstream

Tag: upstream/1.0.4

Diff is too long (more than 200 lines). Download the raw diff.

Debdiff

[The following lists of changes regard files as different if they have different names, permissions or owners.]

Files in second set of .debs but not in first

-rw-r--r--  root/root   /usr/share/rubygems-integration/all/specifications/rails-deprecated_sanitizer-1.0.4.gemspec

Files in first set of .debs but not in second

-rw-r--r--  root/root   /usr/share/rubygems-integration/all/specifications/rails-deprecated_sanitizer-1.0.3.gemspec

No differences were encountered in the control files

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t fresh-snapshots ruby-rails-deprecated-sanitizer

Lintian Result

Full worker log Full build log Full dist log