Run of fresh-releases for ruby-sshkit

Try this locally package):

debcheckout ruby-sshkit
cd ruby-sshkit
DEB_UPDATE_CHANGELOG=auto deb-new-upstream --refresh-patches
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
[2022-03-14 23:09:24] Opening branch at https://salsa.debian.org/ruby-team/ruby-sshkit.git/,branch=master
[2022-03-14 23:09:25] Using cached branch https://janitor.debian.net/git/ruby-sshkit/,branch=debian%2Flatest
[2022-03-14 23:09:27] Total 768 (delta 54), reused 0 (delta 0), pack-reused 702
[2022-03-14 23:09:28] Total 36 (delta 0), reused 36 (delta 0), pack-reused 0
[2022-03-14 23:09:28] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-03-14 23:09:28] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-03-14 23:09:29] Total 0 (delta 0), reused 0 (delta 0), pack-reused 0
[2022-03-14 23:09:29] Workspace ready - starting.
[2022-03-14 23:09:29] Running ['deb-new-upstream', '--refresh-patches']
Using upstream branch https://github.com/capistrano/sshkit.git (from configuration)
Total 4622 (delta 26), reused 68 (delta 25), pack-reused 4545
Using version string 1.21.2.
No upstream upstream-revision format specified, trying tag:1.20.0
No upstream upstream-revision format specified, trying tag:ruby-sshkit-1.20.0
No upstream upstream-revision format specified, trying tag:v1.20.0
Not including upstream history, since previous upstream version (1.20.0) is not present in packaging branch history.
Using uscan to look for the upstream tarball.
Searching for revision importing ruby-sshkit version 1.20.0 on branch upstream, packaging branch, tag debian/1.20.0-2, tag debian/1.20.0-1.
Upstream import of 1.20.0 lacks a tag. Set one by running: brz tag -rrevid:git-v1:5dbfd685b927644d7a4a049385e194c8b01817aa upstream/1.20.0
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.7.1 points at non-present sha 525c07d7503af27c06f9daf2b7bafa9c3f855a9b
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.9.0-1 points at non-present sha 601738cab15fb55476e58042b93d4d26ffed3015
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.9.0_rc1 points at non-present sha c0fb02fc4e56c0afc43400fdbd141cc67ed530a3
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.13.1 points at non-present sha ed989bbf30abf8aafac1bde0440b9fefdaa803d0
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.4.0-1 points at non-present sha 37dffe430c69d2c1af59e0246b2a90a98ccea6af
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.16.0-1 points at non-present sha 791daf70759b2ba264aa09b15698770b67224d76
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.8.0 points at non-present sha 4d4313a9440ec05c6ab797b5c920dc233be5612d
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.16.0 points at non-present sha 60e78d1bb9ae75dbaa0188aa0916e695051ff90f
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.20.0-2 points at non-present sha eb769b225c4c8d9d99327d93143781414a304afd
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.11.4 points at non-present sha 4149070872bc7cbcf0988bcddeb97c11fe163236
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.20.0-1 points at non-present sha aa1435fbbb541f15a64b4d58ce1c86f400396ddf
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.7.1-1 points at non-present sha 807d20459ff89ef019c20c998fae055e67b3516f
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.20.0 points at non-present sha 6a5bf9bb30c6e3fc44f80c0609146d673ffa1b5a
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.9.0 points at non-present sha 1b949f5f5a2eb4879da4ebbe061e1bb19ad7b4bc
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/upstream/1.4.0 points at non-present sha e98779769b7a209bc2b50e7a169eda03516f262f
  warnings.warn(
/code/dulwich/dulwich/repo.py:496: UserWarning: ref refs/tags/debian/1.9.0_rc1-1 points at non-present sha cbb3007589224ed23b8208a6849e3dc6f5b82785
  warnings.warn(
upstream/1.7.1 does not point to a valid object
debian/1.9.0-1 does not point to a valid object
upstream/1.9.0_rc1 does not point to a valid object
upstream/1.13.1 does not point to a valid object
debian/1.4.0-1 does not point to a valid object
debian/1.16.0-1 does not point to a valid object
upstream/1.8.0 does not point to a valid object
upstream/1.16.0 does not point to a valid object
debian/1.20.0-2 does not point to a valid object
upstream/1.11.4 does not point to a valid object
debian/1.20.0-1 does not point to a valid object
debian/1.7.1-1 does not point to a valid object
upstream/1.20.0 does not point to a valid object
upstream/1.9.0 does not point to a valid object
upstream/1.4.0 does not point to a valid object
debian/1.9.0_rc1-1 does not point to a valid object
Imported ruby-sshkit_1.21.2.orig.tar.gz with pristine-tar.
All changes applied successfully.
Committing to: /tmp/janitormxz9h4mq/ruby-sshkit/
added .github
added .github/release-drafter.yml
added .github/workflows
added .github/workflows/push.yml
modified .rubocop.yml
modified .travis.yml
modified CHANGELOG.md
modified Dangerfile
modified EXAMPLES.md
modified Gemfile
modified README.md
modified RELEASING.md
modified Rakefile
modified Vagrantfile
modified debian/changelog
modified examples/simple_connection.rb
modified lib/sshkit/backends/connection_pool/cache.rb
modified lib/sshkit/command.rb
modified lib/sshkit/version.rb
modified sshkit.gemspec
modified test/functional/backends/test_local.rb
modified test/functional/backends/test_netssh.rb
modified test/helper.rb
modified test/unit/formatters/test_pretty.rb
Committed revision 61.
Merged new upstream version 1.21.2 (previous: 1.20.0)
Refresh quilt patches.
An error occurred refreshing quilt patch 001_disabled-rubygems-bundler.patch: 

Applying patch debian/patches/001_disabled-rubygems-bundler.patch
patching file test/helper.rb
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- rejects in file test/helper.rb
Patch debian/patches/001_disabled-rubygems-bundler.patch does not apply (enforce with -f)

Full worker log