Run of cme for rust-condure

Try this locally (using the cme package):

debcheckout rust-condure
cd rust-condure
DEB_UPDATE_CHANGELOG=auto cme fix dpkg
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
Warning in 'control source Standards-Version': Current standards version is '4.5.1'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version '4.4.1' to '4.5.1'.

Offending value: '4.4.1'
Warning in 'control source Build-Depends:0': debhelper dependency version is too old (11). It should be 13
Offending value: 'debhelper (>= 11)'
Warning in 'control source Build-Depends:0': debhelper dependency is deprecated. It should be a dependency for debhelper-compat package
Offending value: 'debhelper (>= 11)'
Warning in 'control source Build-Depends:5': package librust-arrayvec-0.5+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-arrayvec-0.5+default-dev'
Warning in 'control source Build-Depends:6': package librust-base64-0.12+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-base64-0.12+default-dev'
Warning in 'control source Build-Depends:7': package librust-clap-2+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-clap-2+default-dev (>= 2.33-~~)'
Warning in 'control source Build-Depends:8': package librust-clap-2+wrap-help-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-clap-2+wrap-help-dev (>= 2.33-~~)'
Warning in 'control source Build-Depends:9': package librust-httparse-1+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-httparse-1+default-dev (>= 1.3-~~)'
Warning in 'control source Build-Depends:10': package librust-iovec-0.1+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-iovec-0.1+default-dev'
Warning in 'control source Build-Depends:11': package librust-log-0.4+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-log-0.4+default-dev'
Warning in 'control source Build-Depends:12': package librust-mio-0.6+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-mio-0.6+default-dev'
Warning in 'control source Build-Depends:13': package librust-openssl-0.10+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-openssl-0.10+default-dev'
Warning in 'control source Build-Depends:14': package librust-sha1-0.6+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-sha1-0.6+default-dev'
Warning in 'control source Build-Depends:15': package librust-signal-hook-0.1+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-signal-hook-0.1+default-dev'
Warning in 'control source Build-Depends:16': package librust-signal-hook-0.1+mio-support-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-signal-hook-0.1+mio-support-dev'
Warning in 'control source Build-Depends:17': package librust-slab-0.4+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-slab-0.4+default-dev'
Warning in 'control source Build-Depends:18': package librust-time-0.1+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-time-0.1+default-dev'
Warning in 'control source Build-Depends:19': package librust-zmq-0.9+default-dev is unknown. Check for typos if not a virtual package.
Offending value: 'librust-zmq-0.9+default-dev'
double entry for copyright Files:"*" Copyright, appending value
Traceback (most recent call last):
  File "/code/janitor/pull_worker.py", line 262, in run_worker
    with process_package(
  File "/usr/lib/python3.9/contextlib.py", line 117, in __enter__
    return next(self.gen)
  File "/code/janitor/worker.py", line 830, in process_package
    changer_result = build_target.make_changes(
  File "/code/janitor/worker.py", line 495, in make_changes
    return self.changer.make_changes(
  File "/code/janitor/worker.py", line 394, in make_changes
    command_result = debian_script_runner(
  File "/code/silver-platter/silver_platter/debian/apply.py", line 201, in script_runner
    new_revision = local_tree.commit(result.description, allow_pointless=False)
  File "/code/breezy/breezy/mutabletree.py", line 167, in commit
    committed_id = commit.Commit().commit(working_tree=self,
  File "/code/breezy/breezy/commit.py", line 425, in commit
    self.rev_id = self.builder.commit(self.message)
  File "/code/breezy/breezy/git/commit.py", line 181, in commit
    self._validate_unicode_text(message, 'commit message')
  File "/code/breezy/breezy/repository.py", line 146, in _validate_unicode_text
    raise ValueError('Invalid value for %s: %r' % (context, text))
ValueError: Invalid value for commit message: '\rReading package lists... 0%\r\rReading package lists... 0%\r\rReading package lists... 0%\r\rReading package lists... 99%\r\rReading package lists... 99%\r\rReading package lists... Done\r\n\rBuilding dependency tree... 0%\r\rBuilding dependency tree... 0%\r\rBuilding dependency tree... 50%\r\rBuilding dependency tree... 50%\r\rBuilding dependency tree... 97%\r\rBuilding dependency tree... Done\r\n\rReading state information... 0% \r\rReading state information... 0%\r\rReading state information... Done\r\nConnecting to api.ftp-master.debian.org to check 20 package versions. Please wait...\nGot info from api.ftp-master.debian.org for 5 packages.\nConnecting to api.ftp-master.debian.org to check librust-arrayvec-0.5+default-dev versions. Please wait...\ngot no info for librust-arrayvec-0.5+default-dev\nConnecting to api.ftp-master.debian.org to check librust-base64-0.12+default-dev versions. Please wait...\ngot no info for librust-base64-0.12+default-dev\nConnecting to api.ftp-master.debian.org to check librust-clap-2+default-dev versions. Please wait...\ngot no info for librust-clap-2+default-dev\nConnecting to api.ftp-master.debian.org to check librust-clap-2+wrap-help-dev versions. Please wait...\ngot no info for librust-clap-2+wrap-help-dev\nConnecting to api.ftp-master.debian.org to check librust-httparse-1+default-dev versions. Please wait...\ngot no info for librust-httparse-1+default-dev\nConnecting to api.ftp-master.debian.org to check librust-iovec-0.1+default-dev versions. Please wait...\ngot no info for librust-iovec-0.1+default-dev\nConnecting to api.ftp-master.debian.org to check librust-log-0.4+default-dev versions. Please wait...\ngot no info for librust-log-0.4+default-dev\nConnecting to api.ftp-master.debian.org to check librust-mio-0.6+default-dev versions. Please wait...\ngot no info for librust-mio-0.6+default-dev\nConnecting to api.ftp-master.debian.org to check librust-openssl-0.10+default-dev versions. Please wait...\ngot no info for librust-openssl-0.10+default-dev\nConnecting to api.ftp-master.debian.org to check librust-sha1-0.6+default-dev versions. Please wait...\ngot no info for librust-sha1-0.6+default-dev\nConnecting to api.ftp-master.debian.org to check librust-signal-hook-0.1+default-dev versions. Please wait...\ngot no info for librust-signal-hook-0.1+default-dev\nConnecting to api.ftp-master.debian.org to check librust-signal-hook-0.1+mio-support-dev versions. Please wait...\ngot no info for librust-signal-hook-0.1+mio-support-dev\nConnecting to api.ftp-master.debian.org to check librust-slab-0.4+default-dev versions. Please wait...\ngot no info for librust-slab-0.4+default-dev\nConnecting to api.ftp-master.debian.org to check librust-time-0.1+default-dev versions. Please wait...\ngot no info for librust-time-0.1+default-dev\nConnecting to api.ftp-master.debian.org to check librust-zmq-0.9+default-dev versions. Please wait...\ngot no info for librust-zmq-0.9+default-dev\n\nChanges applied to dpkg configuration:\n- control source Standards-Version: \'4.4.1\' -> \'4.5.1\' # applied fix for :Current standards version is \'4.5.1\'. Please read https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the changes that may be needed on your package to upgrade it from standard version \'4.4.1\' to \'4.5.1\'.\n\n- control source Build-Depends:0: \'debhelper (>= 11)\' -> \'debhelper-compat (= 13)\' # applied fix for :Set debhelper dependency version to 13~; changed debhelper dependency to debhelper dependency\n- copyright Files:"*" Copyright: \'2020 Justin Karneges <justin@fanout.io>\' -> \'2020 Justin Karneges <justin@fanout.io> 2020 Fanout, Inc.\' # conflicting initial values\n- patches:"rustc-1.43-compat.diff" Synopsis has new value: \'Rustc 1.43 compat.diff\' # applied fix for :Empty synopsis\n- patches:"disable-lib.diff" Synopsis has new value: \'Disable lib.diff\' # applied fix for :Empty synopsis\n\n'

Full worker log