Run of scrub-obsolete for ssl-cert

Try this locally (using the lintian-brush package):

debcheckout ssl-cert
cd ssl-cert
deb-scrub-obsolete

Merge these changes:

git pull https://janitor.debian.net/git/ssl-cert scrub-obsolete/main

Diff

diff --git a/debian/changelog b/debian/changelog
index 67a1e77..4753c83 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,7 +1,13 @@
 ssl-cert (1.0.40) UNRELEASED; urgency=medium
 
+  [ Stefan Fritsch ]
   * Migrate from alioth to salsa
 
+  [ Debian Janitor ]
+  * Remove constraints unnecessary since stretch:
+    + Build-Depends: Drop versioned constraint on debhelper.
+    + ssl-cert: Drop versioned constraint on openssl in Depends.
+
  -- Stefan Fritsch <sf@debian.org>  Tue, 01 May 2018 10:30:06 +0200
 
 ssl-cert (1.0.39) unstable; urgency=medium
diff --git a/debian/control b/debian/control
index 70b396f..95844fe 100644
--- a/debian/control
+++ b/debian/control
@@ -3,14 +3,14 @@ Section: utils
 Priority: optional
 Maintainer: Debian Apache Maintainers <debian-apache@lists.debian.org>
 Uploaders: Tollef Fog Heen <tfheen@debian.org>, Stefan Fritsch <sf@debian.org>
-Build-Depends: debhelper (>= 7), po-debconf
+Build-Depends: debhelper, po-debconf
 Standards-Version: 3.9.8
 Vcs-Browser: https://salsa.debian.org/apache-team/ssl-cert
 Vcs-Git: https://salsa.debian.org/apache-team/ssl-cert.git
 
 Package: ssl-cert
 Architecture: all
-Depends: ${misc:Depends}, openssl (>= 0.9.8g-9), adduser
+Depends: ${misc:Depends}, openssl, adduser
 Suggests: openssl-blacklist
 Multi-Arch: foreign
 Description: simple debconf wrapper for OpenSSL

Debdiff

File lists identical (after any substitutions)

Control files: lines which differ (wdiff format)

  • Depends: debconf (>= 0.5) | debconf-2.0, openssl (>= 0.9.8g-9), openssl, adduser

Publish History

  • 2021-03-26T17:54: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T11:03: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T09:29: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T07:51: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-26T05:34: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T11:50: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T08:36: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-25T03:55: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-24T22:31: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))
  • 2021-03-24T17:04: Failed to create merge proposal: merge-conflict (merge would conflict (upstream changes?))

Full worker log Full build log