Run of cme for swaybg

Try this locally (using the cme package):

debcheckout swaybg
cd swaybg
DEB_UPDATE_CHANGELOG=auto cme fix dpkg

Diff

diff --git a/debian/changelog b/debian/changelog
index c1b53dc..b4eaaec 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,26 @@ swaybg (1.0-3) UNRELEASED; urgency=medium
 
   * Remove constraints unnecessary since buster:
     + Build-Depends: Drop versioned constraint on meson and wayland-protocols.
+  * Reading package lists... 0%Reading package lists... 0%Reading package
+    lists... 0%Reading package lists... 94%Reading package lists... 99%Reading
+    package lists... 99%Reading package lists... Done Building dependency
+    tree... 0%Building dependency tree... 0%Building dependency tree...
+    50%Building dependency tree... 50%Building dependency tree... Done Reading
+    state information... 0% Reading state information... 0%Reading state
+    information... Done Connecting to api.ftp-master.debian.org to check 8
+    package versions. Please wait... Got info from api.ftp-master.debian.org for
+    8 packages.  Changes applied to dpkg configuration: - control source
+    Standards-Version: '4.4.0' -> '4.5.1' # applied fix for :Current standards
+    version is '4.5.1'. Please read
+    https://www.debian.org/doc/debian-policy/upgrading-checklist.html for the
+    changes that may be needed on your package to upgrade it from standard
+    version '4.4.0' to '4.5.1'.  - control binary:swaybg Breaks:0 deleted value:
+    'sway (<< 1.1~rc1)' # applied fix for :unnecessary older-than versioned
+    dependency: sway (<< 1.1~rc1). Debian has stable -> 1.5-7; unstable ->
+    1.5.1-2; testing -> 1.5.1-2; experimental -> 1.6-1; - control binary:swaybg
+    Replaces:0 deleted value: 'sway (<< 1.1~rc1)' # applied fix for :unnecessary
+    older-than versioned dependency: sway (<< 1.1~rc1). Debian has stable ->
+    1.5-7; unstable -> 1.5.1-2; testing -> 1.5.1-2; experimental -> 1.6-1;
 
  -- Debian Janitor <janitor@jelmer.uk>  Sun, 29 Aug 2021 15:29:22 -0000
 
diff --git a/debian/control b/debian/control
index 1a6732e..622c87f 100644
--- a/debian/control
+++ b/debian/control
@@ -1,31 +1,27 @@
 Source: swaybg
-Section: x11
-Priority: optional
 Maintainer: Sway and related packages team <team+swaywm@tracker.debian.org>
 Uploaders: Birger Schacht <birger@rantanplan.org>,
            Nicolas Braud-Santoni <nicoo@debian.org>
-Build-Depends:
- debhelper-compat (= 12),
- meson,
- libwayland-dev,
- wayland-protocols,
- libcairo2-dev,
- libgdk-pixbuf2.0-dev,
- pkgconf,
- scdoc
-Standards-Version: 4.4.0
-Homepage: https://github.com/swaywm/swaybg
+Section: x11
+Priority: optional
+Build-Depends: debhelper-compat (= 12),
+               meson,
+               libwayland-dev,
+               wayland-protocols,
+               libcairo2-dev,
+               libgdk-pixbuf2.0-dev,
+               pkgconf,
+               scdoc
+Standards-Version: 4.5.1
 Vcs-Browser: https://salsa.debian.org/swaywm-team/swaybg
 Vcs-Git: https://salsa.debian.org/swaywm-team/swaybg.git
+Homepage: https://github.com/swaywm/swaybg
 Rules-Requires-Root: no
 
 Package: swaybg
 Architecture: any
-Depends:
- ${shlibs:Depends},
- ${misc:Depends}
-Replaces: sway (<< 1.1~rc1)
-Breaks: sway (<< 1.1~rc1)
+Depends: ${shlibs:Depends},
+         ${misc:Depends}
 Description: Wallpaper utility for Wayland compositors
  swaybg is a wallpaper utility for Wayland compositors. It is compatible with
  any Wayland compositor which implements the following Wayland protocols:

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t cme swaybg-dbgsym
apt install -t cme swaybg

Lintian Result

Full worker log Full build log