Run of cme for tdom

Try this locally (using the cme package):

debcheckout tdom
cd tdom
DEB_UPDATE_CHANGELOG=auto cme fix dpkg

Diff

diff --git a/debian/changelog b/debian/changelog
index c0d61cd..3b40fe8 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,28 @@
+tdom (0.9.2-2) UNRELEASED; urgency=medium
+
+  * Reading package lists... 0%Reading package lists... 0%Reading package
+    lists... 0%Reading package lists... 79%Reading package lists... 93%Reading
+    package lists... 93%Reading package lists... 94%Reading package lists...
+    94%Reading package lists... 95%Reading package lists... 95%Reading package
+    lists... 95%Reading package lists... 95%Reading package lists... 96%Reading
+    package lists... 96%Reading package lists... 96%Reading package lists...
+    96%Reading package lists... Done Building dependency tree... 0%Building
+    dependency tree... 0%Building dependency tree... 50%Building dependency
+    tree... 50%Building dependency tree... Done Reading state information... 0%
+    Reading state information... 0%Reading state information... Done Connecting
+    to api.ftp-master.debian.org to check 4 package versions. Please wait... Got
+    info from api.ftp-master.debian.org for 4 packages.  Changes applied to dpkg
+    configuration: - compat deleted value: '13' - control source
+    Build-Depends:0: 'debhelper (>= 13)' -> 'debhelper-compat (= 13)' # applied
+    fix for :Cleared deprecated compat value; changed debhelper dependency to
+    debhelper dependency - control source Build-Depends:1: 'tcl-dev (>= 8.5)' ->
+    'tcl-dev' # applied fix for :unnecessary greater-than versioned dependency:
+    tcl-dev (>= 8.5). Debian has oldoldoldstable -> 8.6.0+8; oldoldstable ->
+    8.6.0+9; oldstable -> 8.6.9+1; stable -> 8.6.11+1; testing -> 8.6.11+1;
+    unstable -> 8.6.11+1; experimental -> 8.7.0+0~exp2;
+
+ -- Debian Janitor <janitor@jelmer.uk>  Thu, 16 Sep 2021 09:56:41 -0000
+
 tdom (0.9.2-1) unstable; urgency=medium
 
   [Hector Romojaro]
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index b1bd38b..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-13
diff --git a/debian/control b/debian/control
index eeaf5f0..afdb344 100644
--- a/debian/control
+++ b/debian/control
@@ -1,18 +1,25 @@
 Source: tdom
+Maintainer: Tcl/Tk Debian Packagers <pkg-tcltk-devel@lists.alioth.debian.org>
+Uploaders: Hector Romojaro <hector.romojaro@gmail.com>,
+           Stefan Sobernig <stefan.sobernig@wu-wien.ac.at>
 Section: libs
 Priority: optional
-Maintainer: Tcl/Tk Debian Packagers <pkg-tcltk-devel@lists.alioth.debian.org>
-Uploaders: Hector Romojaro <hector.romojaro@gmail.com>, Stefan Sobernig <stefan.sobernig@wu-wien.ac.at>
-Build-Depends: debhelper (>= 13), tcl-dev (>= 8.5), libexpat1-dev, libgumbo-dev, pkg-config
+Build-Depends: debhelper-compat (= 13),
+               tcl-dev,
+               libexpat1-dev,
+               libgumbo-dev,
+               pkg-config
 Standards-Version: 4.5.1
-Homepage: http://tdom.org/
 Vcs-Browser: https://salsa.debian.org/tcltk-team/tdom
 Vcs-Git: https://salsa.debian.org/tcltk-team/tdom.git
+Homepage: http://tdom.org/
 
 Package: tdom
 Architecture: any
 Multi-Arch: same
-Depends: ${tclsh:Depends}, ${shlibs:Depends}, ${misc:Depends}
+Depends: ${tclsh:Depends},
+         ${shlibs:Depends},
+         ${misc:Depends}
 Description: fast XML/DOM/XPath/XSLT/HTML/JSON extension for Tcl written in C
  tDOM takes advantage of Expat, the XML parser from James Clark,
  including namespace and DTD support. It includes a modified version
@@ -26,10 +33,11 @@ Description: fast XML/DOM/XPath/XSLT/HTML/JSON extension for Tcl written in C
  nroff formats.
 
 Package: tdom-dev
-Section: libdevel
 Architecture: any
 Multi-Arch: same
-Depends: tdom (= ${binary:Version}), ${misc:Depends}
+Section: libdevel
+Depends: tdom (= ${binary:Version}),
+         ${misc:Depends}
 Description: header files and development libraries for tDOM
  tDOM is a fast XML/DOM/XPath/XSLT/HTML/JSON extension for Tcl written in C.
  tDOM takes advantage of Expat, the XML parser from James Clark,

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t cme tdom-dbgsym
apt install -t cme tdom-dev
apt install -t cme tdom

Lintian Result

Full worker log Full build log