Run of lintian-fixes for vdr-plugin-osdserver

Try this locally (using the lintian-brush package):

debcheckout vdr-plugin-osdserver
cd vdr-plugin-osdserver
lintian-brush

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 4ca448b..6d1bf6b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+vdr-plugin-osdserver (0.1.3-21) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from old 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 13 Jul 2020 18:59:19 -0000
+
 vdr-plugin-osdserver (0.1.3-20) unstable; urgency=medium
 
   * Standards-Version: 4.4.1
@@ -303,4 +312,3 @@ vdr-plugin-osdserver (0.0.1-1) unstable; urgency=low
   * Initial Release (closes #408663)
 
  -- Tobias Grimm <tg@e-tobi.net>  Sat, 27 Jan 2007 15:26:56 +0100
-
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 82f4c25..0ec69a4 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,8 @@ Section: video
 Priority: optional
 Maintainer: Debian VDR Team <pkg-vdr-dvb-devel@lists.alioth.debian.org>
 Uploaders: Thomas Schmidt <tschmidt@debian.org>, Tobias Grimm <etobi@debian.org>, Thomas G├╝nther <tom@toms-cafe.de>
-Build-Depends: debhelper (>= 9), vdr-dev (>= 2.4.1), pkg-config
-Standards-Version: 4.4.1
+Build-Depends: debhelper-compat (= 12), vdr-dev (>= 2.4.1), pkg-config
+Standards-Version: 4.5.0
 Homepage: http://www.udo-richter.de/vdr/osdserver.en.html
 Vcs-Git: https://salsa.debian.org/vdr-team/vdr-plugin-osdserver.git
 Vcs-Browser: https://salsa.debian.org/vdr-team/vdr-plugin-osdserver

Full worker log Full build log