Run of lintian-fixes for vdr-plugin-vcd

Try this locally (using the lintian-brush package):

debcheckout vdr-plugin-vcd
cd vdr-plugin-vcd
lintian-brush

Merge these changes:

git pull https://janitor.debian.net/git/vdr-plugin-vcd lintian-fixes/main

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 8bb16e1..b4b3547 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+vdr-plugin-vcd (0.9-29) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from deprecated 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 17 Aug 2020 15:17:02 -0000
+
 vdr-plugin-vcd (0.9-28) unstable; urgency=medium
 
   * Standards-Version: 4.4.1
@@ -202,7 +211,7 @@ vdr-plugin-vcd (0.8-2) unstable; urgency=low
    * Switched Build-System to cdbs, Build-Depend on cdbs
    * Bumped Standards-Version to 3.7.3
    * Added Homepage field to debian/control
-   * Renamed XS-Vcs-* fields to Vcs-* in debian/control 
+   * Renamed XS-Vcs-* fields to Vcs-* in debian/control
 
  -- Thomas Schmidt <tschmidt@debian.org>  Fri, 28 Dec 2007 21:59:01 +0100
 
@@ -517,11 +526,11 @@ vdr-plugin-vcd (0.0.6c-1) unstable; urgency=low
     - First upload to the official archive (closes: #273312)
     - New upstream release
     - Added watch-file
-    - Added patchlevel-mechanism, to be compatible with c't-vdr		
+    - Added patchlevel-mechanism, to be compatible with c't-vdr
     - Use dpatch, so build-dep on dpatch
     - Add 01_Makefile-fPIC-fix.dpatch
     - Use dh_install
-    - Changed maintainer to Debian VDR and DVB Packaging Team 
+    - Changed maintainer to Debian VDR and DVB Packaging Team
       <pkg-vdr-dvb-devel@lists.alioth.debian.org>
     - Changed architecture to any
 
@@ -561,7 +570,7 @@ vdr-plugin-vcd (0.0.4i-6) unstable; urgency=low
 vdr-plugin-vcd (0.0.4i-5) unstable; urgency=low
 
   * changed the plugin-dir to /usr/lib/vdr/plugins, to be FHS compliant
-    Thanks to Henning Glawe <glaweh@physik.fu-berlin.de> for pointing me 
+    Thanks to Henning Glawe <glaweh@physik.fu-berlin.de> for pointing me
     to this one
 
  -- Thomas Schmidt <thomas.schmidt@in.stud.tu-ilmenau.de>  Sun, 14 Sep 2003 16:35:01 +0200
@@ -623,7 +632,7 @@ vdr-plugin-vcd (0.0.4f-3) unstable; urgency=low
 
 vdr-plugin-vcd (0.0.4f-2) unstable; urgency=low
 
-  * rebuild for vdr 1.1.25 
+  * rebuild for vdr 1.1.25
 
  -- Thomas Schmidt <thomas.schmidt@in.stud.tu-ilmenau.de>  Wed,  5 Mar 2003 20:15:52 +0100
 
@@ -644,4 +653,3 @@ vdr-plugin-vcd (0.0.4b-1) unstable; urgency=low
   * Initial Release.
 
  -- Thomas Schmidt <thomas.schmidt@in.stud.tu-ilmenau.de>  Sun,  2 Feb 2003 15:21:57 +0100
-
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 6457634..d7638d7 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,8 @@ Section: video
 Priority: optional
 Maintainer: Debian VDR Team <pkg-vdr-dvb-devel@lists.alioth.debian.org>
 Uploaders: Thomas Schmidt <tschmidt@debian.org>, Tobias Grimm <etobi@debian.org>, Thomas G├╝nther <tom@toms-cafe.de>
-Build-Depends: debhelper (>= 9), vdr-dev (>= 2.4.1)
-Standards-Version: 4.4.1
+Build-Depends: debhelper-compat (= 12), vdr-dev (>= 2.4.1)
+Standards-Version: 4.5.0
 Homepage: http://www.vdr.heiligenmann.de/
 Vcs-Git: https://salsa.debian.org/vdr-team/vdr-plugin-vcd.git
 Vcs-Browser: https://salsa.debian.org/vdr-team/vdr-plugin-vcd

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package vdr-plugin-vcd

No differences were encountered between the control files of package vdr-plugin-vcd-dbgsym

Full worker log Full build log