Run of lintian-fixes for vdr-plugin-weather

Try this locally (using the lintian-brush package):

debcheckout vdr-plugin-weather
cd vdr-plugin-weather
lintian-brush

Merge these changes:

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index 101c638..fe1c2e9 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+vdr-plugin-weather (0.2.1e-71) UNRELEASED; urgency=low
+
+  * Trim trailing whitespace.
+  * Bump debhelper from deprecated 9 to 12.
+  * Set debhelper-compat version in Build-Depends.
+  * Update standards version to 4.5.0, no changes needed.
+
+ -- Debian Janitor <janitor@jelmer.uk>  Mon, 24 Aug 2020 17:40:59 -0000
+
 vdr-plugin-weather (0.2.1e-70) unstable; urgency=medium
 
   * Standards-Version: 4.4.1
@@ -428,7 +437,7 @@ vdr-plugin-weather (0.2.1e-11) experimental; urgency=low
   * Thomas Schmidt <tschmidt@debian.org>
     - Added 02_vdr_1.3-fix.dpatch to allow compiling the plugin
       for vdr (>=1.3.23)
-    - Updated debian/watch 
+    - Updated debian/watch
   * Tobias Grimm <tg@e-tobi.net>
     - Depend/Build-Depend on vdr (>=1.3.27-1)
     - Conflict with vdr (>=1.3.28)
@@ -449,7 +458,7 @@ vdr-plugin-weather (0.2.1e-10) unstable; urgency=low
 vdr-plugin-weather (0.2.1e-9) unstable; urgency=low
 
   * Thomas Schmidt <thomas.schmidt@in.stud.tu-ilmenau.de>
-    - Fixed debian/watch and debian/copyright (point to new 
+    - Fixed debian/watch and debian/copyright (point to new
       Upstream URL)
 
  -- Debian VDR Team <pkg-vdr-dvb-devel@lists.alioth.debian.org>  Sat,  4 Dec 2004 12:40:06 +0100
@@ -466,7 +475,7 @@ vdr-plugin-weather (0.2.1e-7) unstable; urgency=low
 
   * Thomas Schmidt <thomas.schmidt@in.stud.tu-ilmenau.de>
     - Build-depend on libmdsp (>= 0.11-6), to make sure the package is
-      compilied with the new libmdsp - hopefully this fixes the 
+      compilied with the new libmdsp - hopefully this fixes the
       FTBFS-problems on hppa and amd64
 
  -- Debian VDR Team <pkg-vdr-dvb-devel@lists.alioth.debian.org>  Sat, 25 Sep 2004 11:31:59 +0200
@@ -474,7 +483,7 @@ vdr-plugin-weather (0.2.1e-7) unstable; urgency=low
 vdr-plugin-weather (0.2.1e-6) unstable; urgency=low
 
   * Thomas Schmidt <thomas.schmidt@in.stud.tu-ilmenau.de>
-    - Changed architecture to any  
+    - Changed architecture to any
     - Added debian/watch
 
  -- Debian VDR Team <pkg-vdr-dvb-devel@lists.alioth.debian.org>  Wed, 18 Aug 2004 00:19:35 +0200
@@ -496,12 +505,12 @@ vdr-plugin-weather (0.2.1e-5) unstable; urgency=low
 vdr-plugin-weather (0.2.1e-4) unstable; urgency=low
 
   * now depends on libmdsp-dev (renamed from mdsplib-dev)
- 
+
  -- Tobias Grimm <tg@e-tobi.net>  Sat, 17 Jan 2004 04:45:00 +0200
 
 vdr-plugin-weather (0.2.1e-3) unstable; urgency=low
 
-  * integrated patchlevel info                                                                                                  
+  * integrated patchlevel info
  -- Peter Siering <ps@ctmagazin.de>  Wed, 14 Jan 2004 18:15:00 +0200
 
 vdr-plugin-weather (0.2.1e-2) unstable; urgency=low
diff --git a/debian/compat b/debian/compat
deleted file mode 100644
index ec63514..0000000
--- a/debian/compat
+++ /dev/null
@@ -1 +0,0 @@
-9
diff --git a/debian/control b/debian/control
index 906e236..049d1b2 100644
--- a/debian/control
+++ b/debian/control
@@ -3,8 +3,8 @@ Section: video
 Priority: optional
 Maintainer: Debian VDR Team <pkg-vdr-dvb-devel@lists.alioth.debian.org>
 Uploaders: Tobias Grimm <etobi@debian.org>, Thomas Schmidt <tschmidt@debian.org>, Thomas G├╝nther <tom@toms-cafe.de>
-Build-Depends: debhelper (>= 9), vdr-dev (>= 2.4.1), libftp-dev, libmdsp-dev (>=0.11-6)
-Standards-Version: 4.4.1
+Build-Depends: debhelper-compat (= 12), vdr-dev (>= 2.4.1), libftp-dev, libmdsp-dev (>= 0.11-6)
+Standards-Version: 4.5.0
 Homepage: http://www.moldaner.de/vdr/
 Vcs-Git: https://salsa.debian.org/vdr-team/vdr-plugin-weather.git
 Vcs-Browser: https://salsa.debian.org/vdr-team/vdr-plugin-weather
@@ -13,5 +13,5 @@ Package: vdr-plugin-weather
 Architecture: any
 Depends: ${shlibs:Depends}, ${misc:Depends}, ${vdr:Depends}
 Description: Weather plugin for VDR
- Displays the current weather conditions for a selected location. 
+ Displays the current weather conditions for a selected location.
  It gets the METAR data from ftp://weather.noaa.gov.

Debdiff

File lists identical (after any substitutions)

No differences were encountered between the control files of package vdr-plugin-weather

No differences were encountered between the control files of package vdr-plugin-weather-dbgsym

Full worker log Full build log