Run of fresh-releases for vmdb2

Try this locally (using the package):

debcheckout vmdb2
cd vmdb2
new-upstream --refresh-patches
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
[2021-05-25 10:56:12] Running ['new-upstream', '--refresh-patches']
[2021-05-25 10:56:12] Opening branch at https://salsa.debian.org/debian/vmdb2.git/,branch=master
[2021-05-25 10:56:13] Using cached branch https://janitor.debian.net/git/vmdb2/,branch=debian%2Flatest
[2021-05-25 10:56:15] Total 2616 (delta 0), reused 0 (delta 0), pack-reused 2616
[2021-05-25 10:56:15] 
[2021-05-25 10:56:18] Total 51 (delta 5), reused 5 (delta 5), pack-reused 46
[2021-05-25 10:56:18] 
[2021-05-25 10:56:21]   69% (317/458)
[2021-05-25 10:56:21]   68% (111/162)
[2021-05-25 10:56:21]   84% (137/162)
[2021-05-25 10:56:21] % (162/162), done.
[2021-05-25 10:56:21] Total 490 (delta 284), reused 424 (delta 275), pack-reused 32
[2021-05-25 10:56:31] All changes applied successfully.
[2021-05-25 10:56:31] Workspace ready - starting.
[2021-05-25 10:56:31] Using upstream branch https://gitlab.com/larswirzenius/vmdb2.git (guessed)
[2021-05-25 10:56:32] 22)
[2021-05-25 10:56:32] (15/22)
[2021-05-25 10:56:32] Total 22 (delta 16), reused 2 (delta 0), pack-reused 0
[2021-05-25 10:56:33] Using version string 0.23.
[2021-05-25 10:56:33] No upstream upstream-revision format specified, trying tag:0.22
[2021-05-25 10:56:33] No upstream upstream-revision format specified, trying tag:vmdb2-0.22
[2021-05-25 10:56:33] Including upstream history, since previous upstream version (0.22) is present in packaging branch history.
[2021-05-25 10:56:33] No upstream upstream-revision format specified, trying tag:0.23
[2021-05-25 10:56:33] No upstream upstream-revision format specified, trying tag:vmdb2-0.23
[2021-05-25 10:56:33] Using uscan to look for the upstream tarball.
[2021-05-25 10:56:37] Searching for revision importing vmdb2 version 0.22 on packaging branch, tag debian/0.22-1.
[2021-05-25 10:56:37] Upstream import of 0.22 lacks a tag. Set one by running: brz tag -rrevid:git-v1:6f81ca9f30e2ffc1002f1622fd88bbb98db48309 upstream/0.22
[2021-05-25 10:57:04] Imported vmdb2_0.23.orig.tar.gz with pristine-tar.
[2021-05-25 10:57:27] Warning: criss-cross merge encountered.  See bzr help criss-cross.
[2021-05-25 10:57:35] All changes applied successfully.
gbp:info: Changelog last touched at '544522a65147d7eaa2ac9fd74eccfec239bcd0ae'
[2021-05-25 10:57:35] Changelog last touched at '544522a65147d7eaa2ac9fd74eccfec239bcd0ae'
gbp:info: Continuing from commit '544522a65147d7eaa2ac9fd74eccfec239bcd0ae'
[2021-05-25 10:57:35] Continuing from commit '544522a65147d7eaa2ac9fd74eccfec239bcd0ae'
gbp:info: No changes detected from 544522a65147d7eaa2ac9fd74eccfec239bcd0ae to HEAD.
[2021-05-25 10:57:35] No changes detected from 544522a65147d7eaa2ac9fd74eccfec239bcd0ae to HEAD.
[2021-05-25 10:57:49] Committing to: /tmp/janitormfy9kf0_/vmdb2/
[2021-05-25 10:57:49] modified NEWS
[2021-05-25 10:57:49] modified debian/changelog
[2021-05-25 10:57:49] modified vmdb/plugins/apt.mdwn
[2021-05-25 10:57:49] modified vmdb/plugins/apt_plugin.py
[2021-05-25 10:57:49] modified vmdb/plugins/mkfs.mdwn
[2021-05-25 10:57:49] modified vmdb/plugins/mkfs_plugin.py
[2021-05-25 10:57:49] modified vmdb/version.py
[2021-05-25 10:57:54] Committed revision 329.
[2021-05-25 10:57:59] Merged new upstream version 0.23 (previous: 0.22)
[2021-05-25 10:57:59] Opened schroot session unstable-amd64-sbuild-1f03cf7e-ab61-49c4-9f7d-b1d455d59df2 (from unstable-amd64-sbuild)
[2021-05-25 10:57:59] Using fixers: [PgBuildExtOutOfDateControlFixer(), SimpleBuildFixer(MissingConfigure, fix_missing_configure), SimpleBuildFixer(MissingAutomakeInput, fix_missing_automake_input), SimpleBuildFixer(MissingConfigStatusInput, fix_missing_config_status_input), SimpleBuildFixer(MissingPerlFile, fix_missing_makefile_pl), SimpleBuildFixer(DebcargoUnacceptablePredicate, coerce_unacceptable_predicate), DependencyBuildFixer(AptFetchFailure, retry_apt_failure), PackageDependencyFixer(AptResolver(<ognibuild.debian.apt.AptManager object at 0x7f548c77fa60>, [functools.partial(<function python_tie_breaker at 0x7f548c81e4c0>, <GitWorkingTree of /tmp/janitormfy9kf0_/vmdb2>, ''), BuildDependencyTieBreaker('/var/run/schroot/mount/unstable-amd64-sbuild-1f03cf7e-ab61-49c4-9f7d-b1d455d59df2'), <function popcon_tie_breaker at 0x7f5483e2dc10>]))]
[2021-05-25 10:57:59] Building debian packages, running 'sbuild -A -s -v'.
[2021-05-25 11:03:24] Built ['vmdb2_0.23-1~jan+nur1_amd64.changes'].
janitor.debian.lintian:info: Running lintian
[2021-05-25 11:03:28] Running lintian
[2021-05-25 11:03:38] Pushing result branch to RemoteVcsManager('https://janitor.debian.net/')
[2021-05-25 11:03:39] warning: ignoring broken ref refs/heads/unchanged/main
[2021-05-25 11:03:40] Pushing packaging branch cache to https://janitor.debian.net/git/vmdb2,branch=debian%2Flatest
[2021-05-25 11:03:48] warning: ignoring broken ref refs/heads/unchanged/main
[2021-05-25 11:03:48] git: cannot lock ref 'refs/heads/debian/latest': is at 544522a65147d7eaa2ac9fd74eccfec239bcd0ae but expected bca57aeb3ea5c627a0b182b88cce06bb753ad0d3
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/upstream/0.19': reference already exists
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/upstream/0.16': is at c881a4daa0febf8d6640f68ec31bb02ac9a262b6 but expected c7fec173cf480fdee0ebfab665efd2acf9aa2a35
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.16-1': is at d5f30807d424c8d44f4d26ad26174dbe1d1f2d01 but expected 8436990296b0c2979ed74fcd1df3b26e86ea2101
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/upstream/0.13.2+git20191220': is at 08ad96d73c046d3102b98b87dd9661a9bb5e7788 but expected dc10a5f31b30f7069c3e49aed4968fda47f3d043
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.22-1': reference already exists
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.13.2+git20191206-1': is at 83c1ccaea2867447055759553889d6bb7bc6ff4c but expected f9d3733644aca7cfa77cd27839f97fd14c4483bf
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/upstream/0.13.2+git20200121': is at 89cfdef45f37a8d57bce71a62be8246ea3f895e9 but expected 666e7da8fee7022c1288596b3cdd6fe11f8fdd38
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.13.2+git20190215-1': is at 645cb5cebbd6ea0f892fd75cff5a0a141bdcb390 but expected 7c41732b71323c6e6a742d5aaa371a50fa9ff216
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.16-2': is at 7c60c6c028c4e0c0f5076fa6754ad7ac1f07822a but expected 155b335a65d1507066c39b8e461df5f34aeeec0f
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.13.2+git20200121-1': is at b4498a7239dbe2821f37d0b83f556369ed648211 but expected f812d01e5406dfd799d6a51cdff970d4c08e7836
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.17-1': is at cbef33d5399a108eca8e226bf450394cdd03de63 but expected d2c6d6bf082d120b3c9bba1055eace608360ebca
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/upstream/0.17': is at ee8545d44cd2d31cca80867ac9c1922ddcdaa850 but expected 504862ce5c7c9a74047e840ecc628f90760f7b81
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/upstream/0.13.2+git20190215': is at c55dbfed3327a3b535a2ae8a1f722bad10d931ea but expected ad6a6cba77668749b137124e4801dab0c8963c19
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.13.2+git20191206-2': is at 66a02632226911554163f103943b8359bc3b00ab but expected 5f135bc4958738b13f870078e50d08922f307eb2
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/upstream/0.13.2+git20190214': is at d062e288602b3715fa499499341f7a29f166e19c but expected 809c7dc1a541d4f6312fd8bdf8fd039da3e78a8f
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.19-1': is at bca57aeb3ea5c627a0b182b88cce06bb753ad0d3 but expected ec7dadbb07e76b7f700c5e49520cb48e5d4c67eb
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.13.2+git20191220-1': is at 3843eff69dc86f4f65ff250a698cda3a3b8b4ddb but expected 82113c6b4fa564fff906b2dbfceb6c7d9d20029a
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.13.2+git20190214-1': is at ce4a8e9b3aad83183211de455183e12f60cf5d19 but expected f5052937e5c23115222453c621abc156c6ff4c13
[2021-05-25 11:03:48] git: cannot lock ref 'refs/tags/debian/0.14-1': is at 607e8114bd4635bd37ab832e7ae8102524024953 but expected 1fd869651c933e024df70bbb3889025578f60b18
Traceback (most recent call last):
  File "/srv/janitor/debian-janitor/janitor/pull_worker.py", line 272, in run_worker
    push_branch(
  File "/srv/janitor/debian-janitor/janitor/pull_worker.py", line 187, in push_branch
    target.push_branch(
  File "/srv/janitor/debian-janitor/breezy/breezy/git/remote.py", line 685, in push_branch
    raise RemoteGitError(error)
breezy.git.remote.RemoteGitError: failed to update ref

Summary

Merged new upstream version: 0.23 (was: 0.22).

Full worker log Full build log