Run of lintian-fixes for x11-apps

Try this locally (using the package):

debcheckout x11-apps
cd x11-apps
DEB_UPDATE_CHANGELOG=auto lintian-brush

Summary

Diff

diff --git a/debian/changelog b/debian/changelog
index dce89fb..bd4f68f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+x11-apps (7.7+9) UNRELEASED; urgency=medium
+
+  * Trim trailing whitespace.
+  * Upgrade to newer source format 3.0 (native).
+
+ -- Debian Janitor <janitor@jelmer.uk>  Wed, 16 Jun 2021 09:21:51 -0000
+
 x11-apps (7.7+8) unstable; urgency=medium
 
   [ Andreas Henriksson ]
diff --git a/debian/rules b/debian/rules
index f6c2d03..cadb5b3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -71,4 +71,3 @@ update-copyright: $(addsuffix /COPYING, $(SUBDIRS)) debian/copyright.head
 		echo $$subdir: >> debian/copyright && \
 		sed -e 's/^./  &/' < $$subdir/COPYING >> debian/copyright \
 	|| exit; done
-
diff --git a/debian/source/format b/debian/source/format
index d3827e7..89ae9db 100644
--- a/debian/source/format
+++ b/debian/source/format
@@ -1 +1 @@
-1.0
+3.0 (native)

Publish History

  • 2021-08-19T04:56: Failed to create merge proposal: branch-rate-limited (Unexpected HTTP status 429 for https://salsa.debian.org/xorg-team/app/x11-apps.git/info/refs?service=git-upload-pack: Unable to handle http code: Too Many Requests)

Resulting package

The resulting binary packages can be installed (if you have the apt repository enabled) by running one of:

apt install -t unstable x11-apps-dbgsym
apt install -t unstable x11-apps

Lintian Result

Full worker log Full build log