Codebase list ciftilib / fresh-snapshots/main debian / rules
fresh-snapshots/main

Tree @fresh-snapshots/main (Download .tar.gz)

rules @fresh-snapshots/mainraw · history · blame

#!/usr/bin/make -f

# Uncomment this to turn on verbose mode.
#export DH_VERBOSE = 1

export DEB_BUILD_MAINT_OPTIONS = hardening=+all
# Prevent overlinkage with libsigc++-2.0.
export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed

%:
	dh $@

override_dh_auto_configure:
	dh_auto_configure -- -DBUILD_SHARED_LIBS=ON -DIGNORE_QT=ON

override_dh_auto_build-indep:
	dh_auto_build -- doc

override_dh_auto_install-indep:
	echo "DO NOTHING IN dh_auto_install in binary independent package since this only has docs"

override_dh_install-indep:
	echo "DO NOTHING IN dh_install in binary independent package since this only has docs"

override_dh_installdocs-indep:
	dh_installdocs --indep
	dh_doxygen --indep

override_dh_compress-indep:
	dh_compress --indep --exclude=examples

override_dh_auto_test-indep:
	echo "Do not run test suite for arch indep builds"

override_dh_auto_test-arch:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
	dh_auto_test --no-parallel
endif