Correct VCS-*; fix AutoPkgTest; add dep on ctdopts
Michael R. Crusoe
5 years ago
|
0 |
ctdconverter (2.0-2) unstable; urgency=medium
|
|
1 |
|
|
2 |
* Update VCS-*
|
|
3 |
* fix AutoPkgTests
|
|
4 |
* Add missing dependency on ctdopts
|
|
5 |
|
|
6 |
-- Michael R. Crusoe <michael.crusoe@gmail.com> Wed, 21 Feb 2018 01:25:52 -0800
|
|
7 |
|
0 | 8 |
ctdconverter (2.0-1) unstable; urgency=medium
|
1 | 9 |
|
2 | 10 |
* Initial release. (Closes: #890755)
|
11 | 11 |
python3-ctdopts,
|
12 | 12 |
help2man
|
13 | 13 |
Standards-Version: 4.1.3
|
14 | |
Vcs-Browser: https://anonscm.debian.org/cgit/debian-med/ctdconverter.git
|
15 | |
Vcs-Git: https://anonscm.debian.org/git/debian-med/ctdconverter.git
|
|
14 |
Vcs-Browser: https://salsa.debian.org/med-team/ctdconverter
|
|
15 |
Vcs-Git: https://salsa.debian.org/med-team/ctdconverter.git
|
16 | 16 |
Homepage: https://github.com/WorkflowConversion/CTDConverter
|
17 | 17 |
X-Python-Version: >= 2.6
|
18 | 18 |
X-Python3-Version: >= 3.2
|
19 | 19 |
+ sys.exit(main())
|
20 | 20 |
--- /dev/null
|
21 | 21 |
+++ ctdconverter/setup.py
|
22 | |
@@ -0,0 +1,171 @@
|
|
22 |
@@ -0,0 +1,170 @@
|
23 | 23 |
+"""A setuptools based setup module.
|
24 | 24 |
+
|
25 | 25 |
+See:
|
|
153 | 153 |
+ #
|
154 | 154 |
+ # For an analysis of "install_requires" vs pip's requirements files see:
|
155 | 155 |
+ # https://packaging.python.org/en/latest/requirements.html
|
156 | |
+ install_requires=['lxml', 'ruamel.yaml'], # Optional
|
157 | |
+ # install_requires=['lxml', 'ctdopts'], # Optional
|
|
156 |
+ install_requires=['lxml', 'ruamel.yaml', 'ctdopts'], # Optional
|
158 | 157 |
+
|
159 | 158 |
+ # List additional groups of dependencies here (e.g. development
|
160 | 159 |
+ # dependencies). Users will be able to install these using the "extras"
|
0 | 0 |
#!/bin/bash
|
1 | 1 |
set -e
|
2 | 2 |
|
3 | |
pkg=#PACKAGENAME#
|
4 | |
|
5 | |
if [ "$AUTOPKGTEST_TMP" = "" ] ; then
|
6 | |
AUTOPKGTEST_TMP=`mktemp -d /tmp/${pkg}-test.XXXXXX`
|
7 | |
trap "rm -rf $AUTOPKGTEST_TMP" 0 INT QUIT ABRT PIPE TERM
|
8 | |
fi
|
9 | |
|
10 | |
cp -a /usr/share/doc/${pkg}/examples/* $AUTOPKGTEST_TMP
|
11 | |
|
12 | |
cd $AUTOPKGTEST_TMP
|
13 | |
|
14 | |
#do_stuff_to_test_package#
|
|
3 |
CTDConverter --help
|