Install helper binaries dpid and dpidc outside $PATH
Closes: #919063
Axel Beckert
4 years ago
3 | 3 |
* Update Vcs-* headers for switch to Salsa.
|
4 | 4 |
* Re-export upstream key minimally; fixes lintian warning
|
5 | 5 |
public-upstream-key-not-minimal.
|
|
6 |
* Patch dpid/Makefile.am to install helper binaries dpid and dpidc
|
|
7 |
outside $PATH. (Closes: #919063)
|
6 | 8 |
|
7 | 9 |
-- Axel Beckert <abe@debian.org> Wed, 16 Jan 2019 19:38:27 +0100
|
8 | 10 |
|
|
0 |
Description: Move helper binaries from /usr/bin/ to /usr/lib/…/dillo/
|
|
1 |
Author: Axel Beckert <abe@debian.org>
|
|
2 |
Bug-Debian: https://bugs.debian.org/919063
|
|
3 |
Forwarded: no
|
|
4 |
|
|
5 |
--- a/dpid/Makefile.am
|
|
6 |
+++ b/dpid/Makefile.am
|
|
7 |
@@ -2,7 +2,7 @@
|
|
8 |
-I$(top_srcdir) \
|
|
9 |
-DDPIDRC_SYS='"$(sysconfdir)/dpidrc"'
|
|
10 |
|
|
11 |
-bin_PROGRAMS = dpid dpidc
|
|
12 |
+pkglibexec_PROGRAMS = dpid dpidc
|
|
13 |
dpid_LDADD = \
|
|
14 |
$(top_builddir)/dpip/libDpip.a \
|
|
15 |
$(top_builddir)/dlib/libDlib.a
|
|
16 |
--- a/src/IO/Makefile.am
|
|
17 |
+++ b/src/IO/Makefile.am
|
|
18 |
@@ -1,6 +1,6 @@
|
|
19 |
AM_CPPFLAGS = \
|
|
20 |
-I$(top_srcdir) \
|
|
21 |
- -DDILLO_BINDIR='"$(bindir)/"'
|
|
22 |
+ -DDILLO_BINDIR='"$(pkglibexecdir)/"'
|
|
23 |
AM_CFLAGS = @LIBFLTK_CFLAGS@
|
|
24 |
AM_CXXFLAGS = @LIBFLTK_CXXFLAGS@
|
|
25 |
|
0 | 0 |
fix-OpenSSL-1.1-detection.patch
|
|
1 |
move-helper-tools-to-libexec.patch
|