Codebase list findbugs / 8b5f5a6a-4567-4778-8d25-b7d50e31a25b/main debian / patches / 0016-dom4j2-compatibility.patch
8b5f5a6a-4567-4778-8d25-b7d50e31a25b/main

Tree @8b5f5a6a-4567-4778-8d25-b7d50e31a25b/main (Download .tar.gz)

0016-dom4j2-compatibility.patch @8b5f5a6a-4567-4778-8d25-b7d50e31a25b/mainraw · history · blame

Description: Fixes the compatibility with dom4j 2.x
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: no
--- a/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
+++ b/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
@@ -30,7 +30,7 @@
 
     @SuppressWarnings("unchecked")
     public static <T> List<T> selectNodes(Node node, String arg0) {
-        return node.selectNodes(arg0);
+        return (List) node.selectNodes(arg0);
     }
 
 }