Codebase list findbugs / 915e2fc debian / patches / bcel-package.diff
915e2fc

Tree @915e2fc (Download .tar.gz)

bcel-package.diff @915e2fcraw · history · blame

Index: findbugs/build.xml
===================================================================
--- findbugs.orig/build.xml	2013-08-29 17:12:15.000000000 +0200
+++ findbugs/build.xml	2013-08-29 17:26:47.000000000 +0200
@@ -143,7 +143,7 @@
 
     <!-- Compile Java source files, and copy other files (properties,
         images, html, XSL stylesheets) that need to be part of the codebase. -->
-    <target name="classes" depends="init">
+    <target name="classes" depends="init, build-patchbcel">
 
         <!-- Compile Java source files. -->
         <echo level="info" message="compiling findbugs"/>
@@ -1288,12 +1288,14 @@
     <target name="patchbcel">
         <delete dir="${build.dir}/bcel-5.2-src"/>
         <delete file="${build.dir}/bcel-5.2-src.zip"/>
-        <get src="http://www.apache.org/dist/jakarta/bcel/source/bcel-5.2-src.zip"
+        <get src="http://archive.apache.org/dist/jakarta/bcel/source/bcel-5.2-src.zip"
              dest="${build.dir}/bcel-5.2-src.zip"
          verbose="on"/>
         <unzip src="${build.dir}/bcel-5.2-src.zip" dest="${build.dir}/bcel-5.2-src"/>
         <delete file="${build.dir}/bcel-5.2-src/bcel-5.2/build.xml"/>
         <patch patchfile="${patch.dir}/bcel.diff" dir="${build.dir}/bcel-5.2-src/bcel-5.2" strip="7"/>
+    </target>
+    <target name="build-patchbcel">
         <ant dir="${build.dir}/bcel-5.2-src/bcel-5.2" inheritAll="false"/>
         <copy file="${build.dir}/bcel-5.2-src/bcel-5.2/bcel.jar" tofile="${jar.dir}/bcel.jar"/>
     </target>