Codebase list findbugs / 9e04488b-3d21-4a08-a5d7-e262c5b28cbf/main debian / patches / 0011-typecast.patch
9e04488b-3d21-4a08-a5d7-e262c5b28cbf/main

Tree @9e04488b-3d21-4a08-a5d7-e262c5b28cbf/main (Download .tar.gz)

0011-typecast.patch @9e04488b-3d21-4a08-a5d7-e262c5b28cbf/mainraw · history · blame

--- a/src/java/edu/umd/cs/findbugs/detect/CheckRelaxingNullnessAnnotation.java
+++ b/src/java/edu/umd/cs/findbugs/detect/CheckRelaxingNullnessAnnotation.java
@@ -202,7 +202,8 @@
                         bug.addClassAndMethod(xmethod);
                         LocalVariableAnnotation lva = null;
                         if (localVariables != null) {
-                            for(LocalVariableNode lvn : localVariables) {
+                            for(Object obj : localVariables) {
+                                LocalVariableNode lvn = (LocalVariableNode)obj;
                                 if (lvn.index == i+1) {
                                     lva = new LocalVariableAnnotation(lvn.name, i+1, 0);
                                     lva.setDescription(LocalVariableAnnotation.PARAMETER_NAMED_ROLE);