Codebase list findbugs / 9e04488b-3d21-4a08-a5d7-e262c5b28cbf/main debian / patches / 0016-dom4j2-compatibility.patch
9e04488b-3d21-4a08-a5d7-e262c5b28cbf/main

Tree @9e04488b-3d21-4a08-a5d7-e262c5b28cbf/main (Download .tar.gz)

0016-dom4j2-compatibility.patch @9e04488b-3d21-4a08-a5d7-e262c5b28cbf/mainraw · history · blame

Description: Fixes the compatibility with dom4j 2.x
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: no
--- a/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
+++ b/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
@@ -30,7 +30,7 @@
 
     @SuppressWarnings("unchecked")
     public static <T> List<T> selectNodes(Node node, String arg0) {
-        return node.selectNodes(arg0);
+        return (List) node.selectNodes(arg0);
     }
 
 }