Codebase list findbugs / aa72aff debian / rules
aa72aff

Tree @aa72aff (Download .tar.gz)

rules @aa72affraw · history · blame

#!/usr/bin/make -f
# -*- makefile -*-

# Uncomment this to turn on verbose mode.
export DH_VERBOSE=1
#JAVA_HOME = /usr/lib/jvm/default-java

%:
	dh $@ --with maven_repo_helper

override_dh_auto_build:
	ant docs build -Dant.java.version=1.8

	# prepare findbugs.1
	help2man -h "-help"   -v "-version" -n "Static Java Code Analyzer" ./bin/fb       -o debian/fb.1
	help2man -h "-textui" -v "-version" -n "Static Java Code Analyzer" ./bin/findbugs -o debian/findbugs.1

override_dh_auto_install:
	chmod -x $(CURDIR)/bin/findbugs.ico

	mkdir -p $(CURDIR)/debian/findbugs/usr/bin

	dh_install --sourcedir=$(CURDIR)
	dh_link

	mh_installpom -plibfindbugs-annotations-java debian/poms/findbugs-annotations.pom
	mh_installjar -plibfindbugs-annotations-java debian/poms/findbugs-annotations.pom \
		--usj-name=findbugs-annotations -l lib/annotations.jar

override_dh_auto_clean:
	rm -f $(CURDIR)/debian/findbugs.1 $(CURDIR)/debian/fb.1
	rm -f lib/*.jar
	rm -rf classesEclipse/
	rm -f src/doc/allBugDescriptions.html src/doc/bugDescriptions.html src/doc/bugDescriptions_??.html
	dh_auto_clean

override_dh_auto_test:
	ant test -Dant.java.version=1.8
	dh_auto_test