Codebase list findbugs / acc93016-b974-4c55-bb05-a11ff0adc893/main debian / patches / 0016-dom4j2-compatibility.patch
acc93016-b974-4c55-bb05-a11ff0adc893/main

Tree @acc93016-b974-4c55-bb05-a11ff0adc893/main (Download .tar.gz)

0016-dom4j2-compatibility.patch @acc93016-b974-4c55-bb05-a11ff0adc893/mainraw · history · blame

Description: Fixes the compatibility with dom4j 2.x
Author: Emmanuel Bourg <ebourg@apache.org>
Forwarded: no
--- a/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
+++ b/src/java/edu/umd/cs/findbugs/xml/XMLUtil.java
@@ -30,7 +30,7 @@
 
     @SuppressWarnings("unchecked")
     public static <T> List<T> selectNodes(Node node, String arg0) {
-        return node.selectNodes(arg0);
+        return (List) node.selectNodes(arg0);
     }
 
 }